Excel 2013
Student’s Course Book
# Table of Contents

## Program Fundamentals
- Starting Excel 2013 ................................................................. 7
- What’s New in Excel 2013 .......................................................... 8
- Understanding the Excel Program Screen ............................... 10
- Giving Commands ................................................................. 11
- Using Command Shortcuts ..................................................... 14
- Creating a New Workbook .................................................... 16
- Opening a Workbook ........................................................... 18
- Previewing and Printing a Worksheet ................................... 19
- Saving a Workbook ............................................................. 20
- Closing a Workbook ............................................................ 23
- Using Help ............................................................................ 24
- Exiting Excel ......................................................................... 26

## Program Fundamentals Review ........................................... 27

## Getting Started with Worksheets
- Navigating a Worksheet ........................................................ 31
- Entering Labels and Values .................................................... 32
- Selecting a Cell Range and Entering Data in a Cell Range .... 33
- Overview of Formulas and Cell References ......................... 34
- Entering Formulas ............................................................... 35
- Entering Content Automatically ........................................... 37
- Referencing External Data .................................................... 39

## Getting Started with Worksheets Review ........................... 41

## Editing a Worksheet
- Editing Cell Contents ............................................................ 44
- Copying and Moving Cells .................................................... 45
- Controlling How Cells Are Moved or Copied ................. 47
- Collecting Items to Move or Copy ........................................ 49
- Checking Spelling ............................................................... 50
- Inserting Cells, Rows, and Columns ................................. 52
- Deleting Cells, Rows, and Columns .................................... 53
- Using Undo and Redo .......................................................... 54
- Finding and Replacing Content ........................................... 55
- Adding Comments to Cells ................................................ 57
- Tracking Changes .............................................................. 59

## Editing a Worksheet Review .................................................. 61

## Formatting a Worksheet
- Formatting Text ..................................................................... 64
- Formatting Values ................................................................ 65
- Adjusting Row Height and Column Width ......................... 66
- Working with Cell Alignment .............................................. 67
- Adding Cell Borders and Background Colors .................... 68
- Copying Formatting ............................................................ 70
- Applying and Removing Cell Styles .................................... 71
- Creating and Modifying Cell Styles .................................... 72
- Using Document Themes ..................................................... 74
- Applying Conditional Formatting ....................................... 76
- Creating and Managing Conditional Formatting Rules .... 78
- Finding and Replacing Formatting ........................................ 80

## Formatting a Worksheet Review ........................................... 81
Creating and Working with Charts ........................................................................................................................... 84
Choosing and Selecting the Source Data ........................................................................................................................... 86
Choosing the Right Chart .............................................................................................................................................. 88
Editing, Adding, and Removing Chart Data ...................................................................................................................... 91
Changing Chart Data .................................................................................................................................................... 93
Changing Chart Layout and Style ....................................................................................................................................... 96
Working with Chart Labels .............................................................................................................................................. 97
Changing the Chart Gridlines ........................................................................................................................................ 99
Changing the Scale ...................................................................................................................................................... 100
Emphasizing Data ........................................................................................................................................................ 102
Using Chart Templates ............................................................................................................................................ 105
Changing Chart Type ................................................................................................................................................ 106
Using Power View ...................................................................................................................................................... 107
Using Sparklines ....................................................................................................................................................... 108

Creating and Working with Charts Review .................................................................................................................. 109

Managing Workbooks .................................................................................................................................................... 111
Using Workbook Views ........................................................................................................................................... 113
Selecting and Switching Between Worksheets ............................................................................................................... 115
Inserting and Deleting Worksheets .................................................................................................................................... 116
Renaming, Moving, and Copying Worksheets ................................................................................................................ 117
Splitting and Freezing a Window ...................................................................................................................................... 119
Creating Headers and Footers ......................................................................................................................................... 121
Hiding Rows, Columns, Worksheets, and Windows ......................................................................................................... 123
Setting the Print Area ................................................................................................................................................... 125
Adjusting Page Margins and Orientation ........................................................................................................................ 127
Adding Print Titles, Gridlines, and Row and Column Headings ......................................................................................... 128
Adjusting Paper Size and Print Scale ................................................................................................................................ 130
Printing a Selection, Multiple Worksheets, and Workbooks ............................................................................................. 131
Working with Multiple Workbook Windows .................................................................................................................. 132
Creating a Template ................................................................................................................................................/assets
Protecting a Workbook ................................................................................................................................................... 135
Protecting Worksheets and Worksheet Elements ........................................................................................................... 137
Sharing a Workbook ................................................................................................................................................... 139
Online Collaboration ........................................................................................................................................................ 141

Managing Workbooks Review ........................................................................................................................................ 143

More Functions and Formulas ........................................................................................................................................ 146
Formulas with Multiple Operators ..................................................................................................................................... 147
New Functions ................................................................................................................................................................. 148
Inserting and Editing a Function ......................................................................................................................................... 150
AutoCalculate and Manual Calculation .......................................................................................................................... 152
Defining Names .............................................................................................................................................................. 154
Using and Managing Defined Names ................................................................................................................................ 156
Displaying and Tracing Formulas ...................................................................................................................................... 158
Understanding Formula Errors .......................................................................................................................................... 160
Using Logical Functions (IF) ............................................................................................................................................... 162
Using Financial Functions (PMT) ...................................................................................................................................... 163
Using Database Functions (DSUM) .................................................................................................................................... 164
Using Lookup Functions (VLOOKUP) .................................................................................................................................. 165
User Defined and Compatibility Functions ........................................................................................................................ 166
Financial Functions .......................................................................................................................................................... 167
Date & Time Functions ................................................................................................................................................... 168
Math & Trig Functions .................................................................................................................................................... 170
Statistical Functions ........................................................................................................................................................ 172
Lookup & Reference Functions ....................................................................................................................................... 173

© 2013 CustomGuide, Inc.
Microsoft Excel is a powerful spreadsheet program that allows quick and accurate numerical calculations and helps make data look sharp and professional. The uses for Excel are limitless: businesses use Excel for creating financial reports, scientists use Excel for statistical analysis, and families use Excel to help manage their investment portfolios.

Excel 2013 has gone through a major redesign from 2010 or earlier. Much of the program’s functionality is the same, but a completely new user interface and many new features have been added to make using Excel more efficient.

This chapter is an introduction to working with Excel. Learn about the main parts of the program screen, how to give commands, use help, and about new features in Excel 2013.
Starting Excel 2013

In order to use a program, start—or launch—it first.

Windows Vista and Windows 7

1. Click the Start button.
   The Start menu appears.

2. Click All Programs.
   The left pane of the Start menu displays the programs and menus installed on the computer.

3. Click Microsoft Office 2013.

   The Excel 2013 program screen appears.

   Other Ways to Launch a Program:
   Click the Start button and type the program name in the Search box. Click the program in the search results to launch it.

Tips

✓ If using Excel 2013 frequently, consider pinning it to the Start menu. To do this, right-click Microsoft Office Excel 2013 in the All Programs menu and select Pin to Start Menu.

   Windows 8 users can also pin a program to the taskbar. To do this, right-click the Excel button in the taskbar and select Pin this program to taskbar from the contextual menu.

Exercise

- Exercise File: None required.
- Exercise: Start the Microsoft Office Excel 2013 program.

Figure 1-1: The All Programs menu in Windows 8.
What’s New in Excel 2013

Excel 2013 is very different from previous versions. The table below gives an overview of what to expect.

<table>
<thead>
<tr>
<th>Table 1-1: What’s New in Excel 2013</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Customizable Ribbon</strong></td>
</tr>
<tr>
<td><strong>Backstage View</strong></td>
</tr>
<tr>
<td><strong>Workbook Management</strong></td>
</tr>
<tr>
<td><strong>Paste with Live Preview</strong></td>
</tr>
<tr>
<td><strong>More Themes and Styles</strong></td>
</tr>
<tr>
<td><strong>Improved Picture-Editing Tools</strong></td>
</tr>
<tr>
<td><strong>Accessibility Checker</strong></td>
</tr>
<tr>
<td><strong>Language Tools</strong></td>
</tr>
<tr>
<td><strong>Better conditional formatting</strong></td>
</tr>
<tr>
<td><strong>Improved charts</strong></td>
</tr>
<tr>
<td><strong>Improved PivotTables</strong></td>
</tr>
<tr>
<td><strong>Improved functions</strong></td>
</tr>
<tr>
<td><strong>Improved filtering</strong></td>
</tr>
<tr>
<td><strong>Equations in text boxes</strong></td>
</tr>
</tbody>
</table>

**Exercise**

- **Exercise File**: None required.
- **Exercise**: Review the new features in Microsoft Office Excel 2013.
Understanding the Excel Program Screen

This lesson covers the Excel 2013 program screen as well as the new user interface.

- **File tab**: Contains basic file management commands—such as New, Open, Save, and Close—and program options.
- **Quick Access Toolbar**: Contains common commands such as Save and Undo. Add more commands if needed, as well.
- **Title bar**: Displays the name of the workbook currently being worked on and the name of the program being used.
- **Close button**: Click the close button in the Title bar to exit the Excel program entirely.
- **Ribbon**: The tabs and groups on the Ribbon replace the menus and toolbars found in previous versions of Excel.
- **Scroll bars**: Use the vertical and horizontal scroll bars to view different parts of the worksheet.
- **Zoom slider**: Click and drag the slider to zoom in or out of a window. Use the + and – buttons, as well, if desired.
- **View buttons**: Use these buttons to quickly switch between Normal, Page Layout, and Page Break Preview views.
- **Worksheet tabs**: Workbooks have three worksheets by default. Move from one worksheet to another by clicking the worksheet tabs.
- **Status bar**: Displays messages and feedback on the current state of Excel. Right-click the status bar to configure it.
- **Name box**: Displays the active cell address or object name. Click the list arrow to enter formulas.
- **Row and column headings**: Cells are organized and referenced by row and column headings (for example, cell A1).
- **Active cell**: Enter or edit data in the active cell.
- **Formula Bar**: View, enter, and edit data in the active cell. Displays values or formulas in the cell.
Giving Commands

Excel 2013 provides easy access to commands through the Ribbon. The Ribbon keeps commands visible while working instead of hiding them under menus or toolbars.

Backstage view

By clicking on the File tab, you are taken to Backstage View. There have been a few changes to it since Office 2010, which are shown in Table 1-2: Backstage View Commands.

**Exercise**

- **Exercise File:** None required.
- **Exercise:** Look at the options available in Backstage view. Return to the Ribbon view and click each tab on the Ribbon to view its commands. Collapse and Show the Ribbon.

---

![Figure 1-2: Clicking the File tab will display the Backstage view for your document.](image)

**Table 1-2: Backstage View Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save</td>
<td>Save changes made to the file.</td>
</tr>
<tr>
<td>Save As</td>
<td>Save the file under a different name or location.</td>
</tr>
<tr>
<td>Open</td>
<td>Open another file.</td>
</tr>
<tr>
<td>Close</td>
<td>Close the current file.</td>
</tr>
</tbody>
</table>
| Info    | **Excel, PowerPoint, and Word:** Change document protection settings, prepare the document for sharing and view document properties, and manage versions of the file.  
**Outlook:** View account settings, set Automatic replies (Out of Office Manager), cleanup your mailbox, and create and manage rules and alerts. |
| Recent  | Displays a list of documents that have been opened or worked on recently. |
| New     | Create a new blank document or a document from a template. |
| Print   | Preview and print the current document. |
| Share   | Save the file to the Web, publish it to a SharePoint web site or as a blog post; email it to others or invite them to collaborate on it. |
| Export  | Convert the file to a PDF or EXP document. Or save it as another file type. |
| Options | Customize how the program saves, displays, and proofs documents by setting program options. |
| Account | View your Office.com account details. |
Program Fundamentals

**Ribbon**

The Ribbon is made up of three basic components: tabs, groups, and buttons. It is the primary way to give commands in Excel.

**Tabs:** Commands are organized into *tabs* on the Ribbon. Each tab contains a different set of commands. There are different types of tabs:

- **Command tabs:** These tabs appear by default whenever the Excel program is opened. In Excel 2013, the Home, Insert, Page Layout, Formulas, Data, Review, and View tabs appear by default.

- **Contextual tabs:** Contextual tabs appear whenever a specific task is performed, or when a specific object is selected. The tabs offer commands relative to only that object or task. For example, whenever an image is selected, the Picture Tools tab appears on the Ribbon.

**Groups:** The commands found on each tab are organized into *groups* of related commands. For example, the Font group contains commands used for formatting fonts. Click the Dialog Box Launcher ((locations) in the bottom-right corner of a group to display even more commands. Some groups also contain galleries that display several formatting options.

**Trap:** Based on the size of the program window, Excel changes the appearance and layout of the commands within the groups.

**Buttons:** One way to issue a command is by clicking its *button* on the Ribbon. Buttons are the smallest element of the Ribbon. Click a button to give a command.
Program Fundamentals

Changing the Ribbon Display

To make working in an application easier, you can choose the way in which the Ribbon is displayed to better suit your needs.

1. Click the Ribbon Display Options button on the top right of the application. You will have three options:
   - **Show Tabs and Commands**: This is the default view, and the entire Ribbon is displayed
   - **Show Tabs**: Collapse the Ribbon and only the tabs are displayed
   - **Auto-hide Ribbon**: The application is placed into full screen mode and the Ribbon is completely hidden

2. Select the option you wish to use.
   The Ribbon is displayed in the view you selected.

Another way to Change the Ribbon Display:
Double-click the currently displayed command tab. Or, right-click a Ribbon tab and select **Collapse the Ribbon** from the contextual menu. To display the Ribbon again temporarily, click any tab. Right-click a tab and deselect **Collapse the Ribbon** to permanently expand the Ribbon.

Quick Access Toolbar

The Quick Access Toolbar appears above the File tab and provides easy access to the commands used most frequently. By default, the Save, Undo, and Redo buttons appear on the toolbar; customize this toolbar if necessary by adding or removing buttons.

Using Touch Mode

Office 2013 is now Touch Mode Optimized, which means that you can switch Excel to Touch Mode to view, navigate and work in it with ease on any touch enabled device.

1. Click the Customize Quick Access Toolbar list arrow and select **Touch/Mouse Mode** from the list of options.

You will now be able to toggle between Mouse and Touch Mode by clicking the Touch/Mouse Mode button on your Quick Access Toolbar.
Using Command Shortcuts

Command shortcuts provide other ways to give commands in Excel. Shortcuts can be a time-saving and efficient alternative to the Ribbon. Use shortcuts for the commands used most frequently.

Keystroke shortcuts

Without a doubt, keystroke shortcuts are the fastest way to give commands in Excel. They’re especially great for issuing common commands, such as saving a workbook.

In order to issue a command using a keystroke shortcut, simply press a combination of keys on the keyboard. For example, rather than clicking the Copy button on the Ribbon to copy a cell, press and hold the copy keystroke shortcut, <Ctrl> + <C>.

Contextual menus

A contextual menu displays a list of commands related to a specific object or area. To open a contextual menu:

1. Right-click an object or area of the worksheet or program screen.
   A contextual menu appears, displaying commands that are relevant to the object or area right-clicked.

2. Select an option from the contextual menu, or click anywhere outside the contextual menu to close it without selecting anything.

Mini Toolbar

The Mini Toolbar appears when text or data within a cell or the formula bar is selected, and contains common text formatting commands.

1. Select text or data within a cell or the formula bar.

   Trap: Sometimes the Mini Toolbar can be hard to see due to its transparency. To make the Mini Toolbar more visible, point to it.

   Tip: To close the Mini Toolbar while text is still selected, press <Esc>.

2. Click a button on the Mini Toolbar.

   The command is given in Excel.

Tips

✔ To make the Mini Toolbar not appear every time text is selected, click the File tab and click Options. Click the Personalize category, uncheck the Show Mini Toolbar on selection check box, and click OK.

<table>
<thead>
<tr>
<th>Table 1-3: Common Keystroke Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Ctrl&gt; + &lt;O&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;N&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;S&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;P&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;B&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;I&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;C&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;X&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;V&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;Home&gt;</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;End&gt;</td>
</tr>
</tbody>
</table>

Exercise

- Exercise File: None required.
- Exercise: Memorize some common keystroke shortcuts.

Open a contextual menu in the main part of the program window.

![A contextual menu.](image1.png)

![The Mini Toolbar.](image2.png)
**Program Fundamentals**

- A larger version of the Mini Toolbar and a contextual menu appear when an object or area of the worksheet window is right-clicked.

**Key Tips**

*Key Tips* appear whenever the `<Alt>` key is pressed. Use Key Tips to perform just about any action in Excel, without ever having to use the mouse.

To issue a command using a Key Tip, first press the `<Alt>` key. Tiny letters and numbers, called *badges*, appear on the Quick Access Toolbar, and all of the tabs on the Ribbon. Depending on the tab or command desired, press the letter or number key indicated on the badge. Repeat this step as necessary until the desired command has been issued.

![Figure 1-10: Press the <Alt> key to display Key Tips.](image-url)
Creating a New Workbook

Creating a new workbook is one of the most basic commands in Excel. It’s also helpful to know how to create a new workbook within the application. Create a blank new workbook, such as the one that appears in a new, open Excel file, or create a new workbook based on a template.

Create a new blank workbook

1. Click the File tab on the Ribbon and select New.
   The New tab of Backstage view appears.
2. Click Blank Workbook.
   The new blank workbook immediately appears.

   Other Ways to Create a Blank Workbook:
   Press <Ctrl> + <N>.

Create a workbook from a template

Excel 2013 has a host of new templates to choose from.

1. Click the File tab on the Ribbon and select New.
   The New tab of Backstage view appears. All the available templates are from Office Online. There are four ways to find the template you require:

   • Featured template: Select a template from the default options available and click Create.

   • Suggested searches: Select a category link from the available options under the search bar that matches the theme of the template you require. Select the template closest to your requirement from the available options and click Create.

   • Search for a template: Type a keyword or phrase for the kind of template you require, in the search bar. Select the template closest to your requirement from the available options and click Create.

   • Personal template: Use a template you have created by selecting the Personal link from the menu options above the featured templates. Select the template you wish to use; it will open automatically.

Exercise

• Exercise File: None required.
• Exercise: Create a new blank workbook. Then create a new workbook from a Microsoft Office Online template.

Figure 1-11: The New tab of Backstage view.
Creating a workbook online with your Office account

It's even easier to use Excel when you’re on the go. If you’re connected to the internet, you can sign in to your Office account and use the full version of Excel, without having to install it locally on your PC.

1. Navigate to www.office.com and sign into your account.

2. Under Create new, select the application for the type of document that you want to create.

3. Give your document a name in the box provided and click Create.

4. Once you have completed your document, click the File tab and select Save As.

5. Choose the location that you want to save your document in. Note that for sharing purposes, it’s probably better that you save your file to the Cloud.

Tip: You can also search for, and download templates from your online account by clicking the Templates tab on your Office account.
**Opening a Workbook**

Opening a workbook that was previously created and then saved is a basic step in using that information.

**Open a workbook**

Locate a workbook on the computer and simply double-click it to open it; another option is to open a workbook from within the Excel program.

1. Click the **File** tab and select **Open**.
   
   The Open tab of Backstage view appears. Select a recent workbook, or select a place to open an Excel workbook from.

   🚀 **Other Ways to Open a Workbook:**
   
   Press `<Ctrl>` + `<O>`.

2. Navigate to the location of the saved file.
   
   The Open tab has several controls that make it easy to navigate to locations and find files on the computer by selecting an option in the Places section.

   
   The workbook immediately opens.

✔️ **Tips**

✔️ To open a workbook that has been used recently, click the **File** tab and select a workbook from the Recent Workbooks list.

---

**Exercise**

- **Exercise File:** Sales.xlsx
- **Exercise:** Open a workbook.

![Image](image.png)

**Figure 1-13:** The Open tab in Backstage view. To open a file, select a recent workbook, or select an option in the Places section.
Previewing and Printing a Worksheet

Once a worksheet is created, and the computer is connected to a printer, print a copy. Before doing this, it’s a good idea to preview how it’s going to look.

1. Click the **File** tab on the Ribbon and select **Print**.
   
   Notice that the print settings and a preview of the document appear together.

   **Tip:** Use the scroll bar or the page navigation controls below the preview to view other pages in the document.

   **Other Ways to Preview and Print:**
   
   Press <Ctrl> + <P>.

2. Specify printing options and click the **Print** button.
   
   The document is sent to the printer.

   ![Figure 1-14: The Print settings and Print Preview as shown in Backstage view. Use the print settings in the left column to control how the document is printed. Use the print preview area in the right column to preview how the document will look when printed.](image)

---

**Exercise Notes**

- **Exercise File:** Sales.xlsx
- **Exercise:** Preview and print the worksheet.
Saving a Workbook

After having created a workbook, save it to use it again. Also, if changes are made to a workbook, save it. Another option is to save a copy of an existing workbook with a new name, to a different location, or using a different file type.

Save a new workbook

1. Click the Save button on the Quick Access Toolbar.

2. Click Place or Folder to save where the workbook is.

   The Save As dialog box appears.

Other Ways to Save:
- Press \(<Ctrl> + <S>\). Or, click the File tab and select Save.

The Save As dialog box has several controls that make it easy to navigate to locations on the computer:

- Address bar: Click a location in the Address bar to open it. Click the arrow to the right of a location to view a list of folders within that location. Select a folder from the list to open it.

- Folders List: Shortcuts to common locations on the computer, such as the Desktop and Documents library.

- Search box: This searches the contents—including subfolders—of that window for the text typed. If a file’s name, file content, tags, or other file properties match the searched text, it will appear in the search results. Search results appear as text is entered in the search box.

4. Enter the file name in the File name text box.

5. Click Save.
Save workbook changes

Once changes are made to a workbook that’s been saved before, save it again.

1. Click the Save button on the Quick Access Toolbar.
   Any changes made to the workbook are saved.

   \textbf{Other Ways to Save:}
   Press $\text{Ctrl} + \text{S}$. Or, click the File tab and select Save.

Save a workbook under a different name and/or location

Save another copy of a saved document using a new name or in a new location.

1. Click the File tab and select Save As.
   The Save As dialog box appears.

2. Enter a different name for the file in the File name text box.

3. Click Save.

Save a workbook as a different file type

Just as some people can speak several languages, Excel can read and write in other file formats, making it easier to share information between programs.

1. Click the File tab and select Save As.
   The Save As dialog box appears.

2. Click the Save as type list arrow and select a file format.

3. Click Save.

Saving to the Cloud

If you have access to SkyDrive or another type of cloud-based file hosting service, you can upload your documents to the shared location and grant people access by either giving them the password or setting permissions.

There are two ways to save to a Cloud.

1. Navigate to and click on the File tab.

2. Click Save As.

3. Under Places, select SkyDrive or another Cloud you are subscribed to, sign in and save your document.

\begin{table}[h]
\centering
\caption{Common Excel File Formats}
\begin{tabular}{|l|l|}
\hline
File Type & Description \\
\hline
Excel Workbook (.xlsx) & The default format for Excel 2013 workbooks. \\
\hline
Excel Macro-Enabled Workbook (.xlsm) & This file format supports macros in Excel 2013. \\
\hline
Excel 97-Excel 2003 Workbook (.xls) & Workbooks in this format can be used by all versions of Excel. Does not support XML. \\
\hline
PDF (.pdf) & Use this format for files to be shared, but not to be changed. \\
\hline
Web page (.htm,.html) & This format is used to create Web pages. \\
\hline
XML Data (.xml) & This file type is used exclusively for XML-enabled workbooks. \\
\hline
CSV (.csv) & Use this to share workbook data with other programs or lists, such as databases. \\
\hline
\end{tabular}
\end{table}

Figure 1-17: Save a document to SkyDrive
Program Fundamentals

Or

1. Navigate to and click on the **File** tab.

2. Click **Share**.

3. Select **Invite People**, and in the right-hand pane, click **Save to Cloud**. The file hosting service that you are subscribed to will be listed. Select it and save your document in the location that is relevant.
Closing a Workbook

When work on a workbook is done, close it

1. Click the File tab on the Ribbon and select Close.

   The workbook closes.

💡 Other Ways to Close a Workbook:
Press <Ctrl> + <W>. Or, click the Close button in the upper right corner of the workbook window (do not confuse this with the program Close button on the title bar).

✅ Tip: If multiple workbooks are open, clicking the active workbook’s Close button only closes that one workbook. The other workbooks remain open in the window until their close buttons are clicked as well.

ℹ️ Trap: The Close button located in the title bar closes only the active workbook if there is more than one workbook open. However, if there is only one workbook open, it closes the workbook and exits the Excel program entirely.

Figure 1-18: Closing a workbook.
Using Help

The Excel Help files can answer questions, offer tips, and provide help for all of Excel’s features.

Search for help

1. Click the Microsoft Excel Help button (?) on the Ribbon.
   The Excel Help window appears.
   Other Ways to Open the Help window:
   Press <F1>.

2. Type what to search for in the “Search help” box and press <Enter>.
   A list of help topics appears.

3. Click the topic that best answers the question.
   Excel displays information regarding the selected topic.

Browse for help

1. Click the Microsoft Excel Help button (?) on the Ribbon.

2. Click a category to browse in the Excel Help window.

3. Click the topic that best answers the question.
   Excel displays information regarding the selected topic.

Choose the Help source

If Excel 2013 is connected to the Internet, it retrieves help from the Office Online database by default.

1. Click the Excel Help button list arrow in the window.
   A list of help sources appears.

2. Select an option from the list.

3. Search from that source.
**Tips**

- Office 2013 offers enhanced ScreenTips for many buttons on the Ribbon. Use these ScreenTips to learn more about what a button does and, where available, view a keystroke shortcut for the command. If the message “Press F1 for more help”, appears, press <F1> to get more information relative to that command.

- When working in a dialog box, click the **Help** button (†) in the upper right-hand corner to get help regarding the commands in the dialog box.

---

**Table 1-5: Help buttons**

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Back" /></td>
<td>Return to the previous help topic.</td>
</tr>
<tr>
<td><img src="image" alt="Forward" /></td>
<td>Return to move forward to the next help topic after clicking Back.</td>
</tr>
<tr>
<td><img src="image" alt="Home" /></td>
<td>Click here to return to the Help home page.</td>
</tr>
<tr>
<td><img src="image" alt="Print" /></td>
<td>Click here to print the current help topic.</td>
</tr>
<tr>
<td><img src="image" alt="Change Font Size" /></td>
<td>Click here to change the size of the text in the Help window.</td>
</tr>
<tr>
<td><img src="image" alt="Keep On Top" /></td>
<td>Click here to layer the Help window so that it appears behind all other Microsoft Office programs.</td>
</tr>
</tbody>
</table>
Exiting Excel

When finished using Excel 2013, exit it. Exiting a program closes it, until it needs to be used again.

1. Click the File tab and select Close.

2. Click the Exit button.

   The Excel program window closes.

⚠️ Other Ways to Exit Excel:
   If there is only one Excel program window open, click the Close button in the title bar. Or, right-click the Excel button on the taskbar and select Close window from the Jump List.

✅ Tips

✓ Having too many programs open at a time could slow down the computer, so it’s a good idea to exit all programs that aren’t being used.

Figure 1-20: There are two ways to exit Excel.
Quiz Questions

1. Excel automatically opens with Windows. (True or False?)

2. Which of the following is NOT a new feature in Excel 2013?
   A. Backstage view
   B. Improved picture editing
   C. The Ribbon
   D. Paste with Live Preview

3. The Ribbon can be hidden so that only tab names appear. (True or False?)

4. The File tab contains basic file commands. (True or False?)

5. What is the Quick Access Toolbar?
   A. There are no toolbars in Excel 2013.
   B. What appears when text is selected.
   C. A customizable toolbar of common commands that appears above or below the Ribbon.
   D. An extension of the Windows taskbar.

6. You can use Excel 2013 on a Touch enabled device. (True or False?)

7. Which of the following is NOT a common keystroke shortcut in Excel?
   A. <Ctrl> + <Alt> + <Delete>
   B. <Ctrl> + <S>
   C. <Ctrl> + <O>
   D. <Ctrl> + <Home>

8. It is only possible to create a new workbook by launching the Excel program. (True or False?)

9. To open a workbook, click the File tab and select ______.
   A. Open
   B. Find
   C. Look in
   D. Search

10. Print settings and print preview appear side by side in Backstage view. (True or False?)

11. When saving a workbook with a different name, the old workbook is deleted. (True or False?)
12. Which of the following must you have in order to use a SkyDrive account:
   A. An external hard drive.
   B. A Microsoft account
   C. An Office 365 account
   D. B or C.

13. Close a workbook which one of the following ways?
   A. Press <Ctrl> + <C>.
   B. Click and drag the workbook window to the Recycle Bin.
   C. Click the workbook’s Close button.
   D. Press <Delete>.

14. What key is pressed to get help in Excel?
   A. <Esc>
   B. <Ctrl> + <H>
   C. <F1>
   D. <F11>

15. Which of the following are ways to exit Excel? (Select all that apply.)
   A. Click the File tab and click Exit Excel.
   B. Click the Office Button and click Close Excel.
   C. Click the Close button on the title bar.
   D. Click the Close button on the Quick Access Toolbar.
Quiz Answers

1. False. Start Excel to begin using it.

2. C. The Ribbon was introduced in Excel 2007, so it is not new in Excel 2013. It has been improved, however, so that it is possible to customize tabs and groups on the Ribbon.

3. True. Double-click a tab to hide the Ribbon, then click any tab to view commands once again.

4. True. The File tab contains basic file commands, similar to the File menu of previous versions.

5. True. By activating Touch mode in Excel, you are able to use the application on any Touch enabled device.

6. A. <Ctrl> + <Alt> + <Delete> is a Windows command, not an Excel command.

7. False. It's true that a new workbook appears automatically when an Excel workbook is opened. However, that is not the only way to create a new workbook.

8. A. Select Open and then navigate to the saved file to open it.


10. False. The original workbook remains intact, with its original name.

11. B or C. As long as you have a Microsoft account (XBoxLive, Outlook.com) or an organizational account through Office 365, you will be able to utilize the SkyDrive.

12. C. Click the Close button or press <Ctrl> + <W> to close a workbook.

13. C. Press <F1> to access help in Excel.

14. A and C. Click the File tab and click Exit, or click the Close button on the title bar.
Getting Started with Worksheets

Navigating a Worksheet .................................... 31
Entering Labels and Values .............................. 32
Selecting a Cell Range ................................. 33
Overview of Formulas .................................... 34
Entering Formulas .......................................... 35
Entering Content Automatically ....................... 37

This chapter will demonstrate the most basic tasks in Excel: entering labels and numbers, and entering formulas.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Navigating a Worksheet

Before entering data into a worksheet, it’s best to learn how to move around in one. Make a cell active by selecting it before entering information in it. Make a cell active by using:

- **The Mouse:** Click any cell with the white cross pointer.

- **The Keyboard:** Move the cell pointer using the keyboard’s arrow keys.

To help navigate in a worksheet, Excel displays row headings, identified by numbers, on the left side of the worksheet, and column headings, identified by letters, at the top of the worksheet. Each cell in a worksheet has its own cell address made from its column letter and row number—such as cell A1, A2, B1, B2, etc. Find the address of a cell immediately by looking at the Name Box, which shows the current cell address.

1. Click any cell to make it active.
   The cell address appears in the name box.
   Try using the keyboard, after becoming familiar with moving the cell pointer with the mouse.

2. Press `<Tab>`.
   The active cell is one cell to the right of the previous cell. Refer to Table 2-1: Navigation Shortcuts for more information on navigating shortcuts.

**Tips**

- Excel 2013 worksheets have 1,048,576 rows and 16,384 columns! To view the off-screen portions of the worksheet, use the scroll bars.

- Using the `<Ctrl>` key with arrow keys is very powerful. These key combinations jump to the edges of data. For example, a group of data in columns A-G and another group in columns R-Z, `<Ctrl>` + `<→>` jumps between each group of data.

<table>
<thead>
<tr>
<th>Press</th>
<th>To Move</th>
</tr>
</thead>
<tbody>
<tr>
<td>→ or <code>&lt;Tab&gt;</code></td>
<td>One cell to the right.</td>
</tr>
<tr>
<td>← or <code>&lt;Shift&gt;</code> + <code>&lt;Tab&gt;</code></td>
<td>One cell to the left.</td>
</tr>
<tr>
<td>↑ or <code>&lt;Shift&gt;</code> + <code>&lt;Enter&gt;</code></td>
<td>One cell up.</td>
</tr>
<tr>
<td>↓ or <code>&lt;Enter&gt;</code></td>
<td>One cell down.</td>
</tr>
<tr>
<td><code>&lt;Home&gt;</code></td>
<td>To column A in the current row.</td>
</tr>
<tr>
<td><code>&lt;Ctrl&gt;</code> + <code>&lt;Home&gt;</code></td>
<td>To the first cell (A1) in the worksheet.</td>
</tr>
<tr>
<td><code>&lt;Ctrl&gt;</code> + <code>&lt;End&gt;</code></td>
<td>To the last cell with data in the worksheet.</td>
</tr>
<tr>
<td><code>&lt;Page Up&gt;</code></td>
<td>Up one screen.</td>
</tr>
<tr>
<td><code>&lt;Page Down&gt;</code></td>
<td>Down one screen.</td>
</tr>
<tr>
<td><code>&lt;F5&gt;</code> or <code>&lt;Ctrl&gt;</code> + <code>&lt;G&gt;</code></td>
<td>Opens the Go To dialog box where it’s possible to go to a specific cell address.</td>
</tr>
</tbody>
</table>
Entering Labels and Values

There are two basic types of information that can be entered in a cell:

- **Labels**: Any information not used in calculations. Labels are used for headings in columns and rows, and as data in columns and rows. Excel treats cell data containing letters or non-numerical punctuation as text and automatically left-aligns it inside the cell.

- **Values**: Numerical data, including: numbers, percentages, fractions, currencies, dates, or times, usually used in formulas or calculations. Excel treats information that contains numbers, dates or times as a value and automatically right-aligns it in the cell.

Excel even treats dates as values, makes it possible to perform calculations and formulas on the labels. For example, subtract one date from another to find how many days are between them. It’s also possible to control how dates appear with cell formatting.

1. Select the cell to enter data in it.
2. Type the data in the cell.
3. Press the <Enter> or <Tab> key.

The cell entry is confirmed and the next cell becomes active.

⚠️ **Other Ways to Confirm a Cell Entry:**

Click the Enter button on the Formula Bar.

If the contents do not fit in the cell, the text spills into the empty cell to the right. If that cell is not empty, Excel truncates the data so only part of it is visible.

✅ **Tips**

- Start a label with a number, type an apostrophe at the beginning of the label. This tells Excel that the cell contents are a label, not a value.

- AutoComplete can help enter labels. Enter the first few characters of a label; Excel displays the label if it appeared previously in the column. Press <Enter> to accept the entry or resume typing to ignore the suggestion.

- Reformat dates after entering them. For example, 4/4/12 can easily be reformatted to April 4, 2012. This is covered in another lesson.
Selecting a Cell Range and Entering Data in a Cell Range

Selecting a cell range

To work with a range of cells, it’s important to know how to select multiple cells.

1. Click to select the first cell in the cell range and hold the mouse button.

2. Drag to select multiple cells.
   As the mouse is dragged, the selected cells are highlighted.

3. Release the mouse button.
   The cell range is selected.

Other Ways to Select a Cell Range:
Select the first cell of the cell range. Press and hold the <Shift> key and select the last cell of the cell range.

Tips
✓ To select all the cells in a worksheet, click the Select All button where the row and column headers come together, or press <Ctrl> + <A>.
✓ To select multiple non-adjacent cells, select a cell or cell range and hold down the <Ctrl> key while selecting other cells.

Entering data in a cell range

When entering a lot of data, selecting the range makes data entry easier and faster. Selecting a range of cells restricts the cell pointer so it can only move inside the selected range.

1. Select the range of cells to enter the data in.

2. Enter the data in the first cell. Press <Tab> or <Enter> to move on to the next cell.
   When the active cell reaches the end of a column or row, the next time <Tab> or <Enter> is pressed, the cell pointer moves to the next cell in the selected range.

3. Click any cell in the worksheet to deselect the range.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sales and Expenses</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Jan</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Sales</td>
<td>12000</td>
<td>17000</td>
<td>16500</td>
<td>15500</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>7000</td>
<td>400</td>
<td>400</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Utilities</td>
<td>3000</td>
<td>3000</td>
<td>3000</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 2-3: Entering text in a selected cell range.

Table 2-3: Navigating in a Selected Cell Range

<table>
<thead>
<tr>
<th>Action</th>
<th>Key Combinations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Down</td>
<td>&lt;Enter&gt;</td>
</tr>
<tr>
<td>Up</td>
<td>&lt;Shift&gt; + &lt;Enter&gt;</td>
</tr>
<tr>
<td>Right</td>
<td>&lt;Tab&gt;</td>
</tr>
<tr>
<td>Left</td>
<td>&lt;Shift&gt; + &lt;Tab&gt;</td>
</tr>
</tbody>
</table>
Overview of Formulas and Cell References

This lesson introduces formulas and the different elements required to write a formula.

**Values**

Values are any numerical data entered in a worksheet. Once values are entered in the worksheet, they can be used in formulas.

**Formulas**

Formulas are values, but unlike regular values, formulas contain information to perform a numerical calculation, such as adding, subtracting, or multiplying. A cell with the formula =5+3 will display the result of the calculation: 8.

All formulas must start with an equal sign (=). Then specify more information: the values to calculate and the arithmetic operator(s) or function name(s) to use to calculate the values.

- **Operators** are the basic symbols used in mathematics: + (plus), - (minus), / (divide), * (multiply). In Excel, use these in the same way as writing out a math problem.

- **Functions** are used more often in Excel. Functions are pre-made formulas that are used as shortcuts, or to perform calculations that are more complicated.

**Relative and absolute cell references**

A cell reference tells Excel where to look for values to use in a formula. For example, the formula =A5+A6 adds the values in cells A5 and A6.

Using cell references is advantageous because if the values in the referenced cells are changed, the formula result automatically updates using the new values. There are two types of cell references: relative and absolute.

- **Relative**: Relative references refer to cells in relation to the cell that contains the formula. When the formula is moved, it references new cells based on their location relative to the formula. Relative references are the default type of references in Excel.

- **Absolute**: Absolute references always refer to the same cell, even when the formula is copied. Absolute references are indicated with dollar signs ($A$1) in formulas. Pressing <F4> changes a cell reference to absolute.

- **Exercise Notes**

  - **Exercise File**: None required.
  - **Exercise**: Understand how formulas are used in Excel.
Entering Formulas

A formula starts with an equal sign, followed by

- Values or cell references joined by an operator.
  
  Example: =5+3 or =A1+A2

- A function name followed by parentheses containing function arguments. Functions are the most common way to enter formulas in Excel.
  
  Example: =SUM(A1:A2)

Enter a formula with an operator

1. Click the desired cell to enter a formula.
2. Type =, then type cell references and operators, or enter the formula in the Formula Bar.
3. Press <Enter>.

The formula calculates the result and displays it in the cell where it was entered.

Enter a formula with a function

1. Click the desired cell to enter a formula in.
2. Click the Formulas tab and click the Insert Function button in the Function Library group.
   
   Tip: If the name of the function is known, type it out instead of selecting it from the Function button.

   Other Ways to Enter a Function:
   Click the Insert Function button on the Formula bar.
3. Select a function and click OK.

   The Function Arguments dialog box appears.
4. Enter the function arguments and click OK.

   The result of the formula appears in the cell.

Tips

- Use the Formula AutoComplete feature to help create and edit complex formulas. Type an = (equal sign) in a cell or the Formula Bar and start typing the formula. A list of functions and names that match the text entered appears. Select an item from the list to insert it into the formula.

Exercise Notes

- Exercise File: Sales2-3.xlsx

- Exercise: In cell B11, total the values in B7:B10
  
  In cell G4, multiply F4 by G2, making G2 an absolute cell reference.
  
  In cell G7, multiply F7 by G2, making G2 an absolute cell reference.
  
  In cell C11, AutoSum the column C expense values.

Figure 2-4: Entering a formula in a worksheet.

Table 2-4: Examples of Operators and Functions

<table>
<thead>
<tr>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>All formulas start with an equal sign.</td>
</tr>
<tr>
<td>+</td>
<td>=A1+B1</td>
</tr>
<tr>
<td>-</td>
<td>=A1-B1</td>
</tr>
<tr>
<td>*</td>
<td>=B1*2</td>
</tr>
<tr>
<td>/</td>
<td>=A1/C2</td>
</tr>
<tr>
<td>SUM</td>
<td>=SUM(A1:A3)</td>
</tr>
<tr>
<td>AVERAGE</td>
<td>=AVERAGE(A2,B1,C3)</td>
</tr>
<tr>
<td>COUNT</td>
<td>=COUNT(A2:C3)</td>
</tr>
</tbody>
</table>
Enter an absolute cell reference in a formula

1. Enter the formula using operators or functions.

2. Click the cell to reference and press the <F4> key.
   Dollar signs $ are added to the cell reference in the formula.

Other Ways to Add an Absolute Cell Reference in a Formula:
Type the address of the cell with $ (dollar signs) before every reference heading. (For example, type $B$4).

Total values automatically with AutoSum

Adding up the values in a range of cells is the most popular formula in Excel, so Microsoft has made this easy to do with the AutoSum feature. AutoSum inserts the SUM function (which adds all the values in a range of cells) and selects the range of cells Excel wants totaled.

1. Click a cell next to the column or row of numbers to sum up.
   For example, to add up a column of numbers, click the cell at the bottom of the column. Or, to add up a row of numbers, click the cell to the right of the row.

2. Click the Home tab and click the AutoSum button in the Editing group.
   The SUM function appears in the cell and a moving dotted line appears around the cell range that Excel will sum up.
   **Tip:** Click the AutoSum button list arrow to choose from other common functions, such as Average.

   **Other Ways to Enter AutoSum:**
   Press <Alt> + <=>.

3. Press the <Enter> key to confirm the action.
   The cell range is totaled in the cell.
   **Tip:** If a value in the summed range is changed, the formula will automatically update to show the new sum.
Entering Content Automatically

Since entering data is a major task in Excel, this lesson covers three tools that make data entry very useful: Fill, AutoComplete, and PickList.

Use Fill

Fill is a great way to quickly enter sequential numbers, months or days. Fill looks at cells that have already been filled in and makes a guess about how to fill in the rest of the series. For example, enter January and Fill will fill in the following months.

1. Select a cell or cell range that contains the data and increment desired.
   
   **Tip:** If selecting only one cell, that same value is copied to the adjacent cells when filled—unless Excel recognizes it as a date or time, in which case it will fill in the next logical date or time period.

2. Position the mouse pointer over the fill handle until the pointer changes to a plus sign (+).

3. Click and drag the fill handle to fill in the information in the desired cells.

   **Tip:** While clicking and dragging, a screen tip appears previewing the value that will be entered in the cell once the mouse button is released.

### Table 2-5: Fill Series Examples

<table>
<thead>
<tr>
<th>Selected Cell(s)</th>
<th>Entries in Next Three Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>February, March, April</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Jan</th>
<th>Feb, Mar, Apr</th>
</tr>
</thead>
<tbody>
<tr>
<td>5:00</td>
<td>6:00, 7:00, 8:00</td>
</tr>
<tr>
<td>Qtr. 1</td>
<td>Qtr. 2, Qtr. 3, Qtr. 4</td>
</tr>
<tr>
<td>5</td>
<td>15, 20, 25</td>
</tr>
<tr>
<td>1/20/12</td>
<td>1/21/12, 1/22/12, 1/23/12</td>
</tr>
<tr>
<td>UPV-3592</td>
<td>UPV-3593, UPV-3594, UPV-3595</td>
</tr>
</tbody>
</table>

**Exercise Notes**

- **Exercise File:** Sales2-4.xlsx
- **Exercise:** Fill in the month labels in row 3. Labels should start with Jan in column B and end with Jun in column G.

   Copy the formula in cell G7 to cells G8:G10. Copy the formula in cell C11 over to columns D, E, F, and G.

---

**Exercise Notes**

- **Exercise File:** Sales2-4.xlsx
- **Exercise:** Fill in the month labels in row 3. Labels should start with Jan in column B and end with Jun in column G.

   Copy the formula in cell G7 to cells G8:G10. Copy the formula in cell C11 over to columns D, E, F, and G.

**Figure 2-7:** Fill fills in months after January into the selected cells. Notice that a screen tip previews the content being filled into the cells.

**Figure 2-8:** Formulas that are copied with Fill are updated relative to their location. This formula copied from C11 is updated to use cell references from the D column.
Control fill options

If Fill doesn’t enter cell content the way expected, the content can be corrected using AutoFill Options. This button appears after using the Fill command, and it offers valuable control over how the Fill command works.

1. Enter cell content using Fill.
   After releasing the mouse button, the Fill Options button appears.

2. Click the Fill Options button.
   A list of ways to control the cell content entered appears.

3. Select a fill option from the list.
   The cell content is changed according to the fill option chosen.

Repeat values in a column

Excel’s AutoComplete feature helps speed up data entry, especially if using repetitive information.

1. Type the first few characters of a label.
   Excel displays the label if it appears previously in the column.

2. Press <Enter>.
   Excel accepts the entry.
   If an unwanted suggestion appears, resume typing to ignore the suggestion.

Select contents from a list

The PickList is a list of data already used and helps keep information consistent.

1. Right-click the desired cell and select Pick from Drop-down List from the contextual menu.
   A list appears under the cell.

2. Select an entry from the list that appears under the cell.
   The data is entered and the list disappears.
Referencing External Data

This lesson explains how to create references to cells in other worksheets, and even to cells in other workbook files altogether.

References to cells or cell ranges on other sheets are called external references or links. One of the most common reasons for using external references is to create a worksheet that summarizes the totals from other worksheets. For example, a workbook might contain twelve worksheets—one for each month—and an annual summary worksheet that references and totals the data from each monthly worksheet.

Reference a worksheet in the same workbook

1. Click the desired cell to enter the formula.

2. Type = (an equals sign), and enter any necessary parts of the formula.

3. Type the name of the worksheet that contains the cell or cell range to reference, followed by an exclamation point (!). For example: =Monday!
   
   The Monday refers to the Monday worksheet sheet. The “!” (Exclamation point) is an external reference indicator—it means that the referenced cell is located outside the active sheet.

4. Enter the cell, cell range, or name to reference.

5. Complete the formula as necessary.

   The external reference is entered and figured in the worksheet.

Exercise

• Exercise File: ExternalReferences.xlsx; InternetReservations.xlsx

• Exercise: Open both workbooks.

   Reference worksheets: Navigate to the Summary worksheet in the ExternalReferences workbook. Create references to cell D61 for each day of the week.

   Reference workbooks: Create a reference to cell B8 in Sheet1 of the InternetReservations workbook.

   Use AutoSum to total the cells in cell G4 of the Summary worksheet.

Figure 2-11: An example of external references used in a worksheet.
Reference a worksheet in a different workbook

1. Click the desired cell to enter the formula.
2. Type = (an equals sign), and enter any necessary parts of the formula.
3. Open the workbook to reference.
4. Enter the workbook name in brackets, followed by the worksheet being referenced. For example:
   
   [InternetReservations.xlsx]Sheet1!

   If the workbook being referenced is not open, include the file path for the workbook in the reference. For example:
   
   [C:\My Documents\[InternetReservations.xlsx]Sheet1!

   Tip: Use file names that do not have spaces for best results. If a file name does have spaces, enter the file name without spaces in the external reference in the Excel worksheet.

5. Enter the cell, cell range, or name referenced.
6. Complete the formula.
Getting Started with Worksheets Review

Quiz Questions

1. Press ______ to move the cell pointer one cell to the left.
   A. <Enter>
   B. <Shift> + <Tab>
   C. The up arrow key
   D. <Tab>

2. Which of these statements is false?
   A. Dates are a type of value.
   B. Labels and values are both aligned along the left side of the cell.
   C. Labels can include numbers.
   D. Values include any data that can be used in formulas or calculations.

3. It's possible to select all the cells in a worksheet at once. (True or False?)

4. Why is entering data in a selected cell range advantageous?
   A. The cell pointer recognizes values and labels correctly.
   B. There are no advantages.
   C. This makes it easier to format cell contents.
   D. The cell pointer stays within the selected cell range.

5. All formulas start with:
   A. /
   B. ( 
   C. =
   D. &

6. Relative cell references always refer to the same cell. (True or False?)

7. Which of the following formulas is NOT correctly written?
   A. 5+6
   B. =A2-B3
   C. =A4/A6
   D. =SUM(A1:A6)

8. Use the Fill command to copy a formula to adjacent cells. (True or False?)
Quiz Answers

1. B. Pressing <Shift> + <Tab> moves the cell pointer one cell to the left.

2. B. Labels are aligned on the left side of the cell. Values are aligned along the right side of the cell.

3. True. It's possible to select all cells at once by pressing Ctrl + A.

4. D. Entering data in a selected cell range is advantageous because the cell pointer stays within the selected cell range.

5. C. All formulas start with an equal sign (=).

6. False. Absolute cell references always refer to the same cell.

7. A. 5 + 6 is incorrect because it doesn't begin with an equal sign.

8. True. Use the Fill command to copy formulas to adjacent cells.
This chapter will show how to edit Excel worksheets, by learning how to edit cell contents; cut, copy and paste information; insert and delete columns and rows; undo any mistakes that might have been made; and even correct spelling errors.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Editing Cell Contents

Once data is entered into a cell, it’s possible to edit, clear, or replace those cell contents.

Edit cell contents

1. Double-click to edit a cell.
   
   The cell is in edit mode.
   
   In Edit mode, the arrow keys move from character to character in the cell instead of from cell to cell.

   **Other Ways to Enter Edit Mode:**
   - Select the cell. Click anywhere in the Formula Bar, or press <F2>.

2. Edit the contents of the cell.

3. Press <Enter>.

   **Other Ways to Edit Cell Contents:**
   - Select the cell, then edit the cell’s contents in the Formula Bar and. Press <Enter> or click the Enter button on the Formula bar.

Replace cell contents

1. Select the cell.

2. Enter new data.

3. Press <Enter>.

   The newly typed information replaces the previous cell contents.

Clear cell contents

1. Select the cell.

2. Press <Delete>.

   **Other Ways to Clear Cell Contents:**
   - Under the Home tab on the Ribbon, click the Clear button in the Editing group.

   **Tip:** Note that this clears the cell contents, not the actual cell.

---

**Exercise Notes**

- **Exercise File:** Mileage3-1.xlsx

- **Exercise:** Edit cell A1 so it reads “Mileage Report”. Edit cell B3 so it reads “Destination”. Edit C3 to read “Beginning”. Edit D3 to read “Ending”.

   Clear the contents of cells G3:G10.

   Edit the formula in F4 to use an absolute reference to F2 instead of the value “0.3”.

   Then copy the formula in F4 to F5:F12.

---

**Figure 3-1:** Clearing cell contents.

**Figure 3-2:** Replacing cell contents.
Copying and Moving Cells

Move or copy information in an Excel worksheet by cutting or copying, and then pasting the cell data in a new place.

Tips

- Cut, copy, and paste any item in a worksheet, such as clip art or a picture, in addition to cell data.

Copy cells

When copying a cell, the selected cell data remains in its original location and is added to the Clipboard.

1. Select the cell(s) to copy.
   - **Tip:** To cut or copy only selected parts of a cell’s contents, double-click the cell to display a cursor and select the characters to cut.

2. Click the Home tab on the Ribbon and click the Copy button in the Clipboard group.
   - **Other Ways to Copy Cells:**
     - Press \(<Ctrl>+<C>\). Or, right-click the selection and select Copy from the contextual menu.

3. Select the cell to paste the copied content there.

4. Click the Home tab on the Ribbon and click the Paste button in the Clipboard group.
   - **Other Ways to Paste Cells:**
     - Press \(<Ctrl>+<V>\). Or, right-click where to paste and select Paste from the contextual menu.

Move cells

Moving cells typically involves a process of cutting and pasting. When cutting a cell, it is removed from its original location and placed in a temporary storage area called the Clipboard.

1. Select the cell(s) to move.

2. Click the Home tab on the Ribbon and click the Cut button in the Clipboard group.
   - A line of marching ants appears around the selected cells and the message, “Select destination and press <Enter> or choose Paste”, appears on the status bar.
Other Ways to Cut Cells:
Press <Ctrl> + <X>. Or, right-click the selection and select Cut from the contextual menu.

3. Select the cell where the cells are to move to.
Tip: When selecting a destination to paste a range of cells, designate the first cell to paste the cell range there.

4. Click the Home tab on the Ribbon and click the Paste button in the Clipboard group.
The copied cell data is pasted in the new location.

Other Ways to Paste Cells:
Press <Ctrl> + <V>. Or, right-click where it will be pasted and select Paste from the contextual menu. Or, select the destination and press <Enter>.

Moving and copying cells using the mouse
Using the mouse to move and copy cells is even faster and more convenient than using the cut, copy and paste commands.

1. Select the cell(s) to move.

2. Point to the border of the cell or cell range.

3. Click and hold the mouse button.

4. Drag the pointer where the selected cell(s) are to move to and then release the mouse button.

Tips
✓ Press and hold the <Ctrl> key while clicking and dragging to copy the selection.

The screen tip previews the address of the cell range as it is moved.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mileage Report</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Date</td>
<td>Destination</td>
<td>Starting</td>
<td>End</td>
<td>Total Miles</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>10</td>
<td>2/2/2012 Duluth</td>
<td>20478</td>
<td>20568</td>
<td>90</td>
<td>$45.00</td>
</tr>
<tr>
<td>11</td>
<td>2/4/2012 Minneapolis</td>
<td>21004</td>
<td>21314</td>
<td>300</td>
<td>$100.00</td>
</tr>
<tr>
<td>12</td>
<td>2/6/2012 St. Cloud</td>
<td>21485</td>
<td>24707</td>
<td>273</td>
<td>$186.00</td>
</tr>
<tr>
<td>13</td>
<td>2/12/2012 Cloquet</td>
<td>21861</td>
<td>21891</td>
<td>90</td>
<td>$45.00</td>
</tr>
<tr>
<td>14</td>
<td>2/15/2012 Hibbing</td>
<td>21966</td>
<td>22266</td>
<td>300</td>
<td>$115.00</td>
</tr>
<tr>
<td>15</td>
<td>2/20/2012 Minneapolis</td>
<td>22278</td>
<td>22938</td>
<td>660</td>
<td>$300.00</td>
</tr>
<tr>
<td>16</td>
<td>2/24/2012 Mentor</td>
<td>24001</td>
<td>24991</td>
<td>520</td>
<td>$260.00</td>
</tr>
<tr>
<td>17</td>
<td>2/7/2012 Minneapolis</td>
<td>24190</td>
<td>24620</td>
<td>520</td>
<td>$260.00</td>
</tr>
<tr>
<td>18</td>
<td>2/7/2012 Minneapolis</td>
<td>25122</td>
<td>272</td>
<td>272</td>
<td>$136.00</td>
</tr>
</tbody>
</table>

Figure 3-5: Moving a cell range using the mouse.
Controlling How Cells Are Moved or Copied

It’s simple to control how cell content looks or behaves when it is pasted. For example, keep the data’s formatting, or have it take on the formatting properties of the destination cells.

Use Paste Options

Control how content is pasted in spreadsheets using the Paste Options in Excel.

1. Paste the content in the spreadsheet and click the Paste Options button.

The Paste Options button appears in the lower-right corner of the pasted content. A list of different ways to paste the content appears.

- **Other Ways to Use Paste Options:**
  - Before pasting, click the Paste button list arrow in the Clipboard group on the Home tab and select a paste option from the list.

- **Tip:** The options available depend on the type of content being pasted. For example, content that contains formulas will have more paste options than content that contains only text.

2. Point at a paste option.

A live preview of how the content will look using that paste option appears.

3. Click a paste option.

The data is pasted using the selected option.

<table>
<thead>
<tr>
<th>Table 3-1: Paste Option Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste</td>
</tr>
<tr>
<td>Formulas</td>
</tr>
<tr>
<td>Formulas &amp; Number Formatting</td>
</tr>
<tr>
<td>Keep Source Formatting</td>
</tr>
<tr>
<td>No Borders</td>
</tr>
<tr>
<td>Keep Source Column Widths</td>
</tr>
<tr>
<td>Transpose</td>
</tr>
</tbody>
</table>

Exercise Notes

- **Exercise File:** Mileage3-3.xlsx
- **Exercise:** Use Paste Options to copy the values only from E4:E12 to E14:E22.

Enter the value 1.25 in cell G4. Use paste special to multiply E4:E12 by this value.

![Figure 3-6: The Paste Options button appears after pasting so it's possible to specify how data is pasted into the worksheet.](image)
Use Paste Special commands

Control how content is pasted using the Paste Special command.

1. Copy or cut an item.
2. Click the cell to paste it to.
3. Click the Home tab and click the Paste button list arrow in the Clipboard group.
4. Select Paste Special.
   The Paste Special dialog box appears.
   **Other Ways to Open Paste Special:**
   Press <Ctrl> + <Alt> + <V>.
5. Select a paste option and click OK.
   The content is pasted into the spreadsheet using the selected option.
6. Press <Enter>.
   The pasted content is deselected.

### Table 3-2: Paste Special Commands

<table>
<thead>
<tr>
<th>Paste Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Pastes all cell contents and formatting. Same as the Paste command.</td>
</tr>
<tr>
<td>Formulas</td>
<td>Pastes only the formulas as entered in the formula bar.</td>
</tr>
<tr>
<td>Values</td>
<td>Pastes only the values as displayed in the cells.</td>
</tr>
<tr>
<td>Formats</td>
<td>Pastes only cell formatting. Same as using the Format Painter button.</td>
</tr>
<tr>
<td>Comments</td>
<td>Pastes only comments attached to the cell.</td>
</tr>
<tr>
<td>Validation</td>
<td>Pastes data validation rules for the copied cells to the paste area.</td>
</tr>
<tr>
<td>All using Source theme</td>
<td>Pastes all cell contents and formatting, including the theme, if one was applied to the source data.</td>
</tr>
<tr>
<td>All except borders</td>
<td>Pastes all cell contents and formatting applied to the copied cell except borders.</td>
</tr>
<tr>
<td>Column widths</td>
<td>Pastes only the width of the source cell’s column to the destination cell’s column.</td>
</tr>
<tr>
<td>Formulas and number formats</td>
<td>Pastes only the formulas and number formats.</td>
</tr>
<tr>
<td>Values and number formats</td>
<td>Pastes only the values and number formats.</td>
</tr>
<tr>
<td>Operation (several options)</td>
<td>Specifies which mathematical operation, if any, to be applied to the copied data.</td>
</tr>
<tr>
<td>Skip blanks</td>
<td>Avoids replacing values in the paste area when blank cells occur in the copy area.</td>
</tr>
<tr>
<td>Transpose</td>
<td>Changes columns of copied data to rows, and vice versa.</td>
</tr>
<tr>
<td>Paste Link</td>
<td>Links the pasted data to the source data by pasting a formula reference to the source data.</td>
</tr>
</tbody>
</table>

Figure 3-7: Paste Special multiplies the value of the copied cell (G4) with the values in the selected cell range (E4:E12).
Collecting Items to Move or Copy

Office Clipboard is a wonderful resource. The Clipboard collects multiple cut or copied items at a time, which can then be pasted as needed. Use it to collect and paste items from other Office programs.

1. Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Clipboard group.

The Clipboard task pane appears along the left side of the window.

2. Cut and copy items.

3. Click the place in the worksheet where the Clipboard should paste the item to.

4. Click the item in the Clipboard.

The item is pasted in the workbook.

Tips

✓ The Clipboard can hold 24 items at a time. As long as the Clipboard is open, it collects items that are cut or copied from all Office programs. The icon next to each item indicates the program the item is from. See Table 3-3: Icons in the Clipboard Task Pane for examples of some common icons.

✓ While the Clipboard is displayed, each cut or copied item is saved to the Clipboard. If the Clipboard is not displayed, the last cut or copied item is replaced.

✓ To remove an item from the Clipboard, click the item’s list arrow and select Delete. Click the Clear All button in the task pane to remove all items from the Clipboard.

Exercise Notes

- Exercise File: Mileage3-4.xlsx
- Exercise: Display the Clipboard. Copy these cell ranges: A6:F6; A10:F10; A12:F12.

Paste the copied items in A14, A15, and A16.

Close the Clipboard and clear the contents of cells A14:F16.

Table 3-3: Icons in the Clipboard Task Pane

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Excel</td>
<td>Content cut or copied from Microsoft Excel.</td>
</tr>
<tr>
<td>PowerPoint</td>
<td>Content cut or copied from Microsoft PowerPoint.</td>
</tr>
<tr>
<td>Word</td>
<td>Content cut or copied from Microsoft Word.</td>
</tr>
<tr>
<td>Outlook</td>
<td>Content cut or copied from Microsoft Outlook.</td>
</tr>
<tr>
<td>Graphic Object</td>
<td>Cut or copied graphic object.</td>
</tr>
</tbody>
</table>

Figure 3-8: A worksheet with the Clipboard task pane displayed.
Checking Spelling

Use Excel’s spell checker to find and correct spelling errors in worksheets.

1. Click the Review tab on the Ribbon and click the Spelling button in the Proofing group.
   Excel begins checking spelling with the active cell.
   
   Tip: Depending on which cell is active when spell check is started, a dialog box may appear asking if spell check should start over at the beginning of the sheet. Select Yes.

Other Ways to Check Spelling:
Press <F7>.

If Excel finds an error, the Spelling dialog box appears with the misspelling in the “Not in Dictionary” text box. Several options are available to choose from when the Spelling dialog box opens:

- **Ignore Once**: Accepts the spelling and moves on to the next spelling error.
- **Ignore All**: Accepts the spelling and ignores all future occurrences of the word in the worksheet.
- **Add to Dictionary**: If a word is not recognized in the Microsoft Office Dictionary, it is marked as misspelled. This command adds the word to the dictionary so it is recognized in the future.
- **Change**: Changes the spelling of the word to the spelling that is selected in the Suggestions list.
- **Change All**: Changes all occurrences of the word in the worksheet to the selected spelling.

   Trap: Exercise caution when using this command—it might end up changing something that shouldn’t be changed.

- **AutoCorrect**: Changes the spelling of the word to the spelling that is selected in the Suggestions list, and adds the misspelled word to the AutoCorrect list so that Excel will automatically fix it whenever it is typed in the future.

2. If the word is spelled incorrectly, select the correct spelling from the Suggestions list. Then click Change, Change All, or AutoCorrect. If the word is spelled correctly, click Ignore Once, Ignore All, Add to Dictionary.

   Excel applies the command and moves on to the next misspelling.
Once Excel has finished checking a worksheet for spelling errors, a dialog box appears, saying the spelling check is complete.

3. Click **OK**.

The dialog box closes.
Inserting Cells, Rows, and Columns

While working on a worksheet, new cells, columns, or rows may need to be inserted. When cells are inserted, the existing cells shift to make room for the new cells.

**Insert cells**

1. Select the cell or cell range.
2. Click the **Home** tab on the Ribbon and click the **Insert** button list arrow in the Cells group. Select **Insert Cells**.
   The Insert dialog box appears.
3. Select the insert option to use and click **OK**.
   The cell(s) are inserted and the existing cells shift.

**Other Ways to Insert Cells:**
Right-click the selected cell(s) and select **Insert** from the contextual menu. Select an option and click **OK**.

**Insert rows or columns**

1. Select the row heading below or column heading to the right of where the new row or column will insert.
2. Click the **Home** tab on the Ribbon and click the **Insert** list arrow in the Cells group. Select **Insert Rows** or **Insert Columns**.
   The row or column is inserted. Existing rows are shifted downward, while existing columns are shifted to the right.

**Other Ways to Insert Rows or Columns:**
Right-click a row or column heading and select **Insert** from the contextual menu.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mileage Report</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td>Cost/Mile</td>
<td>$0.50</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mileage Report</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Date</td>
<td>Destination</td>
<td>Starting</td>
<td>End</td>
<td>Total Miles</td>
<td>Amount</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2/2/2012</td>
<td>Duluth</td>
<td>20471</td>
<td>20508</td>
<td>11.5</td>
<td>$56.00</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>2/4/2012</td>
<td>Minneapolis</td>
<td>2100</td>
<td>2364</td>
<td>450</td>
<td>$275.00</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>2/8/2012</td>
<td>St. Cloud</td>
<td>21423</td>
<td>21767</td>
<td>340</td>
<td>$170.00</td>
<td></td>
</tr>
</tbody>
</table>

**Exercise Notes**

- **Exercise File:** Mileage3-6.xlsx
- **Exercise:** Insert new cells in A2:F2 and shift cells down.
  Insert new cells in F3:F13 and shift cells to the right.
  Insert two new rows above row 2.

**Figure 3-11:** Existing cells shift down to make room for the inserted cells.

**Figure 3-12:** The Insert dialog box.
Deleting Cells, Rows, and Columns

It’s easy to quickly delete existing cells, columns, or rows from a worksheet. When cells are deleted, the existing cells shift to fill the space left by the deletion.

Delete cells

1. Select the cell(s) to delete.

2. Click the Home tab on the Ribbon and click the Delete list arrow in the Cells group. Select Delete Cells. The Delete dialog box appears. Here Excel tells how to move the remaining cells to cover the hole left by the deleted cell(s) by selecting “Shift cells left” or “Shift cells up.”

   Tip: Select Entire row or Entire column in the Delete dialog box to delete an entire row or column.

3. Select an option and click OK.

   The cell(s) are deleted and the remaining cells are shifted.

   Trap: Pressing the <Delete> key only clears a cell’s contents; it doesn’t delete the actual cell.

   Other Ways to Delete Cells:
   Right-click the selection and select Delete from the contextual menu. Select an option and click OK.

Delete rows or columns

1. Select the row or column heading(s) to delete.

2. Click the Home tab on the Ribbon and click the Delete button in the Cells group. The rows or columns are deleted. Remaining rows are shifted up, while remaining columns are shifted to the left.

   Other Ways to Delete Rows or Columns:
   Select the column or row heading(s) to delete, right-click any of them, and select Delete from the contextual menu. Or, click the Delete list arrow and select Delete Sheet Rows or Delete Sheet Columns. The row or column of the active cell is deleted.

Exercise Notes

• Exercise File: Mileage3-7.xlsx
• Exercise: Delete rows 2, 3, and 4.
   Delete cells F2:F12 and shift cells left.

Figure 3-13: Existing cells shift up to replace the deleted rows.

Figure 3-14: The Delete dialog box.
Using Undo and Redo

The undo and redo commands are very useful commands for working with cell contents and cell formatting.

**Undo an action**

*Undo* does just that—it undoes any actions as though they never happened.

1. Click the *Undo* button on the Quick Access Toolbar.
   The last action is undone.

*Other Ways to Undo:*
Press `<Ctrl>` + `<Z>`.

**Redo an action**

*Redo* is the opposite of undo: it redoes an action that has been undone.

1. Click the *Redo* button on the Quick Access Toolbar.
   The last action is redone.

*Other Ways to Redo an Action:*
Press `<Ctrl>` + `<Y>`.

*Tip:* Click the *Redo* button list arrow to redo multiple actions.

**Undo or redo multiple actions**

1. Click the *Undo* button list arrow or *Redo* button list arrow on the Quick Access Toolbar.
   A list of the actions in Excel appears. To undo or redo multiple actions, point to the command to undo or redo.

*Tip:* Up to 100 actions can be changed with the undo or redo actions in Excel, even after saving the workbook.

2. Click the last action to undo or redo in the list.
   The action and all subsequent actions are undone or redone.

---

**Exercise Notes**

- **Exercise File:** Mileage3-8.xlsx
- **Exercise:** Delete the contents of cell A1. Undo the action, then redo the action.
  Enter “.35” in F2. Delete rows 4 and 5. Undo both actions, then redo both actions.
Finding and Replacing Content

Excel’s find and replace commands can scan a worksheet for labels and values with just a few clicks of the mouse.

Find

The Find feature makes it very easy to find specific words and values in a worksheet.

1. Click the **Home** tab on the Ribbon and click the **Find & Select** button in the Editing group. Select **Find** from the list.

   The Find tab of the Find and Replace dialog box appears.

   **Other Ways to Find Text:**
   - Press `<Ctrl>` + `<F>`.

2. Type the text or value to find in the “Find what” text box.

3. Click the **Find Next** button.

   Excel jumps to the first occurrence of the word, phrase, or value that was entered.

4. Click the **Find Next** button again to move on to other occurrences.

5. Click **Close**.

Replace

Replace finds specific words and values, and then replaces them with something else.

1. Click the **Home** tab on the Ribbon and click the **Find & Select** button in the Editing group. Select **Replace** from the list.

   The Replace tab of the Find and Replace dialog box appears.

   **Other Ways to Replace Text:**
   - Press `<Ctrl>` + `<H>`.

2. Type the text or value to replace in the “Find what” text box.

3. Type the replacement text or value in the “Replace with” text box.

4. Click the **Find Next** button.

   Excel jumps to the first occurrence of the word, phrase, or value in the “Find what” box.

---

**Exercise Notes**

- **Exercise File:** Mileage3-9.xlsx
- **Exercise:** Find all instances of “Minneapolis” in the worksheet.
  Replace all instances of “Mankato” with “Blaine”.

---

---

**Exercise Notes**

- **Exercise File:** Mileage3-9.xlsx
- **Exercise:** Find all instances of “Minneapolis” in the worksheet.
  Replace all instances of “Mankato” with “Blaine”.

---

---

**Exercise Notes**

- **Exercise File:** Mileage3-9.xlsx
- **Exercise:** Find all instances of “Minneapolis” in the worksheet.
  Replace all instances of “Mankato” with “Blaine”.

---

---

**Exercise Notes**

- **Exercise File:** Mileage3-9.xlsx
- **Exercise:** Find all instances of “Minneapolis” in the worksheet.
  Replace all instances of “Mankato” with “Blaine”.

---

---

**Exercise Notes**

- **Exercise File:** Mileage3-9.xlsx
- **Exercise:** Find all instances of “Minneapolis” in the worksheet.
  Replace all instances of “Mankato” with “Blaine”.

---

---

**Exercise Notes**

- **Exercise File:** Mileage3-9.xlsx
- **Exercise:** Find all instances of “Minneapolis” in the worksheet.
  Replace all instances of “Mankato” with “Blaine”.

---

---

**Exercise Notes**

- **Exercise File:** Mileage3-9.xlsx
- **Exercise:** Find all instances of “Minneapolis” in the worksheet.
  Replace all instances of “Mankato” with “Blaine”.

---
5. Choose how to replace the text:
   - **Replace**: Click to replace the current item.
   - **Replace All**: Click to replace each item found in the document. Use this command with caution: it may replace something that shouldn’t be replaced.

6. Click **Close**.

**Search options**

Use Excel’s search options to change how Excel searches in the document.

1. Click the **More** button in the Find and Replace dialog box to specify how to search for data.

   **Table 3-4: Find and Replace Search Options**, describes the Search Options available under the Find and Replace tabs.

   ![Figure 3-19: The Find and Replace dialog box with search options displayed.](image)

   **Tip**: If Search Options are specified, make sure to turn them off when finished. Otherwise, subsequent find or replace commands will use the same search options.

**Table 3-4: Find and Replace Search Options**

<table>
<thead>
<tr>
<th>Within</th>
<th>Choose whether to search within just the current sheet or the entire workbook.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search</td>
<td>Search by rows (left to right, then top to bottom) or columns (top to bottom, then left to right).</td>
</tr>
<tr>
<td>Look in</td>
<td>Specify which kinds of data to search in, such as formulas, values, or comments.</td>
</tr>
<tr>
<td>Match case</td>
<td>Searches exactly as text is typed in the text box.</td>
</tr>
<tr>
<td>Match entire cell contents</td>
<td>Searches only for cells that match the contents in the text box entirely. Parts of phrases or words are not included.</td>
</tr>
<tr>
<td>Format button</td>
<td>Specify formatting characteristics to find attached to the text in the Find what text box.</td>
</tr>
</tbody>
</table>
Adding Comments to Cells

Sometimes notes may need to be added to a workbook to document complicated formulas or questionable values, or to leave a comment for another user. Excel’s cell comments command help document the worksheets and make them easier to understand. Think of cell comments as Post-It Notes that can attach to any cell. Cell comments appear whenever the mouse is pointed at the cell they’re attached to.

Insert a comment

1. Click the cell to attach a comment to.
2. Click the Review tab on the Ribbon and click the New Comment button in the Comments group.
3. Type a comment.
4. Click outside the comment area when finished.
   ✅ Other Ways to Insert a Comment:
   Right-click the cell to attach a comment to and select New Comment from the contextual menu. Type a comment.

View a comment

1. Point to the red triangle-shaped comment marker that’s located in the cell with the comment.
   Tip: To display a comment all the time, click the cell with the comment, then click the Review tab on the Ribbon and click the Show/Hide Comments button in the Comments group. Or, click the Show All Comments button in the Comments group to display all the comments in a worksheet at once.

Edit a comment

1. Click the cell that contains the comment to edit.
2. Click the Review tab on the Ribbon and click the Edit Comment button in the Comments group.
3. Edit the comment.
   Tip: Change the size of a comment text box by clicking and dragging one of the eight sizing handles that surrounds the comment.
4. Click outside the comment area when finished.
   ✅ Other Ways to Edit a Comment:
   Right-click the cell with the comment to edit and...
select **Edit Comment** from the contextual menu.
Edit the comment.

**Delete a comment**

1. Click the cell that contains the comment to delete.

2. Click the **Review** tab on the Ribbon and click the **Delete** button in the Comments group.

   **Other Ways to Delete a Comment:**
   Right-click the cell to delete and select **Delete Comment** from the contextual menu.
Tracking Changes

Track changes made to a workbook allow easier collaboration with other users. If the workbook is set to track changes, Excel also shares the workbook.

Track changes

1. Click the Review tab on the Ribbon, click the Track Changes button in the Changes group, and select Highlight Changes.

   The Highlight Changes dialog box appears.

2. Click the Track changes while editing check box.

3. Click the highlighting options to be used and click OK.

   Another dialog box appears, confirming that the workbook will be saved and become a shared workbook.

4. Click OK.

5. Make changes to the shared workbook.

   After a change is made, a cell comment appears in the affected cell, describing the change that was made and who made it.

Accept/reject changes

Once changes have been made and tracked in a workbook, decide whether to accept or reject those changes.

1. Click the Review tab on the Ribbon, click the Track Changes button in the Changes group, and select Accept/Reject Changes.

   A message appears, saying that the workbook will be saved.

2. Click OK.

   The Select Changes to Accept or Reject dialog box appears. Use the commands to tell Excel which changes to be accepted or rejected.

3. Click OK.

Exercise

- Exercise File: Mileage3-11.xlsx
- Exercise: Turn on track changes while editing. Change cell A1 to “Reimbursements” and change C4 to “2100”. Accept both of the changes.

Figure 3-21: The Highlight Changes dialog box.

Figure 3-22: The Accept or Reject Changes dialog box.
The Accept or Reject Changes dialog box appears, displaying the changes that have been made to the document.

4. Click the **Accept** or **Reject** buttons as each change is highlighted.
Editing a Worksheet Review

Quiz Questions

1. It's possible to replace cell contents by typing over the current contents. (True or False?)

2. To copy cells using the mouse, press and hold the _____ key while clicking and dragging the selection.
   A. <Alt>
   B. <Ctrl>
   C. <Shift>
   D. <F4>

3. The Paste Options button appears after pasting cells in Excel. (True or False?)

4. With the Paste Special command, choose to paste only _______.
   A. values
   B. formulas
   C. cell comments
   D. All of these are correct.

5. The Office Clipboard is available in other Office programs besides Excel. (True or False?)

6. Which button should be clicked to leave misspelled text alone and move to the next questionable word?
   A. Ignore Once
   B. Ignore All
   C. Add to Dictionary
   D. Change

7. When a row is inserted, the existing rows are shifted in which direction?
   A. Left
   B. Upward
   C. Downward
   D. Right

8. Pressing the <Delete> key deletes the selected cell and its contents. (True or False?)

9. It's possible to undo multiple actions in Excel. (True or False?)

10. To access the find and replace commands, click the Find & Select button in the _______ group on the Home tab.
    A. Editing
    B. Cells
    C. Number
    D. Clipboard

11. Excel can delete a cell comment, but it can’t edit one. (True or False?)
Quiz Answers

1. True. Simply click a cell and type to replace its contents.

2. B. Press and hold the <Ctrl> key to copy cells using the mouse.

3. True. The Paste Options button appears after pasting cells in Excel.

4. D. Use the Paste Special command to paste any of these elements.

5. True. The Office Clipboard can be used in all Office programs.

6. A. Click the Ignore Once button to leave text alone and move to the next questionable word.

7. C. The existing rows are shifted downward when a row is inserted.

8. False. Pressing the <Delete> key only deletes the cell’s contents.

9. True. It’s possible to undo multiple actions in Excel.

10. A. Editing

11. False. Excel can edit or delete a cell comment.
Formatting a Worksheet

Formatting Text ..................................................... 64
Formatting Values .................................................. 65
Adjusting Row Height and Column Width .......... 66
  Adjust column width ..................................... 66
  Adjust row height ....................................... 66
  AutoFit columns or rows ............................ 66
Working with Cell Alignment .............................. 67
Adding Cell Borders and Background Colors ... 68
Copying Formatting ............................................. 70
Applying and Removing Cell Styles ................... 71
  Apply a cell style ....................................... 71
  Remove a cell style ................................... 71
Creating and Modifying Cell Styles .................... 72
  Modify or duplicate a cell style .................. 73
Using Document Themes .................................... 74
  Apply a document theme ............................ 74
  Mix and match document themes .................. 74
  Create new theme colors and fonts .............. 75
  Save a new document theme ..................... 75
Applying Conditional Formatting ....................... 76
  Apply Highlight Cell Rules and Top/Bottom Rules ................................................. 76
  Apply Data Bars, Color Scales and Icon Sets ...................................................... 77
Creating and Managing Conditional Formatting Rules .................................................. 78
  Create a new rule ...................................... 78
  Manage rules .......................................... 78
  Remove conditional formatting .................. 79
Finding and Replacing Formatting .................... 80

It’s probably a familiar story: those few colleagues who know how to dazzle everyone at meetings with their sharp-looking worksheets that use colorful fonts and borders.

This chapter explains how to format a worksheet to make it more visually attractive and easier to read.

It’s easy to learn how to change the appearance, size, and color of text and how to align text inside a cell, how to add borders and shading and how to use cell styles, as well as many other tools that will help worksheets look more organized and professional.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

  • Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
  • Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Formatting Text

Emphasize text in a worksheet by making the text darker and heavier (bold), slanted (italics), or in a different typeface (font). The Font group on the Home tab makes it easy to apply character formatting.

1. Click the cell(s) with the label to format.
2. Click the Home tab on the Ribbon and click a formatting button in the Font group.

Other Ways to Format Text:
Right-click the cell(s) to format. Click a formatting button on the Mini Toolbar. Or, right-click the cell(s) to format and select Format Cells from the contextual menu or click the Dialog Box Launcher in the Font group. Select formatting options on the Font tab in the Format Cells dialog box.

Tips
✓ To use different font formats for different characters within the same cell, make the formatting changes while in edit mode.
✓ The formatting buttons in the Font group, such as Font Color and Font Size, are not just for formatting labels—use them to format values as well.
✓ Text is often called a “label” in Excel, because text usually acts as a label to the data in the worksheet.

Exercise Notes
- **Exercise File:** Sales4-1.xlsx
- **Exercise:** Format cell A1 with 14 pt. Cambria font, then format the cell ranges B3:G3 and A4:A12 with bold Cambria font.

![Figure 4-1: The Format Cells dialog box](image)

### Table 4-1: Font Formatting Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Make text <strong>darker and heavier</strong>.</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Make text <em>slanted</em>.</td>
</tr>
<tr>
<td><strong>Underline</strong></td>
<td>Add a line or double line under text.</td>
</tr>
<tr>
<td><strong>Font</strong></td>
<td>Select a different font.</td>
</tr>
<tr>
<td><strong>Font Size</strong></td>
<td>Adjust font size.</td>
</tr>
<tr>
<td><strong>Increase/Decrease Font Size</strong></td>
<td>Adjust font size by one increment, either larger or smaller.</td>
</tr>
<tr>
<td><strong>Font Color</strong></td>
<td>Adjust text color.</td>
</tr>
</tbody>
</table>
Formatting a Worksheet

Formatting Values

Applying number formatting changes how values are displayed—it doesn’t change the actual information. Excel is often smart enough to apply some number formatting automatically. For example, if a dollar sign is used to indicate currency, such as $548.67, Excel will automatically apply the currency number format.

1. Click the cell(s) with the value(s) to format.
2. Click the Home tab on the Ribbon and click a formatting button in the Number group.

The values are formatted.

Tip: See the table below for more information on buttons in the Number group.

Other Ways to Format Values:
Right-click the cell(s) to be formatted. Click a formatting button on the Mini Toolbar. Or, right-click the cell(s) to be formatted and select Format Cells from the contextual menu or click the Number group’s Dialog Box Launcher. Select formatting options on the Number tab in the Format Cells dialog box.

Tips

✓ Create custom number formats in the Format Cells dialog box by selecting the Custom category, selecting a number format code in the list, and editing it in the Type text box. Watch the sample area to see how the custom number format will be displayed.

✓ The formatting buttons in the Font group, such as Font Color and Font Size, are not just for formatting labels—they can be used to format values as well.

Table 4-2: Number Formatting Buttons

<table>
<thead>
<tr>
<th>Format Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Select from several number formats—like General, Number, or Time—or click More to see all available formats.</td>
</tr>
<tr>
<td>Accounting Number Format</td>
<td>$1,000.00</td>
</tr>
<tr>
<td>Percent Style</td>
<td>100%</td>
</tr>
<tr>
<td>Comma Style</td>
<td>1,000</td>
</tr>
<tr>
<td>Increase/Decrease Decimal</td>
<td>1000.0 or 1000.0</td>
</tr>
</tbody>
</table>

Exercise Notes

- **Exercise File:** Sales4-2.xlsx
- **Exercise:** Format the cell range B4:G12 with the Accounting number format and decrease the decimal places so no decimals are shown.

Select the range B6:G10 and display the Format Cells dialog box. Select the Accounting category and remove the dollar symbols from the range (select None as the symbol).
Adjusting Row Height and Column Width

When work is begun on a worksheet, all the rows and columns are the same size. As information is entered into the worksheet, some of the columns or rows may not be large enough to display the information they contain.

Adjust column width

1. Point to the column header’s right border until the pointer changes to a →.
2. Click and drag to the left or right to adjust the width.
   A dotted line appears as its dragged, showing where the new column border will be.

   Other Ways to Adjust Column Width:
   Right-click the column header(s), select Column Width from the contextual menu, and enter the column width. Or, select the column header(s), click the Format button in the Cells group on the Home tab, select Width, and enter column width.

Adjust row height

1. Point to the row header’s bottom border until the pointer changes to a ↓.
2. Click and drag up or down to adjust the height.
   A dotted line appears as its dragged, showing where the new row border will be.

   Other Ways to Adjust Row Height:
   Right-click the row header(s), select Row Height from the contextual menu, and enter the row height. Or, select the row header(s), click the Format button in the Cells group on the Home tab, select Height, and enter the row height.

AutoFit columns or rows

The AutoFit feature automatically resizes columns or rows to fit the cell in each column or row that has the widest or tallest contents.

1. Double-click the right border of the column(s) or bottom border of the row(s).

Tips

✓ To AutoFit multiple rows or columns, select the rows and columns, then double-click the corresponding border to adjust all selected rows or columns.
Working with Cell Alignment

By default, the contents of a cell appear at the bottom of the cell, with values (numbers) aligned to the right and labels (text) aligned to the left.

1. Select the desired cell(s) to align.

2. Click the Home tab on the Ribbon and click an alignment button in the Alignment group.

The cell contents are realigned. See Table 4-3: Cell Alignment Buttons in the Alignment Group for more information about alignment options in Excel.

**Other Ways to Align Cells:**
Right-click the cell(s) to align. Click an alignment button on the Mini Toolbar. Or, right-click the cell(s) to align and select Format Cells from the contextual menu or click the Dialog Box Launcher in the Alignment group. Select alignment options on the Alignment tab in the Format Cells dialog box.

<table>
<thead>
<tr>
<th>Table 4-3: Cell Alignment Buttons in the Alignment Group</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Top/Middle/Bottom Align" /></td>
</tr>
<tr>
<td><img src="image2.png" alt="Align Left/Center/Right" /></td>
</tr>
<tr>
<td><img src="image3.png" alt="Orientation" /></td>
</tr>
<tr>
<td><img src="image4.png" alt="Decrease/Increase Indent" /></td>
</tr>
<tr>
<td><img src="image5.png" alt="Wrap Text" /></td>
</tr>
<tr>
<td><img src="image6.png" alt="Merge &amp; Center list arrow" /></td>
</tr>
</tbody>
</table>

**Exercise Notes**
- **Exercise File:** Sales4-4.xlsx
- **Exercise:** Center align the labels in cells B3:G3. Merge and center the label “Income & Expenses” across cells A1:G1.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Left Aligned</td>
</tr>
<tr>
<td>2</td>
<td>Centered</td>
</tr>
<tr>
<td>3</td>
<td>Right Aligned</td>
</tr>
<tr>
<td>4</td>
<td>Merged and Centered</td>
</tr>
<tr>
<td>5</td>
<td>Indented</td>
</tr>
</tbody>
</table>

The text in this cell is wrapped.

**Figure 4-4:** An example of horizontal alignment options.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Top Aligned</td>
<td>Middle Aligned</td>
</tr>
</tbody>
</table>

**Figure 4-5:** An example of vertical alignment options.
Adding Cell Borders and Background Colors

Adding cell borders and filling cells with colors and patterns can make them more attractive, organized and easier to read.

Add a cell border

Borders are lines that can be added to the top, bottom, left, or right of cells.

1. Select the cell(s) to add the border to.
2. Click the Home tab on the Ribbon and click the Border list arrow in the Font group.
3. Select a border type.

Tips:
- To remove a border, click the Border list arrow in the Font group and select No Border
- Other Ways to Add a Border:
  - Right-click the cell(s) to add the border to. Click the Border list arrow on the Mini Toolbar and select a border. Or, right-click the cell(s) to format and select Format Cells from the contextual menu or click the Dialog Box Launcher in the Font group. Click the Border tab in the Format Cells dialog box and select border options.

Draw a cell border

Sometimes it’s easier to draw the borders in cells, so that the borders can be seen as they are applied.

1. Click the Border button list arrow in the Font group of the Home tab and select Draw Border.
   The cursor changes into a pencil shape.
2. Click and drag the cell gridlines.
   The borders are applied to cells.

Tips
- To change the style or color of the lines used by the Draw Border tool, click the Border button list arrow in the Font group and select the Line Color and Line Style to use.

Add a cell background color

Fill the background of a cell by adding a color or pattern.

Exercise Notes
- Exercise File: Sales4-5.xlsx
- Exercise: Add a bottom border to cells B3:G3 and B9:G9. Add a light blue fill color (Accent 1, Lighter 80%) to the Income & Expenses merged cell.
1. Select the cell(s) to add the color to.

2. Click the **Home** tab on the Ribbon and click the **Fill Color** list arrow in the Font group.

3. Select the color to use.
   The fill color is applied.

   **Other Ways to Apply Background Color:**
   Right-click the cell selection and click the **Fill Color** list arrow on the Mini Toolbar. Select a color.
   Or, right-click the cell(s) to format and select **Format Cells** from the contextual menu or click the **Dialog Box Launcher** in the Font group. Click the **Fill** tab in the Format Cells dialog box and select a background color or fill effects.

**Tips**

✓ Use an image as the background of a worksheet. Click the **Page Layout** tab and click the **Background** button. Browse to and select the image to be used as the worksheet background. Click **Insert**.

✓ To apply the shading to another paragraph, just click the button to apply the displayed shading color.
Copying Formatting

The Format Painter copies the formatting of a cell or cell range and applies it elsewhere.

1. Select the cell(s) to copy the formatting from.

2. Click the Home tab on the Ribbon and click the Format Painter button in the Clipboard group.

Other Ways to Access the Format Painter Button:
Select the cell(s) with the formatting options to copy, then right-click the selection. Click the Format Painter button on the Mini Toolbar.

The mouse pointer changes to indicate it is ready to apply the copied formatting.

Tip: Single-click the Format Painter button to apply copied formatting once. Double-click the Format Painter button to apply copied formatting as many times as necessary, then click it again or press the <Esc> key to deactivate the Format Painter.

3. Click the cell to apply the copied formatting to it.
The copied formatting is applied.

Exercise

Exercise File: Sales4-6.xlsx

Exercise: Use the Format Painter to copy the value formatting from the cell B4 to the range B10:G10.

Figure 4-10: Using the Format Painter tool to copy formatting from cells in row 4 to cells in row 10.
Applying and Removing Cell Styles

Styles contain preset font formatting, cell shading, and other formatting items that can be applied to a cell or cell range all at once. This is a convenient and easy formatting option for cells.

Apply a cell style

1. Select the cell(s) to format.
2. Click the Home tab and click the Cell Styles button in the Styles group.
3. Select a cell style from the gallery that appears.
   ✔ Tip: Hover the pointer over a style to preview how it will look before selecting it.

Remove a cell style

1. Select the cell(s) that have the cell style applied.
2. Click the Home tab and click the Cell Styles button in the Styles group.
3. Click Normal.

Tips

✔ Cell styles are associated with the theme that is being used for the workbook. To switch to a new theme, the cell styles will update to match it.
✔ If another workbook contains the desired styles to copy into the current workbook, click the Cell Styles button in the Styles group and select Merge Styles.

Exercise

- **Exercise File**: Sales4-7.xlsx
- **Exercise**: Apply the “Heading 3” cell style to the cell range B3:G3.
  Apply the “Heading 4” cell style to the cell range A4:A12.
  Apply the “Total” cell style to the cell range B12:G12.
- Remove the “Heading 4” cell style from the range A4:A12.

Figure 4-11: A preview of how the cell style will look appears as the mouse hovers over styles in the Cell Styles gallery.
Creating and Modifying Cell Styles

It's easy to modify cell styles and create new styles.

Create a new cell style

If applying the same formatting over and over, know that it is simple to create a style with that formatting so that it can be applied those formatting settings with one click.

1. Select the cell that has the desired formatting to use for the style.
2. Click the Home tab and click the New Cell Style button in the Cell Styles gallery of the Styles group.
3. Type a name for the style in the Style name text box. The Style dialog box appears with the formatting for the selected cell. Further define the formatting for the cell if desired.
4. Check or uncheck “Style includes” boxes to select which formatting items the style should include. If a check box is left empty, the default settings will be used for the cell.
5. Click the Format button and define formatting as needed.
6. Click OK. The Format dialog box closes.
7. Click OK. The Style dialog box closes and the new style is available in the Cell Styles gallery.
8. Reapply the new style to the cell.

Tips

✓ New styles are added to the theme that is currently applied to the workbook.
✓ If another workbook contains desired styles to copy into the current workbook, click the Cell Styles button in the Styles group and select Merge Styles.

Exercise

- Exercise File: Sales4-8.xlsx
- Exercise: Create a new style using the formatting in cell A1, and name the style Income&Expenses.
  Modify the Income&Expenses style: change the font size to 16 pt. and add Bold formatting.

Figure 4-12: The Style dialog box.

Figure 4-13: The new style appears under the Custom section of the Cell Styles gallery.
Modify a cell style

1. Click the Home tab and click the Cell Styles button in the Styles group.

2. Right-click the cell style to be modified and select Modify.
   The Style dialog box appears.
   A Trap: Selecting Modify changes the style, while selecting Duplicate, adds a new custom style and leaves the original built-in style alone.

3. Click the Format button and change formatting items on each tab, as needed. Click OK.
   The Format dialog box closes.

4. Click OK.
   The Style dialog box closes and the style is modified.

Tips

To duplicate and then modify a cell style, right-click a style and select Duplicate. This creates a new custom style.

✓ To remove a cell style from all cells and delete the cell style itself, click the Home tab on the Ribbon and click the Cell Styles button in the Styles group. Right-click the style to delete and select Delete.
Using Document Themes

A theme is a set of unified design elements that can be applied to a worksheet to give it a consistent look and feel. Document themes coordinate the look of a worksheet with theme colors, theme fonts, and theme effects.

- **Theme Colors**: A set of eight coordinated colors used in formatting text and objects in the worksheet.
- **Theme Fonts**: A set of coordinated heading and body font types.
- **Theme Effects**: A set of coordinated formatting properties for shapes and objects in the document.

**Apply a document theme**

Applying a document theme affects all elements of the worksheet: colors, fonts, and effects.

1. Click the **Page Layout** tab on the Ribbon and click the **Themes** button in the Themes group.

   A list of built-in document themes appears. The default theme is “Office.”

   Tip: Feel free to browse for additional themes online by clicking More Themes on Microsoft Office Online. Or, if a theme is saved elsewhere on the computer or network location, click Browse for Themes to go to the theme’s location.

2. Click the document theme to apply it.

   The formatting associated with the selected document theme is applied to the worksheet.

**Mix and match document themes**

Excel is not bound to the colors, fonts, or effects that are assigned to a document theme. Mix and match theme colors, theme fonts, and theme effects.

1. Click the **Page Layout** tab on the Ribbon.

2. Click the **Theme Colors**, **Theme Fonts**, or **Theme Effects** button and select the set of colors, fonts, or effects desired.

   The change is applied to the document. The document theme isn’t changed, it is just no longer applied. To use this set of theme items together again, save them as a new document theme.

---

**Exercise**

- **Exercise File**: Sales4-9.xlsx
- **Exercise**: Apply the Black Tie document theme.

  Apply the Civic theme color set.

  Save these settings as a new document using the name “Income&Expenses”.

  Change the workbook back to the Office document theme.
Create new theme colors and fonts
Another option is to change which colors or fonts make up
the theme colors and theme fonts.

1. Click the Page Layout tab on the Ribbon.
2. Click the Theme Colors or Theme Fonts button.
3. Select Create New Theme Colors or Create New
   Theme Fonts from the list.
4. Select the colors or fonts to use.
   Once the color or font theme looks the desired way,
save it.
5. Type a name for the new theme in the “Name” text
   box.
   To coordinate new theme colors and fonts, save them
   under the same name, just as they are with built-in
   themes.
6. Click Save.

Save a new document theme
Finally, save any combination of theme colors, theme fonts,
and theme effects as a new document theme.

1. Apply the colors, fonts, and effects to use in the new
document theme.
2. Click the Page Layout tab on the Ribbon and click the
   Themes button in the Themes group.
3. Select Save Current Theme.
   The Save Current Theme dialog box appears.
4. Type a name for the theme in the File name box.
5. Click Save.

Tips
✓ When saving a new theme color or font, or saving a
  new document theme, it becomes available in all
  Office programs.
✓ To remove a custom theme or theme element, right-
  click the theme and select Edit. Click Delete in the
dialog box and click Yes to confirm the deletion.
Applying Conditional Formatting

Conditional formatting formats cells only if a specified condition is true. For example, use conditional formatting to display weekly sales totals that exceeded $50,000 in bright red boldface formatting, and bright blue italics formatting if the sales totals were under $20,000. If the value of the cell changes and no longer meets the specified condition, the cell returns to its original formatting.

Apply Highlight Cells Rules and Top/Bottom Rules

Highlight specific cells in a range using a comparison operator; only cells that meet the specified criteria will be formatted.

1. Select the cell range to format.
2. Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group.

Several conditional formatting rules appear to choose from:

**Highlight Cells Rules:** These conditions focus on general analysis. Preset conditions include: Greater Than; Less Than; Between; Equal To; Text That Contains; Date Occurring; Duplicate Values.

**Top/Bottom Rules:** These conditions focus on the high and low values in the worksheet. Preset conditions include: Top 10 Items; Top 10%; Bottom 10 Items; Bottom 10%; Above Average; Below Average.

3. Point to Highlight Cells Rules or Top/Bottom Rules and select a conditional formatting rule.

A dialog box appears to specify the details relating to the rule.

For example, if the Greater Than rule, in the “Format cells that are Greater Than:” box is selected, enter a value or click a cell to enter a cell reference. Then click the list arrow and select the desired formatting to apply to cells that fit the criteria set—in this example, cells that are greater than the value entered.

4. Complete the dialog box to define the condition.
5. Click OK.

The conditional formatting is applied to the cells.

---

**Exercise**

- **Exercise File:** Sales4-10.xlsx
- **Exercise:** Use conditional formatting to highlight cells that are below average in cell range B4:G4.

Add Blue data bars to cells B10:G10.

Add the 3 Arrows (colored) icon set to cells B12:G12. (Columns may need to be widened so the contents are visible.)
Apply Data Bars, Color Scales and Icon Sets

Format cells with data bars, color scales, or icon sets to visually display variations in the values of cells in a range.

1. Select the cell range to format.

2. Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group.

   ✔ Take a closer look at three similar types of conditional formatting:
   
   **Data Bars**: Colored bars appear in the cells. The longer the bar, the higher the value in that cell. Choose from different bar colors.
   
   **Color Scales**: Cells are shaded different color gradients depending on the relative value of each cell compared to the other cells in the range. Choose from different colors.
   
   **Icon Sets**: Different shaped or colored icons appear in cells, based on each cell’s value. Choose from several types and colors of icons.

3. Point to **Data Bars, Color Scales or Icon Sets**.

   A menu appears, differing based on the selection.

4. Select a data bar, 2- or 3-color scale, or icon set.

   The conditional formatting is applied to the cells.

   ✔ **Tips**

   ✔ Additional options for data bars have been added to Excel 2013. Apply solid fills and borders, and even change the direction of the bar. Data bars also have a new way to display negative values.

   ✔ More icon sets have been added to Excel 2013. Specify which icons appear from an icon set.

**Figure 4-19**: Applying conditional formatting.

**Figure 4-20**: The worksheet with conditional formatting applied.
Creating and Managing Conditional Formatting Rules

Create and manage new conditional formatting rules that follow the parameters and formatting specified.

Create a new rule

1. Select the cell range to format with a customized rule.
2. Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group.
4. Select a rule type in the Select a Rule Type list.
5. Complete the fields in the Edit the Rule Description area.
   This area will display different fields depending on the type of rule selected.
   Tip: Click Preview in the New Formatting Rule dialog box to see how the rule will appear before applying it.
6. Click OK.
   The new rule is created and formatting is applied.

Other Ways to Create a New Rule:
   Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group. Click Manage Rules, then click New Rule. Or, click the Home tab on the Ribbon and click the Conditional Formatting list arrow in the Styles group. Click one of the rule types, then click More Rules.

Manage rules

Manage all aspects of conditional formatting—creating, editing, and deleting rules—in one place using the Rules Manager.

1. Select the cell range with the conditional formatting to manage.
2. Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group.

Exercise

- Exercise File: Sales4-11.xlsx
- Exercise: Create and apply a new formatting rule that applies bold formatting to values that are below average for cell range B4:G4.
  Select cells B12:G12 and edit the rule so that the green icon appears for values greater than or equal to 60% and the yellow for values greater than or equal to 30%.
  Clear all the conditional formatting on the worksheet.
3. Select **Manage Rules**.
   The Conditional Formatting Rules Manager dialog box appears. The rules applied to the selected cells appear in the dialog box.
   Use these buttons to manage the rules:
   - **New Rule**: Create a brand new conditional formatting rule.
   - **Edit Rule**: Edit the selected formatting rule.
   - **Delete Rule**: Delete the selected rule from the worksheet.

   **Tip**: If a cell range is not selected where conditional formatting is applied, it is still possible to view all the rules in the worksheet. Click the **Show formatting rules for** list arrow and select **This Worksheet**.

4. Manage the formatting rules. Click **OK** when finished.

**Remove conditional formatting**

The Clear Rules command helps remove conditional formatting rules from the worksheet.

1. Click the **Home** tab on the Ribbon and click the **Conditional Formatting** list arrow in the Styles group.
2. Select the cell range.
3. Point to **Clear Rules**.
4. Select **Clear Rules from Selected Cells** or **Clear Rules from Entire Sheet**.

   Conditional formatting is cleared either from the cells selected or the entire worksheet.
Finding and Replacing Formatting

Excel’s Find and Replace features can find and/or replace formatting in addition to text and information.

1. Click the **Home** tab on the Ribbon and click the **Find & Select** button in the Editing group.

2. Select **Replace**.

   The Find and Replace dialog box appears, displaying the Replace tab.

   **Other Ways to Open Find and Replace:** Press **<Ctrl>+<H>**.

3. Click the **Options** button.

   The dialog box expands to display more search options.

4. Click the top **Format** button.

   The Find Format dialog box appears.

5. Select the formatting options to find and then click **OK**.

6. Click the bottom **Format** button.

   The Replace Format dialog box appears.

7. Select the new formatting options to use and click **OK**.

   Once the formatting options are set, Excel is ready to begin finding and replacing the formatting.

8. Click **Find Next** to find each occurrence of the cell formatting. Click **Replace** to replace the cell formatting.

   After replacing an occurrence, Excel automatically moves to the next occurrence; click Find Next to skip an occurrence without replacing the formatting.

**Tips**

- **Click Replace All** to replace all occurrences of the cell formatting at once.

- **To find other types of items**, click the **Find & Select** button and then select one of the Find options: Formulas, Comments, Conditional Formatting, Constants, or Data Validation.

---

**Exercise**

- **Exercise File**: Sales4-12.xlsx
- **Exercise**: Replace all bold formatting in the worksheet with bold italic formatting.

---

**Figure 4-25**: The Find & Select button on the Ribbon.

**Figure 4-26**: The Replace tab of the Find and Replace dialog box.

**Figure 4-27**: The formatting of headings in cell range B3:G3 is updated through finding and replacing formatting.
Formatting a Worksheet Review

Quiz Questions

1. Which of the following is NOT a type of font formatting?
   A. Bold
   B. Italic
   C. Underline
   D. Comma Style

2. Which of the following is NOT a type of number formatting?
   A. Number
   B. Accounting
   C. Dollar
   D. Percentage

3. The ______ feature automatically resizes columns or rows to best fit cell contents.
   A. AutoFit
   B. AutoSize
   C. AutoAdjust
   D. FitRight

4. It's possible to align cell contents horizontally but not vertically within a cell. (True or False?)

5. The Border list arrow is located in the ______ group on the Home tab.
   A. Alignment
   B. Clipboard
   C. Font
   D. Number

6. Click the Format Painter button once to apply it once or twice to apply it multiple times. (True or False?)

7. Excel contains preset formatting styles that can be quickly applied to cells. (True or False?)

8. Which of these formatting properties can be included in style formatting?
   A. Number
   B. Font
   C. Fill and Border.
   D. All of these.

9. Document themes consist of:
   A. Theme colors
   B. Theme fonts
   C. Theme effects
   D. All of these
10. _______ allows highlighting of cells that meet specific criteria.
   A. Conditional formatting
   B. Font formatting
   C. Filtering
   D. Find and replace

11. Which of the following is not a conditional format that can be applied to cells?
   A. Data Bars
   B. Characters
   C. Color Scales
   D. Icon Sets

12. It's possible to preview how a new conditional formatting rule looks before applying it. (True or False?)

13. It is not possible to edit a conditional formatting rule after it's been created. (True or False?)

14. Which of the following types of items can NOT be found using Excel’s Find feature?
   A. Formulas
   B. Comments
   C. Conditional Formatting
   D. Styles
Quiz Answers

1. D. Comma Style is not a type of font formatting.
2. C. Dollar is not a type of number formatting.
3. A. AutoFit resizes columns or rows to best fit cell contents.
4. False. You can align cell contents vertically and horizontally within a cell.
5. C. The Border list arrow is located in the Font group.
6. True. Click the Format Painter button once to apply it once or twice to apply it multiple times.
7. True. Excel contains preset formatting styles that are all ready for you to apply to cells.
8. D. Number, Font, Fill and Border, are all available in cell styles. You can also include Alignment and Protection formatting in the style.
10. A. Conditional formatting allows you to highlight cells that meet specific criteria.
11. B. Characters is not a conditional formatting option in Excel.
12. True. Click Preview in the New Formatting Rule dialog box to see how new conditional formatting will look before you apply it.
13. False. You can edit a conditional formatting rule.
14. D. Styles cannot be found using the Find feature.
Charts present data, relationships, or trends graphically. Charts are often better at presenting information than hard-to-read numbers in a table or spreadsheet.

In this chapter, learn how to create, edit and format dynamic looking charts.

**Using Exercise Files**
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Using Chart Templates ........................................ 105
  Save a chart as a template ............................ 105
  Create a new chart using a template ............... 105
  Delete a template ....................................... 105

Changing Chart Type ...................................... 106
  Swap data over the axes ................................ 106

Using Power View ......................................... 107
  Insert a Power View Sheet ......................... 107
  Adding a visualization to your Power View Sheet ........................................ 107

Using Sparklines .......................................... 108
  Insert a sparkline ................................... 108
  Change sparkline style ............................. 108
  Add data points to sparklines .................... 108
Choosing and Selecting the Source Data

Charts are a great way to share data and information. The foundation of charts is the data they illustrate. Choosing the right data is the first and most important step in creating a chart.

Choose the right data

When selecting a chart, it’s important to decide what data needs to be included in it.

- **What is the main point?**
  What is the purpose of the chart? Identify the point of the chart, and then include the data that illustrates this point and puts it in context.

- **What is the truth?**
  Avoid spinning the data. Communicate what the data shows, not what it should to say.

- **Keep it simple.**
  Only show the data that is relevant. This makes it easier to process the information that is important. Make sure that the rest of the data is available so that conclusions are backed up with ample evidence.

Select the data

Once data and labels are chosen to be included in the chart, select them.

1. Click and drag to select the desired cells to include in the chart. To select multiple non-adjacent cells, select a cell or cell range and hold down the `<Ctrl>` key while selecting other cells.

Tips

- ✓ If a value changes in the chart’s data source, that change is automatically updated in the chart.
- ✓ If labels are not included in the selected cell range, Excel will insert placeholders in the chart.

Exercise

- **Exercise File:** Survey5-1.xlsx
- **Exercise:** Select A4:D9 and A12:D12 and look at available options under Recommended Charts.

**Figure 5-1:** An example of results from a survey. Show that among all travel destinations, the most popular destination for trips taken for leisure is Europe.

**Figure 5-2:** In this example, the data labels in column A and row 4 are selected along with the values in A5:E9 and A12:E12.
**Recommended Charts**

Sometimes it’s helpful to let someone else do the thinking for you. By using the Recommended Charts button you can let Excel recommend charts that represent your data in the most efficient way.

1. Select your data set.
2. On the **Insert** tab, click **Recommended Charts**.
3. The Insert Chart window appears. On the **Recommended Charts** tab, you will see the charts that Excel recommends you use. Select the chart that best suits your application and click **OK**.

Your chart is inserted into your worksheet.

**Tip:** On the Insert Chart window, you will also see the **All Charts** tab. To see the charts that excel recommends in more categories, click this tab.

**Using Quick Analysis**

The Quick Analysis function lets you convert your data into a chart or table with just a few simple steps.

1. Select a data range.
2. Click the **Quick Analysis** button that appears on the bottom right of the data range.
3. Select the **Charts** tab from the menu.

The charts that Excel recommends are displayed in the gallery.

4. Select the Chart that you prefer.

Your chart is inserted into your worksheet.

**Trap:** Be careful when selecting your data. The Quick Analysis button will not appear when using the <Ctrl> key to make multiple selections. Similarly, if you include any headings in your selection it will also not appear, so ensure that you have only selected the relevant data range.
Choosing the Right Chart

Once results are determined that the chart is to display, choose the chart that best suits this purpose. The most popular charts are column, line, pie, and bar charts.

Exercise

- Exercise File: None required.
- Exercise: Review the different types of charts available in Excel.

<table>
<thead>
<tr>
<th>Table 5-1: Chart Types in Excel</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Column</strong></td>
</tr>
<tr>
<td><strong>Line</strong></td>
</tr>
<tr>
<td><strong>Pie</strong></td>
</tr>
<tr>
<td><strong>Bar</strong></td>
</tr>
<tr>
<td><strong>Area</strong></td>
</tr>
<tr>
<td><strong>XY (Scatter)</strong></td>
</tr>
<tr>
<td><strong>Stock</strong></td>
</tr>
<tr>
<td><strong>Surface</strong></td>
</tr>
<tr>
<td><strong>Radar</strong></td>
</tr>
<tr>
<td><strong>Combination</strong></td>
</tr>
</tbody>
</table>
Inserting a Chart

Once the type of chart to use is chosen, insert the chart in the worksheet.

1. Make sure the cell range containing the data and labels to chart are selected.
   ✓ Tip: Chart non-adjacent cells by holding down the <Ctrl> key while selecting the cells.

2. Click the Insert tab on the Ribbon.

3. Click a chart type button in the Charts group.
   A list of charts for the selected chart type appears.

4. Select the chart to use from the list.
   The chart appears in the worksheet and the Chart Tools tab appears on the Ribbon. The Chart Tools include three new tabs—Design, Layout and Format—that help modify and format the chart.

Tips
✓ To see all available chart types, click any chart type in the Charts group, and then select All Chart Types. The Insert Chart dialog box appears, displaying every chart type that is available.

Move a chart within a worksheet

Usually, it may be necessary to move a chart after it is inserted because it covers up the data on the worksheet.

1. Select the chart.

2. Point to the chart’s border.
   The pointer changes to a cross-arrow pointer.

3. Click and drag the chart in the worksheet.

Move a chart to another worksheet

Move a chart to another worksheet as an embedded object or move it to its own worksheet.

1. Under Chart Tools on the Ribbon, click the Design tab and click the Move Chart button in the Location group.
   The Move Chart dialog box appears, displaying two options:
   • New sheet: Moves the chart to its own worksheet.
   • Object in: Allows the chart to be embedded in another existing worksheet.
2. Select the option to use and enter or select a worksheet name.

3. Click **OK**.

**Resize the chart**

1. Select the chart.
   
   Eight sizing handles appear along the chart edges once it is selected.
   
   ✔ **Tip:** Clicking a chart displays the Chart Tools on the Ribbon, which include the Design, Layout, and Format tabs.

2. Click a sizing handle and drag it to resize the chart.
   
   ✔ **Tip:** A faint outline appears as the chart border is dragged so that a preview of the size of the chart appears before releasing the mouse button.

◊ **Other Ways to Resize a Chart:**
   
   Under Chart Tools on the Ribbon, click the **Format** tab and use the Height and Width fields in the Size group.

![Figure 5-7: To resize a chart, click and drag the corner of the chart.](image)
Editing, Adding, and Removing Chart Data

After inserting the chart, the data will probably still be changed. Edit, add, and remove chart data even after inserting the chart.

Edit chart source data

The values in a chart are linked to the worksheet data from which the chart is created. If the source data is changed, the chart will automatically chart the new values.

1. Replace and edit values in the source data.
   The changes are automatically reflected in the chart.

Add a data series

It’s possible to add data to a chart after it has been created. Here’s how to add a data series:

1. Select the chart; then click the Design tab and click the Select Data button in the Data group.
   The Select Data Source dialog box appears.

2. Click the Add button under Legend Entries (Series).
   The Edit Series dialog box appears.

3. In the “Series name” box, select the name of the series from the worksheet or type the series name.

4. In the “Series values” box, select the data range of the data series or type the cell range reference.
   Tip: Remove placeholder text before selecting the series values. For example, if a {1} appears in the Series values text box, remove these characters so only the equals sign (=) remains. Then enter or select values.

5. Click OK.
   The Edit Series dialog box closes.

6. Click OK.
   The Select Data Source dialog box closes, and the data is added to the chart.

Other Ways to Add Data to a Chart:
If the chart uses adjacent cells for source data, click and drag the sizing handles around the source data on the worksheet.

Exercise

Exercise File: Survey5-4.xlsx

Exercise: Change the value in cell B7 to “134”.
Add the “Total” data series to the chart.
Add the “Middle East” category to the chart.
Remove the “Total” data series from the chart.

Figure 5-8: The Select Data Source dialog box.

Figure 5-9: Adding a new data series.

Figure 5-10: Another way to add and remove data in a chart is to click and drag the sizing handles around the source cells. These sizing handles only appear if the source data is adjacent.
Copy data into a chart

Another way to add data to a chart is to copy it into the chart. This is useful if the chart uses non-adjacent cells for source data or if the chart and source data are not on the same worksheet.

1. Select the cells containing the data to add to the chart, including labels for the data.
2. Click the Home tab on the Ribbon and click the Copy button in the Clipboard group.
   The data is copied to the clipboard.
3. Select the chart to add the data to.
4. Click the Paste button in the Clipboard group.
   The chart is updated to include the pasted data.

Remove a data series

To simplify a chart or to get rid of some data, it’s easy to remove a data series from the chart.

1. Under Chart Tools on the Ribbon, click the Design tab and click the Select Data button in the Data group.
   The Select Data Source dialog box appears.
2. Select the data series to remove under Legend Entries (Series).
3. Click the Remove button under Legend Entries (Series).
   Other Ways to Delete Data:
   Select the source data to be removed from the chart and press <Delete>.
4. Click OK.
Changing Chart Data

Once data is in a chart, there are some tweaks and changes that need to be made. Here are a few ways to change the data in a chart.

Change the source cell range

To use a new set of data for a chart, change the data source.

1. Under Chart Tools on the Ribbon, click the Design tab and click the Select Data button in the Data group.
   The Select Data Source dialog box appears.

2. Click the Chart Data Range reference button and select the cell(s) to use as the data source. Press and hold the <Ctrl> key to include non-adjacent cells in the data source.

3. Press <Enter>.
   The Select Data Source dialog box expands. The new cell range for the source data is selected in the Chart data range text box.

4. Click OK.
   The dialog box closes and the chart is updated with the new data.

Rename or edit a data series

Charts are not completely tied to the source data. It’s possible to change the name and values of a data series without changing the data in the worksheet.

1. Under Chart Tools on the Ribbon, click the Design tab and click the Select Data button in the Data group.
   The Select Data Source dialog box appears.

2. Select the series to change under Legend Entries (Series).

3. Click the Edit button.
   The Edit Series dialog box appears.

4. In the “Series name” box, type the desired label to use for the series, or select the label from the worksheet.
   Tip: Even if a name for the data series is typed, that name is not added to the worksheet, it only appears in the chart.

Exercise

- Exercise File: Survey5-5.xlsx
- Exercise: Change the source cell range to A4:D4, A6:D9, A12:D12.
  Rename the “Other” data series “Adventure” without changing the source data.
  Reorder the data series to this order:
  Leisure
  Business
  Adventure
  Rename the “United States” category “U.S.”
  Filter the data so that the chart only shows a comparison for Leisure in Europe and Australia. Undo the Filter.
5. In the “Series values” box, select the data range of the
data series, or type the cell range reference.

**Other Ways to Enter Cell Range Values:**
Type values for the data series in the “Series
values” box. These values will not be added to the
worksheet; they only appear in the chart.

6. Click **OK**.

The Edit Series dialog box closes and the updated
series label appears in the Select Data Source dialog
box.

7. Click **OK**.

The Select Data Source dialog box closes and the
changes are displayed in the chart.

**Reorder the data series**
Change the order of data in the chart without changing the
order of the source data.

1. Under Chart Tools on the Ribbon, click the **Design**
tab and click the **Select Data** button in the Data group.

   The Select Data Source dialog box appears.

2. Select the data series to move under Legend Entries
(Series).

3. Click the **Move Up** or **Move Down** arrows to reorder
the data series.

   The chart is updated to display the new order of data.

**Update horizontal axis labels**
Update or change the horizontal axis labels by selecting a
cell range of labels in the worksheet.

1. Under Chart Tools on the Ribbon, click the **Design**
tab and click the **Select Data** button in the Data group.

2. Click the **Edit** button under the Horizontal (Category)
Axis Labels.

3. Select the desired range of cells to use for the axis
labels.

4. Click **OK**.

**Other Ways to Update Axis Labels:**
Edit the label in the source data.
Filtering Chart Data

Sometimes you’ll find it necessary to edit the data points and names that are visible in a chart.

1. Select the chart that you want to format.

2. Click the Chart Filters button.[1]
   A contextual menu appears with a VALUES tab and a NAMES tab.

3. Under the Series section, a list of all the available Series is shown. To add a Series to a chart, check the box next to it, and it is immediately displayed.

4. To remove a Series, deselect the box next to it, and it is immediately removed.

5. Further down, you’ll see the Categories section. To have a Category included on your chart, check the box next to it.

6. If you want to remove a Category, uncheck the box next to it and it will be removed.

7. To show or hide the Names of Series or Categories, click the Names tab.

8. Under the Series section, you’ll see Names of Series that are part of the data you selected. To include a Name and have it displayed in the chart, check the circle next to it.

9. To remove a Name of a Series, uncheck the circle next to it and it will not be displayed.

10. Under the Categories section, you’ll see the Names of Categories specific to your chart. To have the Name of a Category displayed, check the circle next to it.

11. To remove a Name of a Category, uncheck the box next to it.

12. Once you are done making changes, click Apply.

Figure 5-15: Contextual formatting menu appears when a chart is selected.
Changing Chart Layout and Style

An easy way to change the look and feel of a chart is by applying one of the built-in layouts and styles that are available in Excel 2013.

Apply a chart layout

Built-in chart layouts can quickly adjust the overall layout of a chart with different combinations of titles, labels, and chart orientations.

1. Select the chart.
   The Chart Tools appear on the Ribbon.

2. Under Chart Tools on the Ribbon, click the Design tab.
   Here are the Chart Layouts and Chart Styles groups.

3. Select the option to use from the Chart Layouts gallery in the Chart Layouts group. Or, click the Quick Layout button in the Chart Layouts group and select an option.
   The chart changes to the selected layout.

Apply a chart style

Built-in chart styles allow adjustments of the format of several chart elements all at once. Styles quickly change colors, shading, and other formatting properties.

1. Select the chart.
   The Chart Tools appear on the Ribbon.

2. Under Chart Tools on the Ribbon, click the Design tab.

3. Select the option to use from the Chart Styles gallery in the Chart Styles group.
   The new style is applied.

Tip:

✓ The Chart Layouts and Chart Styles groups offer many formatting options. A few are displayed by default; for more, click the arrow buttons to scroll down and access additional layouts and styles, or click the More button to expand a gallery.

Another way to change the Style or Colors on your chart: Click the contextual Chart Styles button next to the chart. Select a different Style or color scheme for your chart.
Working with Chart Labels

Another option is to use a specific layout for the chart’s labels; add, remove, and format the labels as needed.

Edit chart label text

It’s easy to edit the text of a label that already appears in the chart.

1. Select the chart and double-click the label to be edited. A cursor appears in the label.
2. Edit the label text and click the chart.

Tip:

✓ Text that is linked to worksheet data cannot be directly edited. To edit these labels, edit the labels and data in the actual worksheet.

Add or move a chart label

Labels can be moved to different locations or layouts on the chart.

1. Select the chart.
2. Under Chart Tools on the Ribbon, click the Design tab. In the Chart Layouts group, select Add Chart Element. There are several labels to choose from, as shown in Table 5-2: Chart Labels.

Tip:

✓ If not enough desired label options appear in the initial list, click the More Options button at the bottom of the list to display the Format dialog box, and fine-tune the label to your required specifications.

4. Select an option to use from the list. The label appears on the chart. If adding a chart or axis title, placeholder text will appear that can be replaced as necessary.

Tips:

✓ To add data labels to one data series, select that data series instead of the entire chart area.
✓ Mouse over the label options in the list to see them previewed on your chart before making your selection.

Exercise

- Exercise File: Survey5-7.xlsx
- Exercise: Replace existing chart label placeholders: Add the text “Popular Leisure Destinations” to the chart title. Add the text “Responses” to the Primary Vertical Axis Title. Move the legend to the bottom of the chart. Remove the Primary Horizontal Axis Title from the chart.

Figure 5-18: Editing a chart label.

<table>
<thead>
<tr>
<th>Table 5-2: Chart Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Chart Title:</strong> Tells people what the chart is about.</td>
</tr>
<tr>
<td><strong>Axis Titles:</strong> Tells people about the data being charted on the axis.</td>
</tr>
<tr>
<td><strong>Legend:</strong> Displays the name of a data series in the chart.</td>
</tr>
<tr>
<td><strong>Data Labels:</strong> Labels the specific values of data in the chart.</td>
</tr>
<tr>
<td><strong>Data Table:</strong> Adds a table that contains all the data in the chart.</td>
</tr>
</tbody>
</table>
Other Ways to Add or Move a Chart Label:
Select the chart and click the button on the right and check the label you want to add. To move a label; click the arrow list button for placement options.

Format a chart label
Labels can be moved to different locations on the chart.

1. Double-click the label.
   The Format pane appears on the right with formatting options for the label.

2. Apply the formatting options to use and exit.

Remove a chart label

1. Select the chart.

2. Under Chart Tools on the Ribbon, click the Design tab.
   In the Chart Layout group, select Add Chart Element.

3. Locate the label option you want to remove and deselect it.
   The label will be removed from your chart.

Other Ways to Remove a Chart Label:
Select the chart and click the button on the right. Check the label you want to remove.
Changing the Chart Gridlines

Gridlines are the lines in the background of a chart that correspond to the values in the chart. In column and bar charts, gridlines make it easier to compare the values in the chart. Change how the gridlines stack up the data in the chart.

Choose major and minor gridlines

1. Select the chart.
2. Under Chart Tools on the Ribbon, click the Design tab and click the Add Chart Element button in the Chart Layouts group.
3. Select a gridline, or click More Gridline Options. A list appears with different display options for the vertical or horizontal gridlines. The table to the right, Table 5-3: Gridline Examples, offers an idea of available gridlines in Excel. The options for the vertical gridlines are the same, which would most likely be used for bar charts.
4. Select the gridline option to use. The chart is updated to show the gridlines as selected.

Format gridlines

Change the line formatting used in gridlines.

1. Select the chart.
2. Under Chart Tools on the Ribbon, click the Design tab and click the Add Chart Element button in the Chart Layouts group.
4. Choose the formatting to apply to gridlines and exit.

Tip: To hide gridlines, select the No Line option in the Format Major Gridlines pane.

Exercise

- Exercise File: Survey5-8.xlsx
- Exercise: Show major and minor horizontal gridlines on the chart.
  Remove horizontal gridlines from the chart.
  Display only major horizontal gridlines on the chart.

Table 5-3: Gridline Examples

<table>
<thead>
<tr>
<th>Primary Major Horizontal</th>
<th>Primary Major Vertical</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary Minor Horizontal</td>
<td>Primary Minor Vertical</td>
</tr>
</tbody>
</table>

Exercise File: Survey5-8.xlsx

Exercise:
- Show major and minor horizontal gridlines on the chart.
- Remove horizontal gridlines from the chart.
- Display only major horizontal gridlines on the chart.

Figure 5-21: The Format Chart Area pane.
Changing the Scale

The scale of the chart is how it displays units of measurement. For example, in what units should the data be shown (i.e. thousands, millions)? Should it show lines for every 20 units? How high should the scale be displayed? Here’s how to change the scale of the chart.

Change display units

Changing the display units makes it easier to read charts that have large values.

1. Select the chart.

2. Under Chart Tools on the Ribbon, click the Design tab and click the Add Chart Element button in the Chart Layouts group.

3. Select Axes and select an axes option.

   The chart is updated to show the units and the axis label shows the unit of measurement that is used.

   ✔ Tip: The axis chosen under the Axes button depends on the type of chart being used. If using a column chart, select the vertical axis. If using a bar chart, select the horizontal axis.

   ✨ Trap: If the Horizontal and Vertical axes are both active on a chart, you cannot use the More Axis Options to access axis specific options like Display Units and Scale. In such cases, right click individual axis labels and select Format Axis.

Exercise

• Exercise File: Survey5-9.xlsx

• Exercise: Change the display units for the vertical axis to thousands. Change it back to the default display units. Change the scale of the vertical axis: change the major unit to 25 and change the maximum to 150.

Figure 5-22: The Format Axis contextual menu.
Change the scale of the axis

The scale of the axis determines how information appears in the chart.

1. Select the chart.

2. Under Chart Tools on the Ribbon, click the Design tab and click the Add Chart Element button in the Chart Layouts group.

3. Select Axes and then select More Axis Options.
   The Axis Options tab is selected. Refer to Table 5-4: Format Axis Dialog Box for a description of the formatting options available in this tab.

4. Select the axis display options to use and click Close.
   The scale of the chart is changed according to the options chosen.

Other Ways to Change Display Units:
Right-click an axis in the chart and select Format Axis from the contextual menu.

Change number formatting for axis values

Change the number formatting used in an axis. For example, if the axis displayed is a monetary value, change the formatting to display the numbers with a currency symbol.

1. Select the chart.

2. Under Chart Tools on the Ribbon, click the Design tab and click the Add Chart Element button in the Chart Layouts group.

3. Select an axis and select More Axis Options from the list.
   The Format Axis pane appears on the right.

4. Click the Number tab and select the number formatting to be used.

5. Click Close.
   The formatting is applied to the axis.

Other Ways to Change Number Formatting:
Right-click an axis in the chart and select Format Axis from the contextual menu. Click the Number tab in the Format Axis pane.

Tips

✓ If the source data already has specific number formatting, it will be reflected in the chart axes.

<table>
<thead>
<tr>
<th>Table 5-4: Format Axis Dialog Box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Minimum/maximum values</strong></td>
</tr>
<tr>
<td><strong>Major/minor unit</strong></td>
</tr>
<tr>
<td><strong>Display units</strong></td>
</tr>
<tr>
<td><strong>Major/minor tick mark type</strong></td>
</tr>
<tr>
<td><strong>Axis labels</strong></td>
</tr>
</tbody>
</table>

Figure 5-23: The Format Axis pane
Emphasizing Data

One way to emphasize data is to change the formatting of a specific piece of data or a data series so it stands out from the rest of the chart.

Change the color of data series

Make a data series stand out by applying a different color to the series.

1. Select the chart and click the Format tab on the Ribbon.
2. In the Current Selection group, click the Chart Elements arrow list and select the data series to change.
3. Click the Format Selection button in the Current Selection group.

The Format Data Series pane appears on the right.

Other Ways to Format the Data Series:
Double-click a data point in the series. Or, right-click a data point and select Format Data Series from the contextual menu.

5. Click the Fill tab and apply the fill properties to be used for the data series.

The formatting is applied to the data series.

Change the color of a single data point

If a single piece of data is the focus in a chart, change the formatting of that data to make it stand out.

1. Click the data series of which the data point is a part.

Once the data series is selected, click the single data point again to format the individual data point.

2. Double-click the data point to format.

The Format Data Point pane appears.

3. Click the Fill tab and apply the fill properties to use for the data point.

The formatting is applied to the data point.

Exercise

- Exercise File: Survey5-10.xlsx
- Exercise: Emphasize the Business data series with an orange fill color. Emphasize the European Leisure data point with a dark orange fill color. Insert Data Labels on the chart and show the Values above the Series.

Figure 5-24: Changing the color of a data series in the chart.

Figure 5-25: Changing the color of a single data point makes it stand out from the rest of the data series and chart.
Formatting your data labels

With enhanced formatting options, you can now create data labels that present your data professionally, but that are also fun to look at.

1. Select the chart that has the labels you want to change.
2. Click the Chart Elements button.
3. Make sure that Data Labels is checked. Hover over Data Labels and then click on the little arrow to its right.
4. A small contextual menu appears with some options for the placing of your labels. To see more formatting options, click More Options…
5. The Format Data Labels menu appears. From here you can make creative changes to your labels that display the data more effectively. As you make the changes, your labels are formatted. This way you can see what your changes will look like before you move on.

Figure 5-26: Formatting the Data Labels on the chart

Figure 5-27: Data Labels on a Bar Chart
Annotate the chart
Add trend lines and other analytical elements to the chart using the Analysis commands.

1. Select the chart.
2. Under Chart Tools on the Ribbon, click the Design tab.
3. Click Add Chart Element in the Chart Layouts group.
4. Select Trendline and then select a type to suit your needs from the options available or click More Trendline Options.

A Confirmation Dialog box will open asking you which data series you want to base your Trendline on. Make your selection and click OK.

If More Trendline Options is selected, you will first need to select which data series to base your Trendline on and only when clicking OK, will further Trendline options appear on the Format Trendline pane.

Use a different chart type for a data series
Another way to make a data series stand out from the rest of the chart is to apply a different chart type to that series. This is called a combination chart. Combining charts can be a powerful way to show overarching trends in data.

One of the most common ways to do this is to make one of the data series in a column chart a line chart.

1. Right-click a single data series in the chart and select Change Series Chart Type from the contextual menu.
2. Use the arrow list options below the chart preview, to select a new chart type for the single data series.

Figure 5-28: An example of an annotated combination chart. The Net Inc. data series uses a line chart type, while a linear trend line appears across the top of the chart.

Figure 5-29: The Change Chart Type dialog box.
Using Chart Templates

Save a template of a chart with customized layouts and formatting. Then use the template to create similar charts in the future.

Save a chart as a template

When a chart is saved as a template that chart’s properties are then saved for easy future use.

1. Select which chart to save as a template.
2. Right-click the chart and click the Save as Template from the contextual menu.
   The Save Chart Template dialog box appears.
3. Type a name for the template in the File name box and click Save.

Create a new chart using a template

Once a template is saved, use that template to create a new chart.

1. Open a workbook and select the cell range to chart.
2. Click the Insert tab on the Ribbon and click the Dialog Box Launcher in the Charts group.
   The Insert Chart dialog box appears. Select the All Charts tab.
3. Click the Templates folder in the list on the left.
   The saved templates appear in the gallery.
4. Select the template to use from the gallery on the right and click OK.

Delete a template

If a certain chart template is no longer needed, it can be deleted.

1. Click the Insert tab on the Ribbon and click the Dialog Box Launcher in the Charts group.
   The Insert Chart dialog box appears. Select the All Charts tab.
   Click the Templates folder in the list on the left.
2. Click the Manage Templates button at the bottom.
3. Right-click the template file and select Delete.
   The template is deleted.
Changing Chart Type

Different types of charts are better for presenting different types of information. For example, a column chart is great for comparing values of different items, but not for illustrating trends or relationships. If a previously created chart isn’t the best fit for the data, switch to a different chart type.

1. Select the chart.
   The Chart Tools tab appears on the Ribbon.

2. Under Chart Tools on the Ribbon, click the Design tab.

3. Click the Change Chart Type button in the Type group.
   The Change Chart Type dialog box appears. It shows the different types of charts available.

4. Select a chart type in the list on the left, then select a chart sub-type from the list on the right.

5. Click OK.

Tip:
Create a combination chart. Right-click a single data series in the chart and select Change Series Chart Type from the contextual menu. Select a new chart type for the single data series.

Swap data over the axes

Switch the rows and columns of data in a chart so they appear in opposite positions.

1. Select the chart.

2. Under Chart Tools on the Ribbon, click the Design tab.

3. Click the Switch Row/Column button in the Data group.
   The chart is updated to the new data configuration.

Trap: If the source data is too complicated (includes lots of nonadjacent cells), Excel cannot swap data over the axes.

Exercise File: Survey5-12.xlsx

Exercise: Change the chart to a “Stacked Column” chart type.
Change the chart to a pie chart. Swap the data over the axis to view data for Business, Leisure, and Other responses.

Figure 5-31: Selecting a Stacked Column chart in the Change Chart Type dialog box.

Figure 5-32: Sometimes it’s necessary to swap data over the axis to view the correct data after changing chart type.
Using Power View

Power View enables you to see enhanced and detailed insights into your data, and allows you to put your data into various presentation forms; but this feature is only available in Office Professional Plus and Office 365 Professional Plus versions.

Insert a Power View Sheet

Before you can start working in Power View, make sure that your data is correct and that it is displayed in a table.

1. Highlight the data that you want to use in Power View.
2. Click the Insert tab on the Ribbon.
3. Click on the Power View button in the Reports group.
   - Trap: If you have not used Power View before, you may need to enable it first. If the Add-ins window appears, click Enable.
   - Trap: Microsoft Silverlight must be installed on your PC. If you don’t already have it, install it so that Power View can render all the objects you are going to use. Once you’ve installed it, click Reload.
4. You should now have a blank Power View sheet. Click in the Title text box at the top of the sheet and give your sheet a title.
5. In the field list on the right side of the screen, check the check boxes of the fields you want displayed on the sheet.
   Your sheet will have a table on it.

Adding a visualization to your Power View sheet

Charts are a great way to show off data in a creative and intuitive way.

1. Select your table.
2. On the Design tab, select a chart type from the Switch Visualizations group.
   Your data is displayed in the visualization you chose.

   Tip: If you change data in your original work sheet, you can refresh your Power View sheet by right-clicking on your table and selecting Refresh from the contextual menu.

Exercise

- Exercise File: Mileage.xlsx
- Exercise: Insert a Power View report on the Mileage data and display the data in a Column Chart.
Using Sparklines

*Sparklines* provide a way to chart information in the individual cells of a worksheet. Sparklines are a great way to show a snapshot of data on a worksheet.

**Insert a sparkline**

1. Click the **Insert** tab on the Ribbon.
   
   **Tip:** There are three types of sparklines available to insert. Refer to the table to the right, Table 5-5: Available Sparklines for more information about each type.

2. Click a sparkline to insert in the Sparklines group.
   
   A dialog box appears, asking to define the range of cells that contain the data on which to base the sparklines.

3. Select the data to use in the sparkline.

4. Click **OK**.
   
   The sparkline is inserted in the cell(s).

**Change sparkline style**

1. Select the sparkline(s).

2. On the **Design** tab, click the **More** list arrow button in the Style Gallery and choose the formatting to apply to the sparkline(s).
   
   The sparklines are updated with the new style formatting.

**Add data points to sparklines**

1. Select the sparkline(s).

2. On the **Design** tab, in the Show group; click the check boxes for points to show or highlight on the sparkline.
   
   The sparkline is updated to show the points selected.

**Tips**

- One advantage of using sparklines is that, unlike charts, sparklines are included when the worksheet that contains them is printed.
Creating and Working with Charts

Review

Quiz Questions

1. Which of these is an important thing to consider when selecting data for a chart?
   A. What is the main point?
   B. Keep it simple.
   C. What is the truth?
   D. All of these.

2. If you want to quickly create a chart using an available data range, the only way to do so, is to use Quick Analysis (True or False?)

3. Which of these chart types would be best for illustrating values as a percentage of a whole?
   A. Area
   B. Pie
   C. Scatter
   D. Column

4. A line chart
   A. displays trends over time.
   B. compares values across categories.
   C. displays the contribution of each value to a total.
   D. compares pairs of values.

5. To create a chart, click the
   A. Home tab.
   B. Insert tab.
   C. Data tab.
   D. Formulas tab.

6. Which of these statements is false?
   A. Horizontal axis labels can be changed without affecting the source data.
   B. The order of data series can be changed without affecting the source data.
   C. Data series labels can be changed without affecting the source data.
   D. The chart source cell range can be changed in an existing chart.

7. To remove a chart label, select the label and press <Delete>. (True or False?)

8. Which of these options is NOT true?
   A. Gridlines can be displayed for both the horizontal and vertical axes.
   B. All gridlines can be removed from a chart by choosing None for the axis.
   C. Gridlines can only be displayed using default settings.
D. Major and minor gridlines can be shown at the same time.

9. Which of these is a way to change the scale of a chart?
   A. Change the display units of an axis in the chart.
   B. Change the minimum or maximum value displayed in the chart.
   C. Add number formatting to values in an axis.
   D. All of the above.

10. It’s possible to double-click a chart element to change its formatting. (True or False?)

11. If a previously saved chart element is no longer needed, it can be deleted. (True or False?)

12. Chart type cannot be changed after a chart is created. (True or False?)

13. What is a sparkline?
   A. A way to combine two different chart types in a chart.
   B. A summary of all the charts in a workbook.
   C. A printout of a chart.
   D. A snapshot of data on a worksheet.

**Quiz Answers**

1. D. Consider all of these when selecting data: the main point, the truth, and simplicity.

2. False. To quickly insert a chart, you can use Quick Analysis or the Recommended Charts function.

3. B. Pie charts are best for showing values as a percentage of a whole.

4. A. A line chart displays trends over time.

5. B. To create a chart, click the Insert tab, then select a chart type and chart in the Charts group.

6. A. Horizontal axis labels are tied to the source data; they only change if the source data is changed.

7. False. To remove a chart label, click the label button in the Labels group and select None from the list.

8. C. Gridlines can be formatted to use whatever color, style, and width preferred.

9. D. All of these are ways to change the scale of a chart.

10. True. Double-click a chart element to change its formatting.

11. True. If a previously saved chart template is no longer needed, it can be deleted.

12. False. The chart type can be changed after it is created.

13. D. A sparkline is a snapshot of data on a worksheet.
Managing Workbooks

Using Workbook Views ........................................... 113
  Change workbook views .................................. 113
  Zoom in or out of a worksheet ......................... 114

Selecting Worksheets in a Workbook .............. 115
  Select a worksheet ...................................... 115
  Select multiple worksheets ......................... 115

Inserting and Deleting Worksheets ............... 116
  Rename, move and copy worksheets ................. 117
    Move or copy a worksheet using click and drag 118

Splitting and Freezing a Workbook Window ... 119

Creating Headers and Footers ...................... 121
  Create a basic header or footer .................. 121
  Use Auto Headers & Footers ....................... 121
  Insert Header & Footer Elements ............... 122

Hiding Rows, Columns, Worksheets and Windows ........................................... 123

Setting the Print Area ........................................ 125
  Set print area ......................................... 125
  Move a page break ................................... 126
  Insert a manual page break ....................... 126
  Remove a page break ................................ 126

Adjusting Margins and Orientation ............. 127

Adding Print Titles, Gridlines and Headings ... 128

Adjusting Size and Scale .............................. 130
  Adjust paper size .................................. 130
  Scale to Fit ........................................ 130

Advanced Printing Options ....................... 131
  Print multiple worksheets ......................... 131
  Print multiple worksheets ......................... 131

Working with Multiple Workbooks ............. 132
  Switch between workbook windows ............... 132
  View multiple workbooks at once ............... 132
  Create another workbook window ............... 132

Creating a Template .................................. 134

Protecting a Workbook ................................. 135
  Add password protection .......................... 135
  Protect workbook structure and windows .... 135

Once a workbook is being filled up with data, it can be difficult to organize and view it all at once.

Luckily, Excel offers several options for viewing and working with data and windows: split windows, insert new worksheets, copy worksheets, work with multiple workbooks at once, hide data, protect and share workbooks.

In this chapter, take a look at ways to make viewing and working with data easier.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Protecting Worksheets and Worksheet Elements 137
Make cells editable in a protected worksheet ................................................................. 137
Make graphics editable in a protected worksheet ................................................ 137
Hide formulas in a protected worksheet .. 138
Protect a worksheet ................................. 138

Sharing a Workbook ........................................... 139
Share a workbook .................................... 139
Save and send a workbook ................. 139

Online Collaboration ................................. 141
Sharing a workbook by Inviting People ... 141
Sharing a workbook by sending a Link.... 141
Sharing a workbook via Social Networks 142
Using Workbook Views

There are several ways to change how a workbook’s contents are displayed on a screen using Workbook views. Zoom in or out to view more or less of a workbook at a time.

Change workbook views

1. Click the View tab on the Ribbon.

2. Click the button for the view to use in the Workbook Views group.

The workbook’s contents are shown in the selected view.

Other Ways to Change Workbook View:

Click the button for the view to use in the status bar of the workbook window.

Excel offers several different workbook views:

- **Normal view**: This is the default Excel view, and the one most usually used when creating and editing workbooks. Row and column headers are displayed.

- **Page Layout view**: Use this view to fine-tune a worksheet before printing, especially if it contains charts. Edit the worksheet like it’s in Normal view, but the rulers can also be seen, change page orientation, work with headers, footers and margins, and hide or display row or column headers.

- **Page Break Preview view**: This view shows where the page breaks will occur if the worksheet is printed. This is helpful for making sure the data is laid out correctly to appear on the desired page(s).

- **Custom view**: Use this view to arrange the view page as preferred. Click Add to create a new view, type a name, and select the features to include. Then, click OK.

Exercise

**Exercise File**: Bookings6-1.xlsx

**Exercise**: View the worksheet in Excel’s different views. Zoom in to 200 percent, then zoom back to 100 percent.
Managing Workbooks

**Zoom in or out**

Sometimes it is helpful to make a worksheet appear larger on the computer’s screen, especially if the computer has a small monitor or the user has poor eyesight. It can also be helpful to zoom out to see how the whole worksheet looks.

1. Click and drag the **Zoom** slider on the status bar to the percentage zoom setting desired.

   **Other Ways to Zoom:**
   Click the **View** tab on the Ribbon and click the **Zoom** button in the Zoom group. Or, click the **Zoom to Selection** button in the Zoom group to zoom in on the currently selected cell(s).

**Create a custom view**

Save the view and print settings by creating a custom view so they don’t have to be reapplied over and over.

1. Click the **View** tab on the Ribbon and click the **Custom Views** button in the Workbook Views group.
   
The Custom Views dialog box appears.

2. Click the **Add** button and type a name for the view in the **Name** text box.
   
   There are two additional settings here:
   - **Print settings:** Saves print settings such as page breaks.
   - **Hidden rows, columns and filter settings:** Keeps columns and rows hidden and any applied filters filtered.

3. Select the settings to use in the view and click **OK**.
   
   Now the view settings are quickly accessible under the new custom view.

**Tips**

- To view a custom view, click the **View** tab on the Ribbon and click the **Custom Views** button in the Workbook Views group. Select the view to use and click **Show**.
Selecting and Switching Between Worksheets

By default, Excel workbooks contain three worksheets. Make one worksheet active at a time or select multiple worksheets at once.

Switching between worksheets

Switch between worksheets in a workbook by selecting a different sheet’s tab.

1. Click the sheet tab to display the selected worksheet.
   
   The worksheet becomes active; it can now be viewed and edited.

Other Ways to Select a Worksheet:

Right-click the tab scrolling buttons and select the worksheet from the contextual menu. Or, use the tab scrolling buttons to scroll through the sheet tabs and then select one.

Select multiple worksheets

Selecting multiple worksheets at once allows data to be entered or edited on multiple worksheets, as well as formatting or printing multiple worksheets at once.

- **To select adjacent worksheets:** Click to select the first sheet tab, press and hold the `<Shift>` key and click to select the last desired tab.

  Both tabs and all tabs in between are selected.

- **To select non-adjacent worksheets:** Click to select the first sheet tab, press and hold the `<Ctrl>` key and click to select the other tabs.

- **To select all worksheets:** Right-click a sheet tab and click Select All Sheets from the contextual menu.

Tips

✓ When multiple worksheets are selected, [Group] appears in the title bar at the top of the worksheet.

✓ To cancel a selection of multiple worksheets in a workbook, click an unselected sheet’s tab. Or, right-click a sheet tab that is selected and select Ungroup Sheets from the contextual menu.
Inserting and Deleting Worksheets

It’s easy to add worksheets to a workbook or delete unwanted ones.

Insert a worksheet

1. Click the New Sheet tab.

A new worksheet is added to the workbook.

Tip: The New sheet tab is located next to the sheet tabs near the bottom of the workbook window.

Other Ways to Insert a Worksheet:
Press `<Shift> + <F11>`. Or, click the Home tab on the Ribbon and click the Insert list arrow in the Cells group. Select Insert Sheet. Or, right-click the tab of an existing worksheet, and select Insert from the contextual menu. Select Worksheet in the General tab of the Insert dialog box and click OK.

Delete a worksheet

1. Right-click the sheet tab to delete and select Delete from the contextual menu.

A dialog box appears to confirm the deletion.

2. Click Yes.

The worksheet is deleted.

Other Ways to Delete a Worksheet:
Select the desired worksheet to delete, click the Home tab on the Ribbon, click the Delete list arrow in the Cells group and select Delete Sheet.
Renaming, Moving, and Copying Worksheets

Manipulate workbooks by renaming worksheets and moving them into different orders and even into different workbooks.

Rename a worksheet

It’s a good idea to give worksheets more meaningful names than the default Sheet1, Sheet2, Sheet3, and so on.

1. Double-click the sheet tab.
   The sheet name is selected so that it can be renamed.

2. Type a new name for the worksheet.

3. Press <Enter>.
   The sheet is renamed.

**Other Ways to Rename a Worksheet:**
Right-click the sheet tab, select Rename from the contextual menu, and type a new name. Or, select the worksheet to rename, click the Home tab on the Ribbon, click the Format button in the Cells group and select Rename Sheet. Type a new name.

Move or copy a worksheet

Rearranging worksheets using the Move or Copy dialog box or by using the mouse is simple.

1. Select the sheet tab(s) for the worksheet(s).

2. Right-click one of the sheet tabs to move or copy and select Move or Copy from the contextual menu.

**Other Ways to Move or Copy a Sheet:**
Select the sheet(s) to move or copy. Click the Home tab on the Ribbon and click the Format button in the Cells group. Select Move or Copy Sheet from the list.

3. Select the sheet after which the moved or copied sheet(s) should appear in the Before Sheet list.
   The moved or copied sheet will be placed in front of the sheet that is selected.

**Tip:** Click the Create a copy check box to copy the selected sheet.

4. Click OK.
   The worksheet(s) are moved or copied to the new location.

---

**Exercise**

- **Exercise File:** Bookings6-3.xlsx
- **Exercise:** Rename Sheet1 to “Monday”.

Move the worksheets so the Monday thru Friday worksheets are in sequential order.

---

![Figure 6-6: Renaming a worksheet](image1)

![Figure 6-7: The Move or Copy dialog box.](image2)
Move or copy a worksheet using click and drag

The easiest way to move or copy a worksheet within a workbook is with the mouse.

1. Select the sheet to move or copy.

2. Click and drag the sheet tab to move it to a new location in the workbook. Or, press and hold the <Ctrl> key while clicking and dragging the sheet tab to copy the sheet.

Tips

✓ To change the color of a sheet tab, right-click the tab, point to Tab Color and select a color from the palette.
Splitting and Freezing a Window

Split or freeze a workbook window to allow holding certain sections of a worksheet in place while scrolling to view other areas. It is especially useful when working with a large worksheet because column and row headings can be locked in place while scrolling through the data in the rest of the worksheet.

Split a worksheet window

To view multiple areas of the worksheet in the same window, split the window into two or four panes. When a worksheet window is split, panes are created in the window. These panes can be navigated independently, allowing changes to be made and multiple areas of a worksheet to be viewed at once.

1. Select the desired cell to split the window.
   The worksheet will be split above and to the left of the active cell, creating four panes.
   - Tip: To split into only two panes, select a cell in the top or bottom-most visible row, or the left-most visible column.

2. Click the View tab on the Ribbon and click the Split button in the Window group.
   The worksheet is split into sections that can be navigated individually without moving other sections.

   Other Ways to Split the Window:
   - Click and drag the vertical split box or the horizontal split box to where the window is to split.

Adjust split panes

Adjust where the panes appear in the window after a split is created.

1. Click and drag the split line.
   The size of the window pane is changed according to where the pane is clicked and dragged.

Remove a worksheet window split

1. Click the Split button in the Window group.
   The window is no longer split.

   Other Ways to Remove a Window Split:
   - Click and drag the split line to the edge of the window.

Exercise

- Exercise File: Bookings6-4.xlsx
- Exercise: View the Tuesday worksheet.

Split the window at column C and scroll to the right in the right pane. Remove the split.
Set and freeze panes at column B and row 4. Scroll down to row 60.
Unfreeze the panes in the worksheet.
Freeze window panes

When panes are frozen, the panes above and to the left of the active cell are immobilized. This is different from splitting, in which each section can be navigated. Also, while split lines can be moved, frozen sections cannot be moved without unfreezing and freezing again.

1. Click the View tab on the Ribbon and click the Freeze Panes button in the Window group.

Here are three options:

- **Freeze Panes:** Freezes the worksheet above and to the left of the cell that is currently active. Creates two or four panes depending on the location of the active cell.
- **Freeze Top Row:** Keeps the top row visible and allows scrolling through the rest of the worksheet. Creates two panes.
- **Freeze First Column:** Keeps the first column visible and allows scrolling through the rest of the worksheet. This creates two panes.

2. Select the option to use from the list.

The panes are frozen. Use the scroll bars to move around in the worksheet.

Remove a worksheet window split

Now unfreeze the panes.

1. Click the Freeze Panes button in the Window group and select Unfreeze Panes.

All cells in the worksheet are unfrozen so it’s now possible to scroll freely throughout the entire worksheet.

![Figure 6-10: A worksheet with frozen panes: columns A-B, and rows 1-4. Information in the frozen panes remains on the screen as the worksheet is scrolled and moved through.](image)
Creating Headers and Footers

Use a header to include the same information at the top of every printed page or a footer to include information at the bottom of every page. Enter custom headers or footers, insert built-in ones, or insert specific elements such as pictures or page numbers.

Create a basic header or footer

1. Click the Page Layout tab on the Ribbon and click the dialog box in the Page Setup group.

2. Select the Header/Footer tab and format the header or footer.

   The header and footer areas are split into three sections—left, right, and center. Click Custom Header or Custom Footer to select these and other features, then click OK.

3. Click OK.

4. Click the View tab and click Page Layout in the Workbook Views group.

   The header and footer are now visible and can be edited.

5. Enter header text, then click away from the header area.

   When finished working with the header and footer, return to Normal view.

Other Ways to Create a Header or Footer:

Click the View tab on the Ribbon and click the Page Layout View button in the Workbook Views group. Click in the header or footer area.

Use Auto Headers & Footers

Instead of entering new header or footer text or fields, use built-in options that are already available.

1. Click the Insert tab on the Ribbon.

2. In the Text group, click Header & Footer.

   Now an auto header or footer can be added by using options available on the Design tab.

3. Select either the Header or Footer buttons in the Header & Footer group.

   A list of many different types of page numbers, titles, dates, and file paths that can be added appears.
Managing Workbooks

4. Select the auto header or footer.
   It is automatically inserted into the worksheet. Any manual header or footer information previously entered is replaced.

**Insert Header & Footer Elements**

Insert individual elements into the header or footer such as pictures or page numbers.

1. Click the Insert tab on the Ribbon and click the Header & Footer button in the Text group.

2. Click the button in the Header & Footer Elements group for the element to add.

**Tips**

✓ Headers and footers can be formatted using the commands in the Font group on the Home tab.

✓ Work with headers and footers by using the Page Setup dialog box. Click the Page Layout tab and click the Dialog Box Launcher in the Page Setup group. Click the Header/Footer tab. Edit headers and footers and select to withhold the header or footer from the first page or to designate different odd and even pages.

<table>
<thead>
<tr>
<th>Table 6-1: Header &amp; Footer Elements Group</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Button</strong></td>
</tr>
<tr>
<td>![Page Number]</td>
</tr>
<tr>
<td>![Number of Pages]</td>
</tr>
<tr>
<td>![Current Date]</td>
</tr>
<tr>
<td>![Current Time]</td>
</tr>
<tr>
<td>![File Path]</td>
</tr>
<tr>
<td>![File Name]</td>
</tr>
<tr>
<td>![Sheet Name]</td>
</tr>
<tr>
<td>![Picture]</td>
</tr>
<tr>
<td>![Format Picture]</td>
</tr>
</tbody>
</table>
Hiding Rows, Columns, Worksheets, and Windows

Hide rows, columns, worksheets and entire workbook windows from view. Data isn’t deleted, but simply hidden from view until it is unhidden.

Hide or unhide a row or column

It is simple to hide whole rows or columns from view.

1. Select the row or column heading(s).

2. Right-click the heading and select Hide from the contextual menu.

   The row(s) or column(s) are hidden.

   Other Ways to Hide a Row or Column: Select the row or column heading(s) for the row(s) or column(s) to hide. On the Home tab, click the Format button in the Cells group. Point to Hide & Unhide and select Hide Rows or Hide Columns.

Now look at how to unhide rows and columns.

3. Select the row or column heading(s) on both sides of the hidden row(s) or column(s).

   For example, if columns C and D were hidden, select the B and E column headings.

4. Right-click the heading and select Unhide from the contextual menu.

   Other Ways to Unhide a Row or Column: Select the row or column heading(s) on both sides of the hidden row(s) or column(s). On the Home tab, click the Format button in the Cells group. Point to Hide & Unhide and select Unhide Rows or Unhide Columns.

Hide or unhide a worksheet

Another option is to hide an entire worksheet.

1. Right-click the sheet tab for the worksheet to hide.

2. Select Hide from the contextual menu.

   Now unhide the sheet.

3. Right-click any sheet tab and select Unhide from the contextual menu.

Exercise

- Exercise File: Bookings6-6.xlsx
- Exercise: View the Tuesday worksheet.
  Hide columns E – G. Unhide them.
  Hide the Wednesday worksheet, then unhide it.
  Hide the Bookings workbook window, then unhide it.

Figure 6-13: A worksheet before and after hiding columns.

Figure 6-14: Selecting a hidden sheet to unhide.
4. Select the sheet to unhide in the Unhide dialog box and click **OK**.

**Other Ways to Hide and Unhide a Worksheet:**
Select the worksheet to hide. On the Home tab, click the **Format** button in the Cells group. Point to **Hide & Unhide** and select **Hide Sheet**. To unhide it, click the **Format** button in the Cells group, point to **Hide & Unhide**, and select **Unhide Sheet**. Click **OK**.

**Hide or unhide a workbook window**

Hide the entire active workbook window.

1. Click the **View** tab on the Ribbon.

2. Click the **Hide Window** button in the Window group.

   The active window is hidden. The Excel program window remains open and active, but the workbook is hidden. It does not even appear in the Switch Windows button or on the Taskbar.

   Here’s how to make the window reappear:

3. Click the **Unhide Window** button in the Window group.

   The window is unhidden.

**Tip:** If there is more than one window hidden, the Unhide dialog box will appear. Select which window to unhide and click **OK**.

---

![Figure 6-15: Selecting a hidden workbook to unhide.](image)
Managing Workbooks

Setting the Print Area

There are two ways to specify the workbook data that is printed: setting the print area and adjusting page breaks.

**Set print area**

To print part of a worksheet, define an area so that any time the worksheet is printed, only that cell range is printed.

1. Select the cell range to print.
2. Click the Page Layout tab on the Ribbon and click the Print Area button in the Page Setup group.
3. Select Set Print Area from the list.

Dashed lines appear around the new print area.

**Trap:** When a print area is set, only the print area that is defined prints. Clear the print area to return to the default page setup.

**Tip:**

✓ Once a print area is set, add additional print areas. Select the additional cells, click the Print Area button in the Page Setup group, and select Add to Print Area. The added area also has dashed lines around it.

**Clear print area**

Clear the print area and return to the default page setup.

1. Click the Page Layout tab on the Ribbon and click the Print Area button in the Page Setup group.

A list of print area options appears.

2. Select Clear Print Area from the list.

The print area is cleared.

**View page breaks**

Excel automatically breaks the page based on the margins and other page settings, but it’s also possible adjust these page breaks or add alternative breaks to divide a worksheet into separate pages for printing.

1. Click the View tab on the Ribbon and click the Page Break Preview button in the Workbook Views group.

**Tip:** The worksheet appears in Page Break Preview view. Dashed lines indicate automatic page breaks, while solid lines represent page breaks that have been changed or added.

---

**Exercise**

- **Exercise File:** Bookings6-7.xlsx

- **Exercise:** View the Tuesday worksheet. Set the print area to A1:E61.

  Move the page break after row 60 up to row 40.
  Add a page break after row 18, then remove the break.
Other Ways to Open Page Break Preview View:
Click the Page Break Preview button on the status bar.

Move a page break
Move existing page breaks in Page Break Preview view.

1. Position the mouse pointer over the page break line so the cursor changes.
2. Click and drag the page break to a new location.
   The dashed line turns into a solid line, indicating the break has been changed.

Insert a page break
Insert new vertical and horizontal page breaks in the workbook.

1. Right-click the cell below or to the right of where to insert the page break.
   Tip: It can be a little confusing to figure out which cell to click to insert a certain type of page break. See the table to the right for more information on where to click.
2. Select Insert Page Break from the contextual menu.
   The break is inserted.

Other Ways to Insert a Page Break:
Click the Page Layout tab on the Ribbon and click the Breaks button in the Page Setup group. Select Insert Page Break from the list.

Remove a page break
1. Click and drag the page break line outside of the Page Break Preview area.
   The page break is removed.

Other Ways to Remove a Page Break:
Select the cell below or to the right of where the page break will be inserted or removed. Click the Page Layout tab on the Ribbon and click the Breaks button in the Page Setup group. Select Remove Page Break. Select Reset All Page Breaks to remove all page breaks.

Figure 6-17: Moving a page break in Page Break Preview view.

Table 6-2: Inserting Page Breaks

| Horizontally | Select a cell in column A that is in the row below where the page break will be. |
| Vertically   | Select a cell in Row 1 that is in the column to the right of where the page break will be. |
| Horizontally and Vertically | Select the cell below and to the right of where the page break will be. |
Adjusting Page Margins and Orientation

Margins are the empty space between the worksheet data and the left, right, top, and bottom edges of the printed page.

Learning how to change the page orientation is also important to know. Everything Excel prints uses one of two orientations: portrait or landscape.

Adjust margins

By default, the margins in Excel worksheets are 0.75 inches at the top and bottom, and 0.70 inches to the left and right.

1. Click the Page Layout tab on the Ribbon and click the Margins button in the Page Setup group.
   A list of three margin options appears: Normal, Wide, or Narrow.

2. Select the margin size to use from the list.
   The margins adjust to the new setting.

   Tip: If the desired margin size is not one of the options on the list, select Custom Margins to display the Margins tab of the Page Setup dialog box. Set custom margins and even adjust the size of headers and footers.

Adjust orientation

Portrait orientation is the default setting for printing worksheets, but using the landscape orientation instead is also an option.

1. Click the Page Layout tab on the Ribbon and click the Orientation button in the Page Setup group.
   A list of two options appears:

   - Portrait: In Portrait orientation, the paper is taller than it is wide—like a portrait painting.
   - Landscape: In Landscape orientation, the paper is wider than it is tall—like a landscape painting.

2. Select the page orientation to use.
Adding Print Titles, Gridlines, and Row and Column Headings

Specify rows and columns to repeat on each printed page. Select whether to view or print cell gridlines and row and column headings.

Print row or column titles

The Print Titles command allows designating certain rows and columns to repeat on every printed page.

1. Click the Page Layout tab on the Ribbon and click the Print Titles button in the Page Setup group.
   
   The Page Setup dialog box appears, displaying the Sheet tab.
   
   In the Print titles area, there are two text boxes: “Rows to repeat at top” and “Columns to repeat at left.” Use the cell reference buttons next to the text boxes to select the ranges that contain the labels to repeat on every page.

2. Click the Rows to repeat at top or Columns to repeat at left cell reference button.
   
   The dialog box minimizes.

3. Select the rows or columns to appear on every printed page and click the cell reference button.

4. Click OK.
   
   Now when printing, the rows and/or columns selected will appear on every page.

View or print gridlines and headings

Choose whether to view or print the worksheet cell gridlines or the column and row headings.

1. Click the Page Layout tab on the Ribbon.
   
   The Sheet Options group has commands for working with the gridlines and headings in a workbook.
   
   - **Gridlines:** The gridlines that appear in the spreadsheet to delineate each cell by default. Select the Print option to print the gridlines with the data.
   
   - **Headings:** The column and row headings (A, B, C… and 1, 2, 3…) appear by default in the spreadsheet to help identify cells. Select the Print option so these headings are printed with the data.

2. Select the options to use in the Sheet Options group.

---

Exercise

- **Exercise File:** Bookings6-9.xlsx
- **Exercise:** View the Tuesday worksheet.
  
  Use the Print Titles command to make row 4 repeat on every page.
  
  Set Sheet Options to display gridlines and headings when printing.
Other Ways to Print Gridlines or Headings:
Click the Page Layout tab on the Ribbon and click the Dialog Box Launcher in the Sheet Options group. Select the option to use in the Print area. Select a different printed page order (“Down, then over” or “Over, then down”).

Figure 6-21: Worksheets without and with gridlines and headings.
Adjusting Paper Size and Print Scale

To print a worksheet on paper that isn’t Letter size, select a different paper size in Excel.

Tip:

✓ It’s also possible to adjust the scale of the printed worksheet so that the printed data stretches or shrinks to fit the number of pages specified.

Adjust paper size

Print Excel worksheets on many different sizes of paper.

1. Click the Page Layout tab on the Ribbon and click the Size button in the Page Setup group.

2. Select the paper size to use from the list.
   The worksheet layout updates to the new paper size.

Scale to Fit

Tell Excel how many pages wide or tall the data needs to be to fit when printed.

1. Click the Page Layout tab on the Ribbon.
   The Scale to Fit group has three options to choose from to adjust the worksheet’s scale for printing:
   
   • Width: Select the maximum width—in number of pages—the printed data will occupy.
   
   • Height: Select the maximum height—in number of pages—the printed data will occupy.
   
   • Scale: Enter a percentage or use the arrow buttons to stretch or shrink the printed output to a percentage of its actual size.

2. Select from the available options to adjust the scale as necessary.

Other Ways to Scale to Fit:

Click the Dialog Box Launcher in the Scale to Fit group to display the Page tab in the Page Setup dialog box. Select the options to use in the Scaling area.

Exercise

• Exercise File: Bookings6-10.xlsx
• Exercise: View the Tuesday worksheet.

In Page Layout view, adjust the paper size to Legal. Change the scale so that the worksheet fits onto 1 page wide by 1 page tall.

Print preview the worksheet.

Change the scale back to automatic width and height and return the paper size to Letter.
Printing a Selection, Multiple Worksheets, and Workbooks

Excel offers several ways to print: selected data, multiple worksheets, or an entire workbook can be printed.

Print selected data
Selecting data and then printing it allows complete control over what is printed.

1. Select the data to print.
2. Click the File tab and select Print.
3. Click the Print Active Sheets list arrow button and then select Print Selection from the list.
4. Click the Print button.

Print multiple worksheets
Print several worksheets at once.

1. Select multiple sheet tabs.
   Tip: To select adjacent tabs, press and hold the <Shift> key and select the first and last worksheet tabs to select. Or, to select non-adjacent tabs, press and hold the <Ctrl> key and click the desired tabs.
2. Click the File tab and select Print.
3. Click the Print button.

Print a single workbook
Printing a workbook prints all the worksheets in the workbook.

1. Open the workbook to print.
2. Click the File tab and select Print.
3. Click the Print Active Sheets button and select Print Entire Workbook from the list.
4. Click the Print button.

Exercise

- Exercise File: Bookings6-11.xlsx
- Exercise: Print or print preview cells A4:E30.

Print or print preview the Tuesday, Thursday, and Summary worksheets.

Exercise File: Bookings6-11.xlsx
Exercise: Print or print preview cells A4:E30.

Print or print preview the Tuesday, Thursday, and Summary worksheets.

Exercise

• Exercise File: Bookings6-11.xlsx
• Exercise: Print or print preview cells A4:E30.

Print or print preview the Tuesday, Thursday, and Summary worksheets.

Exercise

- Exercise File: Bookings6-11.xlsx
- Exercise: Print or print preview cells A4:E30.

Print or print preview the Tuesday, Thursday, and Summary worksheets.

Exercise

• Exercise File: Bookings6-11.xlsx
• Exercise: Print or print preview cells A4:E30.

Print or print preview the Tuesday, Thursday, and Summary worksheets.

Exercise

- Exercise File: Bookings6-11.xlsx
- Exercise: Print or print preview cells A4:E30.

Print or print preview the Tuesday, Thursday, and Summary worksheets.
Working with Multiple Workbook Windows

This lesson explains how to view and work with more than one workbook at a time.

Switch between workbook windows

If more than one workbook window is open, it’s possible to quickly switch between the windows.

1. Click the Excel button on the Windows taskbar and select the workbook to view.

Other Ways to Switch between Workbooks:
   - Click the View tab on the Ribbon and click the Switch Windows button in the Window group. Select the workbook to view from the list.
   - The selected document window becomes the active document.

View multiple workbooks at once

1. Click the View tab on the Ribbon and click the Arrange All button in the Window group.

The Arrange Windows dialog box appears, allowing arrangements of the open workbooks in Tiled, Horizontal, Vertical, or Cascade order.

2. Select an option and click OK.

Other Ways to View Multiple Workbooks:
   - Click the View tab on the Ribbon and click the View Side By Side button in the Window group. If the Compare Side by Side dialog box appears, select the workbook to display alongside the active workbook and click OK.

Tips

✓ Click the Save Workspace button in the Window group to save the layout of the open windows for future access.

Create another workbook window

View a workbook in more than one window at a time.

1. Click the View tab on the Ribbon and click the New Window button in the Window group.

Tips

✓ Viewing the same workbook in multiple windows does not create a new file. When a change is made to the workbook in one window, the change is reflected in all the windows for the workbook.
Managing Workbooks

✓ Each instance of a workbook window is marked in the title bar. For example, if a new window was opened for Workbook 1, the two windows would be named Workbook 1:1 and Workbook 1:2.
Creating a Template

If recreating the same type of workbook over and over, save some time by using a template. A template is a workbook that contains frequently-used labels, formulas, formatting, and macros. Once having created a template, use it to create new workbooks.

1. Create or open a workbook to use as a template.
2. Click the File tab on the Ribbon and select Save As.
   
   There are three basic types of templates to create:
   - Excel Template: This is the standard Excel 2007 template that works with XML.
   - Excel Macro-Enabled Template: This type of template is the standard template but is enabled to work with XML.
   - Excel 97-2003 Template: Use this to create workbooks that are compatible with earlier versions of Excel. These files are not XML compatible.
3. Click the Save as type list arrow and select the type of template to create.
   
   Once change the file type is changed to a template, the location automatically changes to the Templates folder.
4. Enter a name for the template in the File name text box.
5. Click Save.

   The template is saved, and can be used to create new workbooks.

Exercise

- Exercise File: Bookings6-13.xlsx
- Exercise: Save the file as an Excel Template and name it “Bookings”.

Figure 6-27: Saving a workbook as an Excel Template.
Managing Workbooks

Protecting a Workbook

Protect entire workbooks from being viewed or modified, as well as protect the structure of workbooks and the position of workbook windows.

Add password protection

Set a password so only authorized users can open a workbook.

1. Open the workbook to protect.
2. Click the File tab on the Ribbon and select Info. The options under the Info sections appear.
3. Click the Protect Workbook button and select Encrypt with Password. The Encrypt Document dialog box appears.
4. Enter the password to use and click OK. The Confirm Password dialog box appears.
5. Re-enter the password and click OK.

From now on, Excel requires a password before opening the protected workbook.

Tips

✓ To change or remove a password, repeat the workbook protection steps and simply change or delete the password in the Encrypt Document dialog box.

Protect workbook structure and windows

Secure a workbook’s structure against changes, such as sheets being added or deleted.

1. Click the Review tab on the Ribbon and click the Protect Workbook button in the Changes group. The Protect Structure and Windows dialog box appears. Select to protect workbook structure, windows, or both.

Other Ways to Protect a Workbook:
Click the File tab on the Ribbon and select the Info tab. Click the Protect Workbook button and select Protect Workbook Structure from the list.

2. Select the option(s) to use and enter a password.
3. Click OK.

The Confirm Password dialog box appears.

Exercise

• Exercise File: Sales6-14.xlsx
• Exercise: Protect the workbook so that users must enter the password “Sales” to open it. Then set a password to protect the workbook’s structure. Close the workbook and reopen it using the password. Remove the workbook password protection and unprotect the workbook’s structure.
4. Enter the password again and click **OK**.

The structure and/or windows of the workbook are protected.

**Tip:** To unprotect the workbook structure or windows, click the **Review** tab on the Ribbon and click the **Protect Workbook** button in the Changes group. Enter the password and click **OK**.

**Tips**

- Use passwords that combine upper and lowercase letters, numbers, and symbols.
- Besides protecting a workbook with a password, apply worksheet protection to individual worksheets and worksheet elements.
Protecting Worksheets and Worksheet Elements

Prevent unauthorized changes to data by protecting worksheets. In a protected worksheet, none of its contents—cells or other elements—can be changed. However, it’s possible to prepare the worksheet so that certain cells and elements can be changed after it is protected.

Make cells editable in a protected worksheet

If there are cells that users should be able to change in a protected worksheet, prepare the worksheet by unlocking the cells.

1. Display the worksheet to protect.
2. Click the Home tab on the Ribbon, click the Format button in the Cells group.
   Tip: Notice that “Lock Cell” near the bottom of the list is highlighted. This indicates that the cells are ready to be locked once the sheet is protected. Unlock the cells so they are editable.
3. Select Lock Cell.

Now when the sheet is protected, the cell range won’t be locked.

Tip: Locking and unlocking cells only takes effect once the sheet is protected.

Other Ways to Unlock/Lock Cells:
Select the desired cell(s), click the Home tab on the Ribbon, click the Format button in the Cells group and select Format Cells. Click the Protection tab. Remove the check mark from the Locked option and click OK.

Make graphics editable in a protected worksheet

Before protecting the worksheet, unlock any graphic objects that users may need to be able to modify.

1. Select each object to remain unlocked after having protected the sheet.
   The Drawing Tools contextual tab appears.
2. Under Drawing Tools on the Ribbon, click the Format tab and click the Dialog Box Launcher in the Size group.
3. Click the Properties tab and uncheck the Locked and Lock text options, as desired. Click Close.

Exercise File: Sales6-15.xlsx
Exercise: Unlock the cell range B4:G9. Protect the worksheet, but don’t enter a password. Try to type in cell B3. Change cell B4 to $14,000. Unprotect the worksheet.

Figure 6-31: Preparing cells so they are editable when the worksheet is protected.
Hide formulas in a protected worksheet

Prevent certain formulas from being displayed once the worksheet has been protected.

1. Select the cells containing formulas to hide.

2. Click the Home tab on the Ribbon, click the Format button in the Cells group and select Format Cells.
   The Format Cells dialog box appears.

3. Click the Protection tab, click the Hidden check box and click OK.

Protect a worksheet

Once finished preparing the worksheet, it’s time to protect the worksheet.

1. Click the Review tab on the Ribbon and click the Protect Sheet button in the Changes group.
   The Protect Sheet dialog box appears.

   Other Ways to Protect the Sheet:
   Right-click the sheet tab and select Protect Sheet from the contextual menu.

2. Enter a password in the text box.
   Tip: A password isn’t strictly necessary in order to protect the worksheet, but if one is not entered, anyone can unprotect the sheet.

3. Select the items that users need to be able to change in the “Allow all users of this worksheet to:” list and click OK.
   The worksheet is protected.

   Tip: To unprotect a worksheet, right-click the sheet tab and select Unprotect Sheet from the contextual menu.
Sharing a Workbook

Share the Excel workbook files with other people, so that work on the data can be done collaboratively. Sharing a workbook has several benefits:

- Several people can use the same shared workbook simultaneously.
- Excel keeps track of any changes made to a shared workbook, when they were made, and who made them.
- Review and accept or reject any changes made to a shared workbook.

Share a workbook

Share a workbook on a network where users can simultaneously modify it.

⚠️ Trap: Some features—merged cells, charts, graphics, conditional formats, macros, PivotTable reports, hyperlinks, and worksheet protection—can’t be modified in a shared workbook.

1. Click the Review tab on the Ribbon and click the Share Workbook button in the Changes group.
   
The Share Workbook dialog box appears.

2. Click the Allow changes by more than one user at the same time check box. Click OK.

✔️ Tip: Make sure the workbook is saved where it is accessible to other users (i.e. a shared folder on a network drive).

Other Ways to Share a Workbook on a Network:

Click the Review tab on the Ribbon and click the Protect and Share Workbook button. Click the Sharing with track changes check box, enter a password, and click OK. The workbook is shared and users are not able to turn off the Change Tracking feature.

✔️ Tips

- Every time a shared workbook is shared, changes made by other users since the last time saved will prompt the current user.
- Uncheck the Allow changes by more than one user at the same time check box to stop sharing the file.

Save and send a workbook

1. Click the File tab on the Ribbon and select Share.

2. Click Email.
   
Select the format you’d like to send the workbook in.

---

Exercise

- Exercise File: Sales6-16.xlsx
- Exercise: Share the workbook file on the network, then remove the file share.

Figure 6-33: The Share Workbook dialog box.

Figure 6-34: Sharing a document via Email.
Managing Workbooks

A new email will open with the workbook attached in the format you have chosen. Enter any necessary info and click Send.
Online Collaboration

Office 2013 has added three new improved ways to share documents and aid in online collaboration in a more relevant way.

Sharing a workbook by Inviting People

Once you have saved your document on your SkyDrive account, you can grant people access to it so that they can view or edit it.

1. Navigate to and click on the File tab.
2. Click Share.

Trap: Note that in order to share a workbook by sending a Link, you must first save the workbook on a shared network location like SharePoint. If you have not done this, the Get a Link option will not be visible as a Share option.

3. Click Invite People, and in the right-hand pane, type the name or email address of the person or people you want to share with.

4. In the small box to the right, select their permissions from the drop box to either Can edit or Can view.

5. Include a message with the invitation (optional).

6. If you want the user to sign in before accessing the document, check the Require user to sign-in before accessing document box.

7. Click Share.

Sharing a workbook by sending a Link

Get a link to your document and send it to those you would like to share it with.

1. Navigate to and click on the File tab.
2. Click Share.

Trap: Note that in order to share a workbook by sending a Link, you must first save the workbook on a shared network location like SharePoint. If you have not done this, the Get a Link option will not be visible as a Share option.

3. Click Get a Sharing Link, and in the right-hand pane, select Create Link from either the View Link section or the Edit Link section, depending on the permissions that you set.

Figure 6-35: Once you have saved your document to SkyDrive, you can share this document in several ways.

Figure 6-36: Getting a Sharing Link.
Managing Workbooks

4. Once the link has been created under Shared links, right-click the new link and select Copy Link.

5. Open a new email and paste the link into it. When you're done composing your email, click Send.

Tip: To email the link to a contact, click on the contact/s under the Shared with heading and click the envelope.

Sharing a workbook via Social Networks

Post your document online to your social network of choice.

1. Navigate to and click on the File tab.

2. Click Share.

Trap: Note that in order to share a workbook via Social Networks like Facebook or LinkedIn, you will need to have activated Social Connector under your Outlook Account Settings before you will be able to share workbooks via Social Networks.

3. Click Post to Social Networks, and in the right-hand pane select the social network you wish to post to.

4. Set the permissions of the people who have access to the document by selecting Can view or Can edit from the drop-down.

5. Include a personal message in the message box (optional).

6. Click Post.
Managing Workbooks Review

Quiz Questions

1. Which of the following is NOT a view option in Excel?
   A. Normal view  
   B. Edit view  
   C. Page Layout view  
   D. Page Break Preview view

2. Use the Zoom slider to change the magnification level of a worksheet. (True or False?)

3. To select a worksheet, click the View tab on the Ribbon, click the Sheet button in the Worksheet Selection group, and select the sheet to make active. (True or False?)

4. It's possible to add additional worksheets to a workbook. (True or False?)

5. Move a worksheet within a workbook simply by dragging the sheet's tab to a new location. (True or False?)

6. Splitting and freezing a workbook window are exactly the same thing. (True or False?)

7. Work with headers and footers is easiest in Page Layout View. (True or False?)

8. When hiding a row, column, or worksheet, the hidden data is deleted. (True or False?)

9. In Page Break Preview view, a page break can be moved by clicking and dragging it to a new location. (True or False?)

10. In Page Break Preview view, a page break can be moved by clicking and dragging it to a new location. (True or False?)

11. Which of the following is NOT a preset margin size setting available in Excel?
   A. Large  
   B. Normal  
   C. Wide  
   D. Narrow

12. The Sheet Options group on the Page Layout tab has commands that allow to view or print which of the following:
   A. The Formula Bar  
   B. Formulas  
   C. Page numbers  
   D. Gridlines

13. The default paper size in Excel is:
   A. Legal
14. Which of these is not a possible way to print?
   A. Print selected data
   B. Print multiple workbooks
   C. Print an entire workbook
   D. Print multiple worksheets from a workbook

15. One way to switch between open workbooks is to click the __________ button in the Window group.
   A. Change Windows
   B. Choose Workbook
   C. Switch Windows
   D. View Workbook

16. Once a template is created, use it to create new workbooks. (True or False?)

17. Protect a workbook from
   A. being modified.
   B. having its structure changed.
   C. being opened.
   D. All of these things.

18. It's possible to unlock cell ranges so that they can still be edited once the worksheet is protected. (True or False?)

19. Which of the following is NOT an option in Excel for publishing a workbook to a server?
   A. Internet Fax
   B. Excel Services
   C. Document Management Server
   D. Create Document Workspace
Quiz Answers

1. B. Edit view is not an Excel view option.
2. True. The Zoom slider on the status bar allows zooming in and out of a worksheet.
3. False. To select a worksheet, click that worksheet's tab at the bottom of the workbook window.
4. True. It's possible to add and delete worksheets.
5. True. Move a worksheet within a workbook simply by dragging the sheet's tab to the new location. Hold down the Ctrl key to copy it.
6. False. They are similar, but splitting allows all window sections to be scrolled through independently. Also, move split lines but not frozen sections.
7. True. Page Layout View makes it easy to work with headers and footers.
8. False. Hiding data doesn't delete it, it just hides it from view until it is unhidden.
10. True. In Page Break Preview view, move a page break by clicking and dragging it to a new location.
11. A. Large is not a margin size option in Excel.
12. D. View or print gridlines and headings using the commands in the Sheet Options group.
13. B. Letter is the default paper size in Excel.
14. B. In Excel 2013, workbooks can only be printed one at a time.
15. C. Click the Switch Windows button in the Window group to switch between multiple open workbooks.
16. True. Once a template is created, use it to create new workbooks.
17. D. It's possible to protect a workbook from all of these things.
18. True. Unlock cell ranges so that they can still be edited once the worksheet is protected.
19. A. Internet Fax is a way to send, not publish a workbook from Excel.
Formulas are the heart and soul of a spreadsheet. Without formulas, Excel would be nothing more than a grid for displaying numbers and text. As this chapter shows, formulas can do a lot more than just adding, subtracting, multiplying, and dividing. Excel has hundreds of different formulas to use to create complex statistical, financial, and scientific calculations. The most expensive calculator in the world couldn’t come close to matching all of Excel’s functions.

This chapter teaches about more complex formula writing, how to insert and edit functions, how to define names, and how to trace formulas and diagnose errors.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Formulas with Multiple Operators

Formulas can contain several values, such as 81 and 3.5; cell references, such as B5 and C1:D11; operators, such as * (multiplication) and + (addition); and functions, such as Sum and Average. When several operations and functions are combined into a single formula, Excel performs the operations in a predetermined order.

When a formula contains several operators with the same precedence, Excel calculates the formula from left to right. Change the order by enclosing the part of the formula Excel needs to calculate first in parentheses. Table 7-1: Order in Which Excel Performs operations in Formulas, is a good reference for how to structure formulas with multiple operations.

Tips

✓ All formulas must begin with an equal sign (=).

Exercise

• Exercise File: None required.

• Exercise: Open a new blank workbook. In cell A1, enter 
  =\(\frac{20+5}{10-5}\). In cell A2, enter \(20+\frac{5}{10}-5\).
  Notice that the parentheses cause the formulas to have different results.

  Close the workbook without saving.

Figure 7-1: Understanding how formulas with multiple operators are performed in Excel.

Table 7-1: Order in Which Excel Performs Operations in Formulas

| Parentheses change the order of evaluation. | For example: |
| \(\frac{20+5}{10-5}\) would add 20 and 5 (25), subtract 10 by 5 (5) and then divide the results to equal 5. But… |
| \(\frac{20+5}{10-5}\) would divide 5 by 10 (0.5), add the result to 20 (20.5) and then subtract 5 to equal 15.5. |
| : Reference Operator |
| % Percent |
| ^ Exponentiation |
| * and / Multiplication and division |
| + and - Addition and subtraction |
| = < > <= => Comparison |

These formulas use the same operators and numbers…

…but the result is different because the parenthesis change the order by which the formula is calculated.
New Functions

Several new functions are now available in Excel 2013, from engineering and math, to statistical and date and time. Once you have these down, your Excel experience will be so much richer. To see a list of all these new functions, see Table 7-2: New Functions in Excel 2013 below.

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACOT function</td>
<td>=ACOT(number)</td>
<td>Returns the arc cotangent of a number</td>
</tr>
<tr>
<td>ACOTH function</td>
<td>=ACOTH(number)</td>
<td>Returns the hyperbolic arc cotangent of a number</td>
</tr>
<tr>
<td>ARABIC function</td>
<td>=ARABIC(text) or (cell number)</td>
<td>Converts a Roman numeral to Arabic as a number</td>
</tr>
<tr>
<td>BASE function</td>
<td>=BASE(number,radix)</td>
<td>Converts a number into a text representation with the given radix (base)</td>
</tr>
<tr>
<td>BINOM.DIST.RANGE function</td>
<td>=BINOM.DIST.RANGE(trials,probability_s,number_s,[number_s2])</td>
<td>Returns the probability of a trial result using a binomial distribution</td>
</tr>
<tr>
<td>BITAND function</td>
<td>=BITAND(number1, number2)</td>
<td>Returns a ‘Bitwise And’ of two numbers</td>
</tr>
<tr>
<td>BITLSHIFT function</td>
<td>=BITLSHIFT(number, shift_amount)</td>
<td>Returns a value number shifted left by shift_amount bits</td>
</tr>
<tr>
<td>BITOR function</td>
<td>=BITOR(number1, number2)</td>
<td>Returns a bitwise OR of 2 numbers</td>
</tr>
<tr>
<td>BITRSHIFT function</td>
<td>=BITRSHIFT(number, shift_amount)</td>
<td>Returns a value number shifted right by shift_amount bits</td>
</tr>
<tr>
<td>BITXOR function</td>
<td>=BITXOR(number1, number2)</td>
<td>Returns a bitwise ‘Exclusive Or’ of two numbers</td>
</tr>
<tr>
<td>CEILING.MATH function</td>
<td>=CEILING(number, [significance])</td>
<td>Rounds a number up, to the nearest integer or multiple of significance</td>
</tr>
<tr>
<td>COMBINA function</td>
<td>=COMBINA(number, number_chosen)</td>
<td>Returns the numbers of combinations with repetitions for a given number of items</td>
</tr>
<tr>
<td>COT function</td>
<td>=COT(number)</td>
<td>Returns the hyperbolic cosine of a number</td>
</tr>
<tr>
<td>COTH function</td>
<td>=COTH(number)</td>
<td>Returns the cotangent of a number</td>
</tr>
<tr>
<td>CSC function</td>
<td>=CSC(number)</td>
<td>Returns the cosecant of an angle</td>
</tr>
<tr>
<td>CSCH function</td>
<td>=CSCH(number)</td>
<td>Returns the hyperbolic cosecant of an angle</td>
</tr>
<tr>
<td>DAYS function</td>
<td>=DAYS(end_date, start_date)</td>
<td>Returns the number of days between dates</td>
</tr>
<tr>
<td>DECIMAL function</td>
<td>=DECIMAL(text, radix)</td>
<td>Converts a text representation of a number in a given base into a decimal number</td>
</tr>
<tr>
<td>ENCODEURL function</td>
<td>=ENCODEURL(text)</td>
<td>Returns a URL-encoded string</td>
</tr>
<tr>
<td>FILTERXML function</td>
<td>=FILTERXML(xml, xpath)</td>
<td>Returns specific data from the XML by using the specific XPath</td>
</tr>
<tr>
<td>FLOOR.MATH function</td>
<td>=FLOOR.MATH(number, significance)</td>
<td>Rounds a number down, to the nearest integer or the nearest multiple of significance</td>
</tr>
<tr>
<td>FORMULATEXT function</td>
<td>=FORMULATEXT(reference)</td>
<td>Returns the formula at the given reference as text</td>
</tr>
<tr>
<td>GAMMA function</td>
<td>=GAMMA(number)</td>
<td>Returns the Gamma function value</td>
</tr>
<tr>
<td>GAUSS function</td>
<td>=GAUSS(z)</td>
<td>Returns 0.5 less than the standard normal cumulative distribution</td>
</tr>
</tbody>
</table>

Exercise Notes

- Exercise File: None required
- Exercise: Become familiar with some of the new functions in Excel 2013.
### Table 7-2: New Functions in Excel 2013

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IFNA function</td>
<td>=IFNA(value, value_if_na)</td>
<td>Returns the value you specify if the expression resolves to #N/A, otherwise returns the result of the expression.</td>
</tr>
<tr>
<td>IMCOSH function</td>
<td>=IMCOSH(inumber)</td>
<td>Returns the hyperbolic cosine of a complex number.</td>
</tr>
<tr>
<td>IMCOT function</td>
<td>=IMCOT(inumber)</td>
<td>Returns the cotangent of a complex number.</td>
</tr>
<tr>
<td>IMCSC function</td>
<td>=IMCSC(inumber)</td>
<td>Returns the cosecant of a complex number.</td>
</tr>
<tr>
<td>IMCSCH function</td>
<td>=IMCSCH(inumber)</td>
<td>Returns the hyperbolic cosecant of a complex number.</td>
</tr>
<tr>
<td>IMSEC function</td>
<td>=IMSEC(inumber)</td>
<td>Returns the secant of a complex number.</td>
</tr>
<tr>
<td>IMSECH function</td>
<td>=IMSECH(inumber)</td>
<td>Returns the hyperbolic secant of a complex number.</td>
</tr>
<tr>
<td>IMSINH function</td>
<td>=IMSHINH(inumber)</td>
<td>Returns the hyperbolic sine of a complex number.</td>
</tr>
<tr>
<td>IMTAN function</td>
<td>=IMTAN(inumber)</td>
<td>Returns the tangent of a complex number.</td>
</tr>
<tr>
<td>ISFORMULA function</td>
<td>=ISFORMULAA(reference)</td>
<td>Returns TRUE if there is a reference to a cell that contains a formula.</td>
</tr>
<tr>
<td>tying</td>
<td>=ISWEEKNUM (date)</td>
<td>Returns the number of the ISO week number of the year for a given date.</td>
</tr>
<tr>
<td>MUNIT function</td>
<td>=MUNIT(dimension)</td>
<td>Returns the unit matrix or the specified dimension.</td>
</tr>
<tr>
<td>NUMBERVALUE function</td>
<td>=NUMBERVALUE(text)</td>
<td>Converts text to number in a locale-independent manner.</td>
</tr>
<tr>
<td>PDURATION function</td>
<td>=PDURATION(rate, pv, fv)</td>
<td>Returns the number of periods required by an investment to reach a specific value.</td>
</tr>
<tr>
<td>PERMUTATIONA</td>
<td>=PERMUTATIONA(number, number-chosen)</td>
<td>Returns the number of permutations for a given number of objects (with repetitions) that can be selected from the total objects.</td>
</tr>
<tr>
<td>PHI function</td>
<td>=PHI(x)</td>
<td>Returns the value of the density function for a standard normal distribution.</td>
</tr>
<tr>
<td>RRI function</td>
<td>=RRI(nper, pv, fv)</td>
<td>Returns an equivalent interest rate for the growth of an investment.</td>
</tr>
<tr>
<td>SEC function</td>
<td>=SEC(number)</td>
<td>Returns the secant of an angle.</td>
</tr>
<tr>
<td>SECH function</td>
<td>=SECH(number)</td>
<td>Returns the hyperbolic secant of an angle.</td>
</tr>
<tr>
<td>SHEET function</td>
<td>=SHEET(value)</td>
<td>Returns the sheet number of the referenced sheet.</td>
</tr>
<tr>
<td>SHEETS function</td>
<td>=SHEETS(reference)</td>
<td>Returns the number of sheets in a reference.</td>
</tr>
<tr>
<td>SKEWP function</td>
<td>=SKEWP (number)</td>
<td>Returns the skewness of a distribution based on a population.</td>
</tr>
<tr>
<td>UNICHAR function</td>
<td>=UNICHAR(number)</td>
<td>Returns the Unicode character that is referenced by the given numeric value.</td>
</tr>
<tr>
<td>UNICODE function</td>
<td>=UNICODE(text)</td>
<td>Returns the number that corresponds to the first character of the text.</td>
</tr>
<tr>
<td>WEBSERVICE function</td>
<td>=WEBSERVICE (url)</td>
<td>Returns data from a web service.</td>
</tr>
<tr>
<td>XOR function</td>
<td>=XOR (logical)</td>
<td>Returns a logical exclusive OR of all arguments.</td>
</tr>
</tbody>
</table>
Inserting and Editing a Function

There are several hundred functions available in Excel. Some are simple, such as the Sum function. Others are much more complex and contain several different arguments.

The Insert Function feature is available to help select, enter, and edit worksheet functions.

Insert a function using the Insert Function dialog box

1. Select the cell in which to enter the formula and click the Insert Function button on the Formula Bar.

   Tip: Table 7-3: Function Categories, describes the function categories available in Excel.

   Other Ways to Open the Insert Function Dialog Box:
   - Click the Formulas tab on the Ribbon and click the Insert Function button in the Function Library group.

2. Click the Or select a category list arrow and select a function category.

   All the functions in the selected category appear in the “Select a function” list.

   Other Ways to Find a Function in the Insert Function Dialog Box:
   - Type a description of the function in the “Search for a function” text box and click Go. The related functions appear in the “Select a function list.”

3. Select the function to use in the “Select a function” list and click OK.

   Tip: Instead of typing argument values into the dialog box, click a Collapse Dialog button, select a cell range in the worksheet, and then click the Expand Dialog button.

4. Enter the arguments in the text boxes and click OK.

Exercise

• Exercise File: Sales7-1.xlsx

• Exercise: Use the Insert Function dialog box to insert the Average function in cell B13 and find the average of all the Net Inc. values (B11:G11).

Use the Date & Time button in the Function Library group on the Ribbon to insert the Today function in cell A1.
Insert a function using the Function Library

Another way to access functions by category is in the Function Library group.

1. Select the cell where to enter the formula in and click the Formulas tab on the Ribbon.

2. Click a function category button in the Function Library and select the function to use.

   The Function Arguments dialog box appears.

3. Enter the arguments in the text boxes and click OK.

   Tip: Click a function category button in the Function Library and then point to a function; a ScreenTip appears that describes the formula.

Edit a function

1. Select the cell with the function to edit.

   Choose from the following options:

   - Click the Insert Function button on the formula bar and edit the function arguments in the Function Arguments dialog box.
   - Click in the formula bar and directly edit the function in the formula bar.

---

Table 7-3: Function Categories

<table>
<thead>
<tr>
<th>Most Recently Used</th>
<th>Lists the functions used most recently.</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Lists every function available in Excel.</td>
</tr>
<tr>
<td>Financial</td>
<td>Lists financial functions to calculate interest, payments, loans, etc.</td>
</tr>
<tr>
<td>Date &amp; Time</td>
<td>Lists functions to calculate date and times values.</td>
</tr>
<tr>
<td>Math &amp; Trig</td>
<td>Lists math and trigonometry functions, such as SUM, COS, and TAN.</td>
</tr>
<tr>
<td>Statistical</td>
<td>Lists statistical functions, to calculate averages, standard deviations, etc.</td>
</tr>
<tr>
<td>Lookup &amp; Reference</td>
<td>Lists functions that lookup or reference values.</td>
</tr>
<tr>
<td>Database</td>
<td>Lists functions that lookup or calculate values in a list or database.</td>
</tr>
<tr>
<td>Text</td>
<td>Lists functions that can be used with text or labels.</td>
</tr>
<tr>
<td>Logical</td>
<td>Lists IF…THEN conditional-type functions.</td>
</tr>
<tr>
<td>Information</td>
<td>Lists functions that return information about values and the worksheet itself.</td>
</tr>
<tr>
<td>Engineering</td>
<td>Lists functions used in engineering calculations.</td>
</tr>
<tr>
<td>Cube</td>
<td>Lists functions that extract data from OLAP cubes.</td>
</tr>
</tbody>
</table>
AutoCalculate and Manual Calculation

Besides using formulas, Excel can automatically perform certain calculations simply by selecting the cells. Then, tell Excel when to manually calculate formulas in a worksheet.

Use AutoCalculate

A formula doesn’t always need to be entered to make a quick calculation. For example, if a column contains a few numbers to add together, simply select the cells and look to the status bar for the answer—Excel has calculated the sum there.

1. Select the cells to average, count or sum.

Excel’s AutoCalculate feature takes the cells selected and displays the results to these common calculations in the status bar, as shown in the example to the right.

Change AutoCalculate options

Change and add calculations in the status bar.

1. Right-click the status bar.

The Customize Status Bar list appears. Add Numerical Count, Minimum or Maximum to the status bar. Remove Average, Count or Sum if preferred. Table 7-4: AutoCalculate Options in the Status Bar, displays more information about these options.

2. Select the calculations to be displayed on the status bar.

The calculations selected appear on the status bar.

Manual formula calculation options

By default, Excel recalculates all the formulas in a workbook whenever a value is changed that affects another value. However, the calculation options can be changed so that formulas will only calculate when directed.

1. Click the Formulas tab on the Ribbon and click the Calculation Options button in the Calculation group.

Three options appear in the list:

- **Automatic**: This is selected by default. Values are automatically recalculated whenever a change occurs in the workbook.

- **Automatic Except for Data Tables**: The workbook is automatically updated with any changes. Data tables are only updated manually.

- **Manual**: The workbook is only updated when directed by the user.

Table 7-4: AutoCalculate Options in the Status Bar

<table>
<thead>
<tr>
<th>By Default</th>
<th>Average</th>
<th>Average of selected cells.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Count</td>
<td></td>
<td>Number of selected cells that contain data.</td>
</tr>
<tr>
<td>Sum</td>
<td></td>
<td>Sum of selected cells.</td>
</tr>
<tr>
<td>Optional</td>
<td>Numerical Count</td>
<td>Number of selected cells that contain numbers.</td>
</tr>
<tr>
<td>Minimum</td>
<td></td>
<td>Smallest value in the selection.</td>
</tr>
<tr>
<td>Maximum</td>
<td></td>
<td>Largest value in the selection.</td>
</tr>
</tbody>
</table>
2. Select a calculation option.
   The Calculate Now button calculates the entire workbook when clicked, while the Calculate Sheet button only calculates the current worksheet.

3. Click the **Calculate Now** or **Calculate Sheet** button in the Calculation group.

   **Other Ways to Calculate:**
   Press `<F9>` to Calculate Now; press `<Shift>` + `<F9>` to Calculate Sheet.
Defining Names

Defining a name makes formulas much easier to understand and maintain. For example, name the cell range B16:H16 “Total Sales.” Then, instead of totaling sales with the formula =Sum(B16:H16), use the defined name to create the more readable formula, =Sum(TotalSales).

Define a name a cell range, formula, constant, or table.

**Define a name for a cell range**

Define a name for a cell, cell range, or even multiple non-adjacent cells selected.

1. Select the cells to name.
   - **Tip:** To select a range of non-adjacent cells, press and hold the <Ctrl> key while selecting cells.

2. Click the Name Box on the formula bar.

3. Type a name, up to 255 characters, for the selection.
   - **Trap:** A cell reference, like B2, can’t be used as a name, and neither can spaces in a name (use an underscore or period instead).

4. Press the <Enter> key.

**Other Ways to Define a Name for a Cell Range:**
Use existing row and column labels as defined names. Select the cell range to name, including the row and/or column labels. Click the Formulas tab on the Ribbon and click the Create from Selection button. Select the name options to use and click OK. The resulting defined name refers to only the cells with values, not the cells with the row and column labels.

**Define names with the New Name dialog box**

For more options and flexibility, use the New Name dialog box to define names for cell references, constants and formulas.

1. Click the Formulas tab on the Ribbon and click the Define Name button in the Defined Names group.

   The New Name dialog box appears.

   - **Other Ways to Display New Name Dialog Box:** Click the Formulas tab on the Ribbon. Click the Name Manager button in the Defined Names group. Click the New button.

---

**Exercise**

- **Exercise File:** Sales7-3.xlsx
- **Exercise:** Create defined names for each of these cell ranges—B5:B8, C5:C8, D5:D8—and name them JanExpenses, FebExpenses, and MarExpenses, respectively.

---

**Figure 7-6:** A defined name in the Name Box.
2. Enter a name in the Name text box.

3. Click the Scope list arrow and select the scope to use.
   ✔ Tip: The scope determines whether the name is recognized by the whole workbook or just individual worksheets within the workbook. Names in which the scope is a worksheet can be recognized in other sheets of the workbook. Just qualify the sheet name first, for example: Sheet1!Income_FY08.

4. Complete the “Refers to” box as necessary.
   The “Refers to” box displays the currently selected cell or cell range. A few options are available:
   - Define a name for the current cell range: Keep the current cell range selected. Do nothing.
   - Select a different cell range: In the “Refers to” box, select a different cell range: Click the Collapse Dialog button, select different cells on the worksheet and click the Expand Dialog button.
   - Define a name for a constant: In the “Refers to” box, enter an equal sign (=) followed by a constant value, such as 7.2.
   - Define a name for a formula: In the “Refers to” box, enter an equal sign (=) followed by a formula, such as FV(8,6,C4).

5. Click OK.
   The name is defined and the dialog box closes.

✔ Tips

✔ Use upper- and lowercase letters in defined names, but Excel doesn’t distinguish between them.

✔ Besides creating defined names, create “table names.” Excel automatically creates a table name like “Table1” when a table is created, but use the Name Manager to change the name.
Using and Managing Defined Names

Once defined names are created, use them in formulas and use the Name Manager dialog box to view, edit, delete, and create new defined names.

Use defined names

Once cells have been given names, they are easy to reference in other formulas.

1. Click the Formulas tab on the Ribbon, click the Use in Formula button in the Defined Names group, and select a name from the list.

Other Ways to Use a Name:
Type a defined name in a formula.

View defined names

There are a few places to view all of a workbook’s defined names:

• Name Manager Dialog box: Click the Formulas tab on the Ribbon and click the Name Manager button in the Defined Names group. Here is a list of the defined names and table names. The list includes the name, current value, current reference for the name, scope, and any comments related to the name. Click and drag the right column border to change the width of a column.

• Worksheet cells: Find an area in the worksheet with two blank columns. Select a cell that will become the upper-left corner of the list. Click the Formulas tab on the Ribbon, click the Use in Formula button and select Paste Names. Click the Paste List button. The defined names and the related descriptions appear in the columns.

• Name Box list: Click the arrow next to the Name Box to view the defined names. If a name is selected here, the cell range that is defined by that name is selected in the worksheet.

Edit defined names

Use the Name Manager dialog box to edit defined names.

1. Click the Formulas tab on the Ribbon and click the Name Manager button in the Defined Names group. The Name Manager dialog box appears.

Exercise

- Exercise File: Sales7-4.xlsx
- Exercise: Edit the defined names in the Name Manager dialog box so they read Jan, Feb, and Mar instead of JanExpenses, FebExpenses, and MarExpenses.

In cell B14, enter the formula =AVERAGE(Jan-Feb-Mar) to find the average expenses per month for the first quarter of the year.

Delete the JanIncome defined name.

Figure 7-8: As defined names are entered in a formula, the cells they represent are highlighted.

Figure 7-9: Defined names are denoted in the Name Manager dialog box by an icon that looks like a note tag. Table names appear with a table icon.
More Functions and Formulas

2. Select a defined name and click the **Edit** button.

   The Edit Name dialog box appears. This dialog box is essentially the same as the New Name dialog box. Change the name of the defined name here or change what the name refers to.

3. Make changes to the defined name as desired, then click **OK**.

4. Click **Close**.

   ![Figure 7-10: The Edit Name dialog box.](image)

   **Other Ways to Edit Defined Names:**
   Select the defined name to edit in the Name Manager dialog box, then change the information in the “Refers to” box.

**Delete defined names**

To remove a defined name, delete it in the Name Manager dialog box.

1. Click the **Formulas** tab on the Ribbon and click the **Name Manager** button in the Defined Names group.

   The Name Manager dialog box appears.

2. Select the defined name(s) to delete.

   ![Tip: Press and hold the <Shift> key to select multiple adjacent names or the <Ctrl> key to select multiple non-adjacent names for deletion.](image)

3. Click the **Delete** button.

   A message appears, asking to delete the defined name or names.

4. Click **OK**.

   ![Tips](image)

   - In the Name Manager dialog box, filter the list of defined names by scope; whether or not they have errors; or by type of name (defined or table). Click the **Filter** button and select the filter to use.
   - Click the **New** button in the Name Manager dialog box to define a new name.
Displaying and Tracing Formulas

By default, Excel displays the results of formulas in the worksheet instead of showing the actual formulas. To understand the calculations and the work that goes into the results, use the Watch Window to trace precedents and dependents.

Display formulas

1. Click the Formulas tab on the Ribbon and click the Show Formulas button in the Formula Auditing group.
   
   Tip: Display formulas and then select a cell that contains a formula; colored lines appear around cells that are referenced by the formula.

   Now hide the formulas again.

2. Click the Show Formulas button in the Formula Auditing group again.
   
   Tip: Print a worksheet with formulas displayed and the formulas print instead of values.

Trace formula precedents and dependents

Trace the influence of formulas by displaying arrows that show precedent and dependent cells.

1. Select a cell that contains a formula to trace.

2. Click the Formulas tab on the Ribbon.

   In the Formula Auditing group, there are a couple different buttons to choose from:

   - Trace Precedents: Displays arrows that show what cells affect the currently selected cell.
   - Trace Dependents: Displays arrows that point to cells that are affected by the currently selected cell.

3. Click the Trace Precedents or Trace Dependents button in the Formula Auditing group.

   Arrows appear, illustrating how the cells relate to the formula in the currently selected cell. Dots appear on the arrows to point out which specific cells are involved. If there are precedents or dependents on another worksheet, an icon appears saying that.

   Once done analyzing formulas, remove the arrows.

Exercise

- Exercise File: Sales7-5.xlsx
- Exercise: Display, then hide, the formulas in the worksheet.

Select cell B14 and trace precedents, then remove the arrows.

Add cell B14 to the watch window. Then, change cell B5 to $1,000 to watch the value update in the watch window. Close the Watch Window.
4. Click the **Remove Arrows** button in the Formula Auditing group.

   ✅ **Tip:** To remove only precedent arrows or only dependent arrows, click the **Remove Arrows** button list arrow and select an option.

**Use the Watch Window**

The Watch Window allows the values of certain cells to be monitored as changes are made to worksheets.

1. Click the **Formulas** tab on the Ribbon and click the **Watch Window** button in the Formula Auditing group.

2. Click the **Add Watch** button.
   
   The Add Watch dialog box appears.

3. Select the cell or cell range to watch and click **Add**.
   
   The workbook and worksheet names, defined name, cell reference, current value, and formula for the selected cell(s) appear in the Watch Window.

   ✅ **Tip:** If no longer wanting to track a certain cell, select it in the Watch Window and click the **Delete Watch** button.

4. Click the Watch Window’s **Close** button.
Understanding Formula Errors

When Excel comes across a formula that it cannot calculate, it displays an error value. Error values occur because of incorrectly written formulas, referencing cells or data that don’t exist, or breaking the fundamental laws of mathematics. Excel includes an Error Checking feature to help deal with errors.

1. Click the Formulas tab on the Ribbon and click the Error Checking button in the Formula Auditing group.

   The Error Checking dialog box also has several buttons to help with errors:

   - **Help on this error:** Displays a Help topic that explains the type of error being seen.
   - **Show Calculation Steps:** Displays the Evaluate Formula dialog box, which breaks down the formula arguments so that the error can be isolated. Click Evaluate to show the current value of the underlined argument or click Step In to examine the source of a particular argument.
   - **Ignore Error:** Allows the current error to be skipped and move to the next error in the worksheet.
   - **Edit in Formula Bar:** Places the cursor in the formula bar, where the formula arguments can be directly edited and the error fixed.

   **Tip:** Click the Previous or Next buttons to move between errors in the worksheet, and click the Options button to change the error checking rules.

   **Other Ways to display the Evaluate Formula Dialog Box:**
   Click the Evaluate Formula button in the Formula Auditing group.

2. Click the button to use in the Error Checking dialog box.

   Now follow Excel’s advice to fix the error.

   **Other Ways to Fix an Error:**
   Select the cell that contains an error and point to the SmartTip icon that appears next to the cell. A tip appears, telling why this type of error is appearing. Click the list arrow and select an error checking option.

---

**Exercise**

- **Exercise File:** Sales7-6.xlsx
- **Exercise:** Add “/0” onto the end of the formula in cell B13 so that the #DIV/0! Error appears.

Then add “+A8” onto the end of formula in cell B14 so that the #VALUE! Error appears.

Display the Error Checking dialog box, and use the Edit in Formula Bar button to delete “/0” from cell B13 and “+A8” from B14.

---

**Figure 7-15:** The Error Checking dialog box.

**Figure 7-16:** The Evaluate Formula dialog box.
Tips

- Another way to analyze errors is by tracing them with arrows. Select a cell with an error, click the Error Checking list arrow in the Formula Auditing group, and select Trace Error. Arrows appear, pointing out the cells that are involved in the erroneous formula.

- If a formula contains its own cell location as a reference, it results in a circular reference, and the formula can’t calculate correctly. To locate circular references in the worksheet, click the Error Checking list arrow in the Formula Auditing group, point to Circular References, and select a cell that contains a circular reference from the list.

Table 7-5: Excel Errors

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>######</td>
<td>The numeric value is too wide to display within the cell. Resize the column by dragging the boundary line between the column headings.</td>
</tr>
<tr>
<td>#VALUE!</td>
<td>A mathematical formula that references a text entry was entered instead of a numerical entry.</td>
</tr>
<tr>
<td>#DIV/0!</td>
<td>An attempt was made to divide number by zero. This error often occurs when creating a formula that refers to a blank cell as a divisor.</td>
</tr>
<tr>
<td>#NAME?</td>
<td>Excel doesn’t recognize text entered in a formula. The name or function may have been misspelled, or a deleted name typed. Text in a formula without enclosing the text in double quotation marks may also have been entered.</td>
</tr>
<tr>
<td>#N/A</td>
<td>This error occurs when a value is not available to a function or a formula. If certain cells on the worksheet contain data that is not yet available, enter #N/A in those cells. Formulas that refer to those cells will then return #N/A instead of attempting to calculate a value.</td>
</tr>
<tr>
<td>#REF!</td>
<td>The #REF! Error value occurs when a cell reference is not valid. A cell range was probably deleted that is referenced in a formula.</td>
</tr>
<tr>
<td>#NUM!</td>
<td>The #NUM! Error value occurs when using an invalid argument in a worksheet function.</td>
</tr>
<tr>
<td>#NULL!</td>
<td>A specified intersection of two ranges in a formula do not intersect.</td>
</tr>
</tbody>
</table>
Using Logical Functions (IF)

The IF function is a conditional function or logical function because it will evaluate a condition specified and return one value if the condition is true and another value if the condition is false. For example, use the IF function in an invoice to create a formula that would subtract a 5% discount from the invoice if the total was more than $500.00, otherwise it wouldn’t subtract anything.

1. Click the Insert Function button on the Formula bar. The Insert Function dialog box appears.

2. Click the Or select a category list arrow and select Logical. Functions that fall under this category are shown in the Select a function box.

3. Select IF in the Select a function box and click OK. Other Ways to Find a Function:
   Type the function’s name in the Search for a function box. Or, select the function from the Select a function box.

Excel is ready to start entering the IF formula. There are three parts in this formula:

- **Logical Test:** This is this first argument, and it evaluates a statement as true or false.
- **Value if True:** If the statement in the Logical Test is true, then this value is entered.
- **Value if False:** If the statement in the Logical Test is false, then this value is entered.

4. Enter the arguments for the IF function and click OK. Tip: Remember, create cell references by clicking the cell or cell range to reference. Click the Collapse Dialog button to collapse the function palette and select the cell range if the Function Arguments dialog box is in the way.

   **Other Ways to Use the IF Function in a Formula:**
   Write the formula using the syntax
   
   `=IF(logical_test,value_if_true,value_if_false).`

---

**Exercise**

- **Exercise File:** Functions.xlsx, IF worksheet
- **Exercise:** Determine the Federal Income Tax for these people and enter these arguments for the IF function in cell B17:
  
  Logical test: B14>=500
  Value if true: B14*.15
  Value if false: B14*.1

  Copy the IF function from B17 to cells C17:H17.

---

=IF(A5>10,A4*.75,A4)

**Figure 7-17:** The syntax for the IF Function.

**Figure 7-18:** The Function Arguments dialog box.
Using Financial Functions (PMT)

The PMT function calculates the payment for a loan based on periodic payments and a constant interest rate. For example, if taking out a $10,000 car loan at 8% interest, the loan would have to be paid off in four years. Use the PMT function to calculate that the monthly payments for such a loan would be $244.13.

Use the PMT function to determine payments to annuities or investments.

1. Click the Insert Function button on the Formula bar. The Insert Function dialog box appears.

2. Click the Or select a category list arrow and select Financial. Functions that fall under this category are shown in the Select a function box.

3. Select PMT in the Select a function box and click OK. The Function Arguments dialog box appears.

4. Enter the required arguments for the PMT function and click OK.

**Tip:** Remember, it’s also possible to create cell references by clicking the cell or cell range to reference. Click the Collapse Dialog button to collapse the function palette and select the cell range if the Function Arguments dialog box is in the way.

**Other Ways to Use the PMT Function in a Formula:**
Write the formula using the syntax PMT(rate,nper,pv)

**Exercise**
- **Exercise File:** Functions.xlsx, PMT worksheet
- **Exercise:** In cell D4, create a PMT function that uses these arguments:
  - Rate: C4/12
  - Nper: B4*12
  - Pv: A4

  The result is a negative number: Add a – (negative) symbol between the = and PMT in the Formula bar so the value is positive.

  Copy the PMT function to D5:D6.

  $$=PMT(.09/12,36,10000)$$

  **Figure 7-19:** The syntax for the PMT Function.

  **Figure 7-20:** The results of the PMT function.

  **Figure 7-21:** The Function Arguments dialog box.
Using Database Functions (DSUM)

Excel’s database functions perform calculations only for records that meet the criteria specified. All the database functions use the same basic syntax: =Function(database, field, criteria). These arguments (parts) of a database function include:

- **Database**: Is the cell range that makes up the list or database.
- **Field**: Indicates which column is used in the function. Refer to fields by their column labels as long as they are enclosed with double quotation marks, such as "Name". Refer to fields as a number that represents the position of the column in the list: 1 for the first column in the list, 2 for the second, and so on. Make sure to refer to their position in the list, and not the column heading numbers!
- **Criteria**: Is a reference to the cell or cell range that specifies the criteria for the function.

Use database functions by creating a formula with the simplest database function—the DSUM function.

1. Click the Insert Function button on the Formula bar. The Insert Function dialog box appears.
2. Click the Or select a category list arrow and select Database.
3. Select DSUM in the Select a function box and click OK.
4. Enter the required arguments for the DSUM function and click OK.

**Tip**: It is important to understand how the field must be entered: either the name in double quotations, or by the number (for example, column A is 1, B is 2, and so on).

**Other Ways to Use the DSUM Function in a Formula**: Write the formula using the syntax =DSUM(database, field, criteria).

=DSUM(A1:I23, "Annual Trips",

**Figure 7-22**: The syntax for the DSUM function.

**Figure 7-23**: The Function Arguments for the DSUM function.

C27 displays the number of records in the Annual Trips column (column I) that match the criteria in C26.

**Figure 7-24**: An example of the DSUM function.
Using Lookup Functions (VLOOKUP)

The VLOOKUP function looks up information in a worksheet. The VLOOKUP searches vertically down the left most column of a cell range until it finds the value specified. When it finds the specified value, it then looks across the row and returns the value in column specified.

Tip:
- It’s important to understand that VLOOKUP only looks down the column that is farthest left in the specified cell range. In then looks across the row.

1. Click the Insert Function button on the Formula bar. The Insert Function dialog box appears.
2. Click the Or select a category list arrow and select Lookup and Reference.
3. Select VLOOKUP in the Select a function box and click OK.
4. Enter the required arguments for the VLOOKUP function.

Other Ways to Use the VLOOKUP Function in a Formula:
Write the formula using the syntax =VLOOKUP (lookup_value, table_array, col_index_num)

Tip:
- The HLOOKUP function is similar to the VLOOKUP function, except it searches horizontal from left to right across the top row of a cell range until it finds the value specified. When it finds the specified value it then looks down the column to find the specified value. Because of the way data is typically structured, VLOOKUP is much more powerful than HLOOKUP.

Exercise
- Exercise File: Functions.xlsx, VLOOKUP worksheet
- Exercise: Start by adding a label for the results of the VLOOKUP function and criteria: Type “Sales by Client” in cell E25 and type “21” in cell E26.

Enter the VLOOKUP function in E27 using these arguments:
- Lookup_value: E26
- Table_array: A1:I23
- Col_index_num: 9
- Range_lookup: False

=VLOOKUP(E26, A1:I23, 9)

Figure 7-25: The syntax for the VLOOKUP function.

Exercise File: Functions.xlsx, VLOOKUP worksheet
Exercise: Start by adding a label for the results of the VLOOKUP function and criteria: Type “Sales by Client” in cell E25 and type “21” in cell E26.

Enter the VLOOKUP function in E27 using these arguments:
- Lookup_value: E26
- Table_array: A1:I23
- Col_index_num: 9
- Range_lookup: False

=VLOOKUP(E26, A1:I23, 9)

Table Array
- The cell range in which data is looked up

Column Index Number
- The number of the column from which the matching value must be returned

Figure 7-26: The Function Arguments for the VLOOKUP function.
User Defined and Compatibility Functions

Functions are one of the major changes in Excel 2013. Many functions have been renamed to better reflect their usage, or replaced with a function that is more accurate. The descriptions for the functions themselves are also clearer, so it easier to understand how a function is to be used.

User Defined functions

If add-ins installed contain functions, these add-in or automation functions will be available in this category.

Compatibility functions

All the functions in this category have been replaced or renamed, but they are still available for backward compatibility. Consider using the new functions instead of these, because they may not be available in future versions of Excel.

Tables describing the rest of the function categories, along with more detailed examples of the functions in each category, appear in the following pages.

Exercise

- **Exercise File**: None required.
- **Exercise**: Understand the User Defined and Compatibility function categories in Excel 2013.
Excel’s financial functions are vital if working with investments or real estate. Financial functions help do things like determine loan payment amounts, calculate the future value of investments, and find rates of return. This table lists some of the Financial Functions available in Excel 2013.

### Table 7-6: Overview of Financial Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
</table>
| FV       | =FV(rate, number of periods, payment, present value, type) | Calculates the future value of an investment based on periodic, constant payments and a constant interest rate. Example: Plan to deposit $2,000 a year for 35 into an IRA, and expect a 10% average rate of return.  
  =FV(10%,35,-2000) equals $542,048.74 |
| IPMT     | =IPMT(rate, period, number of periods, present value, future value, type) | Calculates the interest payment for over a specified period of time, with constant periodic payments and a constant interest rate. Example: The following formula calculates the interest due in the first month of a three-year $8000 loan at 10 percent annual interest:  
  IPMT(0.1/12, 1, 36, 8000) equals -$66.67 |
| IRR      | =IRR(values, guess) | Calculates the internal rate of return of investment. The investments do not have to be equal, but they must occur at regular intervals. The internal rate of return is the interest rate received for an investment consisting of payments (negative values) and income (positive values) that occur at regular periods. Example: To start a business, it will cost $40,000 to start the business, and expect to net the following income in the first three years: $10,000, $15,000, and $20,000. Enter the four values in the cells A1:A4 of the worksheet, making sure to enter the initial $40,000 investment as a negative value.  
  IRR(A1:A4) equals 5% |
| NPV      | =NPV(rate, value1, value2, ...) | Calculates the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values). |
| PMT      | =PMT(rate, number of periods, present value, future value, type) | Calculates the payment for a loan based on constant payments and a constant interest rate. Example: The following formula calculates the monthly payment on a $20,000 loan with an annual interest rate of 9% that must be paid in 36-months.  
  PMT(9%/12, 36, 20000) equals ($635.99) |
| PV       | =PV(rate, number of periods, payment, future value, type) | Returns the present value of an investment. Example: An annuity that pays $600 every month for the next 20 years costs $50,000, and the money paid out will earn 7%. To determine whether this would be a good investment, use the PV function and find that the present value of the annuity is:  
  PV(0.07/12, 12*20, 600, , 0) equals ($77,389.50) |
| RATE     | =RATE(total number of payments, payment, present value) | Determines the interest rate per period of an annuity. Example: Calculate the rate of a four-year (48 month) $8,000 loan with monthly payments of $200. Using the RATE function:  
  RATE(48, -200, 8000) equals 0.77 percent  
  This is the monthly rate, because the period is monthly. The annual rate is 0.77%*12, which equals 9.24 percent. |

### Exercise

- **Exercise File**: None required.
- **Exercise**: Become familiar with Excel’s Financial functions.
Date & Time Functions

Use dates and time in formulas just like any other value.

One very important thing to know about working with date and time functions: while Excel can display dates and times using just about any format, it actually stores dates as chronological numbers called serial values. So when thinking of dates as months, days, and years, such as May 1, 2012, Excel thinks of dates in terms of serial numbers, such as 36281.

Since the date and time formulas often return serial number values, format any cells with date or time formulas with data and time formats that can easily be understood. Create custom number formats to display the results of date formulas.

This table lists some of the Date & Time Functions available in Excel 2013.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATE()</td>
<td>Enters a date in the cell.</td>
<td>=DATE(12,5,1) equals May 1, 2012.</td>
</tr>
<tr>
<td>TODAY()</td>
<td>A special version of the DATE function. While the DATE function can return the value of any date, the TODAY function always returns the value of the current date.</td>
<td></td>
</tr>
<tr>
<td>TIME()</td>
<td>Enters a time in the cell. Uses a 24-hour (military) time system.</td>
<td>=TIME(14,30) equals 2:30 PM.</td>
</tr>
<tr>
<td>NOW()</td>
<td>A special version of the TIME function. While the TIME function can return the value of any time, the NOW function always returns the value of the current time.</td>
<td></td>
</tr>
<tr>
<td>WEEKDAY()</td>
<td>Returns a day of the week for a specific date. The serial_number argument is a date value (or reference to one).</td>
<td>=WEEKDAY(&quot;2/14/12&quot;) equals Wednesday.</td>
</tr>
<tr>
<td>YEAR()</td>
<td>Returns a value of the year for a specific date. The serial_number argument is a date value (or reference to one).</td>
<td>=YEAR(&quot;3/15/2012&quot;) equals 1998.</td>
</tr>
<tr>
<td>MONTH()</td>
<td>Returns a value of the month for a specific date. The serial_number argument is a date value (or reference to one).</td>
<td>=MONTH(&quot;3/15/2012&quot;) equals 3.</td>
</tr>
<tr>
<td>DAY()</td>
<td>Returns a value of the day for a specific date. The serial_number argument is a date value (or reference to one).</td>
<td>=DAY(&quot;3/15/2012&quot;) equals 15.</td>
</tr>
<tr>
<td>HOUR()</td>
<td>Returns hour value for a specific time. The serial_number argument is a time value (or reference to one). Uses a 24-hour time format.</td>
<td>=HOUR(&quot;12:15:45&quot;) equals 12.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** None required.
- **Exercise:** Become familiar with Excel’s Date & Time functions.
### Table 7-7: Overview of Date & Time Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>MINUTE</strong></td>
<td><code>=MINUTE(serial_number)</code></td>
<td>Returns the minute value for a specific time. The serial_number argument is a time value (or reference to one). Uses a 24-hour time format. Example: MINUTE(&quot;12:15:45&quot;) equals 15.</td>
</tr>
<tr>
<td><strong>SECOND</strong></td>
<td><code>=SECOND(serial_number)</code></td>
<td>Returns a value of a second for a specific time. The serial_number argument is a time value (or reference to one). Uses a 24-hour time format. Example: SECOND(&quot;12:15:45&quot;) equals 45.</td>
</tr>
<tr>
<td><strong>HOUR</strong></td>
<td><code>=HOUR(serial_number)</code></td>
<td>Returns the hour as a number from 0 (12:00 A.M.) to 23 (11:00 P.M.). Example: HOUR(“3:30 PM”) equals 15.</td>
</tr>
<tr>
<td><strong>DAYS360</strong></td>
<td><code>=DAYS360(start_date,end_date)</code></td>
<td>Returns the number of days between two dates based on a 360-day year (twelve 30-day months), which is used in some accounting calculations. Example: DAYS360(&quot;1/30/12&quot;, &quot;2/1/12&quot;) equals 1.</td>
</tr>
</tbody>
</table>
Math & Trig Functions

Find many of Excel’s mathematical functions on a typical scientific calculator.

This table lists some of the Math & Trig Functions available in Excel 2013.

Table 7-8: Overview of Math & Trig Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABS</td>
<td>=ABS(number)</td>
<td>Determines the absolute value of a number. The absolute value of a number is the number without its sign.</td>
</tr>
<tr>
<td>ACOS</td>
<td>=ACOS(number)</td>
<td>Returns the arccosine of an angle. ACOS is the inverse of the COS function.</td>
</tr>
<tr>
<td>ACOSH</td>
<td>=ACOSH(number)</td>
<td>Returns the inverse hyperbolic cosine of a number.</td>
</tr>
<tr>
<td>AGGREGATE</td>
<td>=AGGREGATE(…)</td>
<td>Returns an aggregate in a list or database.</td>
</tr>
<tr>
<td>ASIN</td>
<td>=ASIN(number)</td>
<td>Returns the arcsine of an angle. ASIN is the inverse of the SIN function.</td>
</tr>
<tr>
<td>CEILING</td>
<td>=CEILING(number, significance)</td>
<td>Rounds a number up, to the nearest multiple of significance.</td>
</tr>
<tr>
<td>CEILING.PRECISE</td>
<td>=CEILING.PRECISE(number, significance)</td>
<td>Rounds a number up, to the nearest integer or to the nearest multiple of significance.</td>
</tr>
<tr>
<td>COMBIN</td>
<td>=COMBIN(number, number_chosen)</td>
<td>Calculates the number of possible combinations from a given number of items.</td>
</tr>
<tr>
<td>COS</td>
<td>=COS(number)</td>
<td>Returns the cosine of an angle.</td>
</tr>
<tr>
<td>DEGREES</td>
<td>=DEGREES(angle)</td>
<td>Converts radians into degrees.</td>
</tr>
<tr>
<td>EVEN</td>
<td>=EVEN(number)</td>
<td>Rounds a number up to the nearest even or odd integer.</td>
</tr>
<tr>
<td>ODD</td>
<td>=ODD(number)</td>
<td></td>
</tr>
<tr>
<td>EXP</td>
<td>=EXP(number)</td>
<td>Calculates the value of the constant e (approximately 2.71828182845904) raised to the power specified by its argument.</td>
</tr>
<tr>
<td>FACT</td>
<td>=FACT(number)</td>
<td>Calculates the factorial of a number. The factorial of a number is the product of all the positive integers from one up to the specified number.</td>
</tr>
<tr>
<td>FLOOR</td>
<td>=FLOOR(number, significance)</td>
<td>Rounds a number down to the nearest multiple of significance.</td>
</tr>
<tr>
<td>FLOOR.PRECISE</td>
<td>=FLOOR.PRECISE(number, significance)</td>
<td>Rounds a number down, to the nearest integer or to the nearest multiple of significance.</td>
</tr>
<tr>
<td>LN</td>
<td>=LN(number)</td>
<td>Calculates the natural (base e) logarithm of a positive number.</td>
</tr>
<tr>
<td>LOG</td>
<td>=LOG(number, base)</td>
<td>Calculates the logarithm of a positive number using a specified base,</td>
</tr>
<tr>
<td>LOG10</td>
<td>=LOG(number)</td>
<td>Calculates the base 10 logarithm of a number.</td>
</tr>
</tbody>
</table>

Exercise

- Exercise File: None required.
- Exercise: Become familiar with Excel’s Math & Trig functions.
### Table 7-8: Overview of Math & Trig Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>MOD</strong></td>
<td>=MOD(number, divisor) Returns the remainder after number is divided by divisor. Example: MOD(3, 2) equals 1, the remainder of dividing 3 by 2.</td>
</tr>
<tr>
<td><strong>PI</strong></td>
<td>=PI( ) Returns the value of the constant pi (π), accurate to 14 decimal places.</td>
</tr>
<tr>
<td><strong>PRODUCT</strong></td>
<td>=PRODUCT(number1, number2…) Multiplies all the numbers in a range of cells</td>
</tr>
<tr>
<td><strong>RADIANS</strong></td>
<td>=DEGREES(angle) Converts degrees to radians.</td>
</tr>
<tr>
<td><strong>RAND</strong></td>
<td>=RAND() Generates a random number between 0 and 1.</td>
</tr>
<tr>
<td><strong>RANDBETWEEN</strong></td>
<td>=RANDBETWEEN (bottom, top) Generates a random number between the bottom and top arguments.</td>
</tr>
<tr>
<td><strong>ROUND</strong></td>
<td>=ROUND(number, num_digits) Rounds a number to a specified number of digits. The ROUNDDOWN and ROUNDUP function takes the same form as the ROUND function, and as their name implies, always round either up or down.</td>
</tr>
<tr>
<td><strong>SIGN</strong></td>
<td>=SIGN(number) Determines the sign of a number. Results in 1 if the number is positive, zero (0) if the number is 0, and -1 if the number is negative.</td>
</tr>
<tr>
<td><strong>SIN</strong></td>
<td>=SIN(number) Returns the sine of an angle.</td>
</tr>
<tr>
<td><strong>SQR</strong></td>
<td>=SQRT(number) Returns a positive square root of a number.</td>
</tr>
<tr>
<td><strong>SUM</strong></td>
<td>=SUM(number1, number2…) Adds all the numbers in a range of cells.</td>
</tr>
<tr>
<td><strong>SUMIF</strong></td>
<td>=SUMIF(range, criteria, sum_range) Adds the cells only if they meet the specified criteria. Example: Total the cell range B1:B5 only if the value in cell A1 is greater than 500. SUMIF(A1,“&gt;500”,B1:B5)</td>
</tr>
<tr>
<td><strong>TAN</strong></td>
<td>=TAN(number) Returns the tangent of an angle.</td>
</tr>
</tbody>
</table>
Statistical Functions

Excel offers a large number of functions to help analyze statistical data.

This table lists some of the Statistical Functions available in Excel 2013.

Table 7-9: Overview of Statistical Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVERAGE</td>
<td>=AVERAGE(number1, number2…) Calculates the average, or arithmetic mean, of</td>
</tr>
<tr>
<td></td>
<td>the numbers in the range or arguments.</td>
</tr>
<tr>
<td>COUNT</td>
<td>=COUNT(number1, number2…) Counts the number of cells that contain numbers,</td>
</tr>
<tr>
<td></td>
<td>including dates and formulas. Ignores all blank cells and cells that contain</td>
</tr>
<tr>
<td></td>
<td>text or errors.</td>
</tr>
<tr>
<td>COUNTA</td>
<td>=COUNTA(number1, number2…) Counts the number of cells in a range that are</td>
</tr>
<tr>
<td></td>
<td>not empty.</td>
</tr>
<tr>
<td>COUNTIF</td>
<td>=COUNTIF(range, criteria) Counts the number of cells within a range that</td>
</tr>
<tr>
<td></td>
<td>meet the given condition.</td>
</tr>
<tr>
<td>MAX</td>
<td>=MAX(number1, number2…) Returns the largest value in a range. Ignores logical</td>
</tr>
<tr>
<td></td>
<td>values and text.</td>
</tr>
<tr>
<td>MEDIAN</td>
<td>=MEDIAN(number1, number2…) Returns the median, or the number in the middle</td>
</tr>
<tr>
<td></td>
<td>of the set of given numbers.</td>
</tr>
<tr>
<td>MIN</td>
<td>=MIN(number1, number2…) Returns the smallest value in a set of numbers.</td>
</tr>
<tr>
<td></td>
<td>Ignores logical values and text.</td>
</tr>
<tr>
<td>MODE.MULT</td>
<td>=MODE.MULT(number1, number2…) Determines which value occurs most frequently</td>
</tr>
<tr>
<td></td>
<td>in a set of numbers.</td>
</tr>
<tr>
<td>MODE.SNGL</td>
<td>=MODE.SNGL(number1, number2…) Returns the most frequently occurring, or</td>
</tr>
<tr>
<td></td>
<td>repetitive, value in an array or range of data.</td>
</tr>
<tr>
<td>STDEV</td>
<td>=STDEV(number1, number2…) Estimates standard deviation based on a sample.</td>
</tr>
<tr>
<td></td>
<td>The standard deviation is a measure of how widely values are dispersed from</td>
</tr>
<tr>
<td></td>
<td>the average value.</td>
</tr>
<tr>
<td>STDEVA</td>
<td>=STDEVA(value1, value2…) Estimates standard deviation based on a sample,</td>
</tr>
<tr>
<td></td>
<td>including logical values and text. Text and the logical value FALSE have the</td>
</tr>
<tr>
<td></td>
<td>value 0; the logical value TRUE has the value 1.</td>
</tr>
<tr>
<td>STDEVPA</td>
<td>=STDEVPA(value1, value2…) Calculates standard deviation based on an entire</td>
</tr>
<tr>
<td></td>
<td>population, including logical values and text. Text and the logical value</td>
</tr>
<tr>
<td></td>
<td>FALSE have the value 0; the logical value TRUE has the value 1.</td>
</tr>
<tr>
<td>VAR.P</td>
<td>=VAR.P(number1, number2…) Estimates variance based on the entire population</td>
</tr>
<tr>
<td></td>
<td>(ignores logical values and text in the population).</td>
</tr>
<tr>
<td>VAR.S</td>
<td>=VAR.S(number1, number2…) Estimates variance based on a sample (ignores</td>
</tr>
<tr>
<td></td>
<td>logical values and text in the sample).</td>
</tr>
<tr>
<td>VARA</td>
<td>=VARA(value1, value2…) Estimates variance based on a sample, including</td>
</tr>
<tr>
<td></td>
<td>logical values and text. Text and the logical value FALSE have the value 0;</td>
</tr>
<tr>
<td></td>
<td>the logical value TRUE has the value 1.</td>
</tr>
<tr>
<td>VARPA</td>
<td>=VARPA(value1, value2…) Calculates variance based on the entire population,</td>
</tr>
<tr>
<td></td>
<td>including logical values and text. Text and the logical value FALSE have the</td>
</tr>
<tr>
<td></td>
<td>value 0; the logical value TRUE has the value 1.</td>
</tr>
</tbody>
</table>

Exercise

- **Exercise File:** None required.
- **Exercise:** Become familiar with some of Excel’s Statistical functions.
Lookup & Reference Functions

Use Excel’s Lookup & Reference functions to locate values in rows or columns of data.

This table lists some of the Lookup & Reference Functions available in Excel 2013.

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COLUMN</td>
<td>=COLUMN(reference)</td>
<td>Returns the column number of a reference.</td>
</tr>
<tr>
<td>COLUMNS</td>
<td>=COLUMNS(array)</td>
<td>Returns the number of columns in an array or reference.</td>
</tr>
<tr>
<td>HLOOKUP</td>
<td>=HLOOKUP(lookup_value, table_array, row_index_num, range_lookup)</td>
<td>Looks for a value in the top row of a table or array of values and returns the value in the same column from a row specified.</td>
</tr>
<tr>
<td>LOOKUP</td>
<td>=LOOKUP(...)</td>
<td>Looks up a value either from a one-row or one-column range or from an array. Provided for backward compatibility.</td>
</tr>
<tr>
<td>ROW</td>
<td>=ROW(reference)</td>
<td>Returns the row number of a reference.</td>
</tr>
<tr>
<td>ROWS</td>
<td>=ROWS(array)</td>
<td>Returns the number of rows in a reference or array.</td>
</tr>
<tr>
<td>TRANSPOSE</td>
<td>=TRANSPOSE(array)</td>
<td>Converts a vertical range of cells as a horizontal range, or vice versa.</td>
</tr>
<tr>
<td>VLOOKUP</td>
<td>=VLOOKUP(lookup_value, table_array, col_index_num, range_lookup)</td>
<td>Looks for a value in the leftmost column of a table, and then returns a value in the same row from a column specified. By default, the table must be sorted in an ascending order.</td>
</tr>
</tbody>
</table>

**Exercise**

- **Exercise File:** None required.
- **Exercise:** Become familiar with Excel’s Lookup & Reference functions.
Database Functions

Database functions return results based on filtered criteria. All the database functions use the same basic syntax:

=Function(database, field, criteria). The arguments include:

- **Database**: The cell range that makes up the list or database.
- **Field**: Indicates which column is used in the function. Refer to fields by their column label enclosed with double quotation marks, such as "Name" or as a number that represents the position of the column in the list: 1 for the first column, 2 for the second, and so on—not the column heading numbers!
- **Criteria**: Is a reference to the cell or cell range that specifies the criteria for the function. For example, total records from a certain region.

**Table 7-11: Overview of Database Functions**, lists some of the Database Functions available in Excel 2013.

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAVERAGE</td>
<td>=DAVERAGE(database, field, criteria)</td>
<td>Averages the values in a column in a list or database that match conditions specified.</td>
</tr>
<tr>
<td>DCOUNT</td>
<td>=DCOUNT(database, field, criteria)</td>
<td>Counts the cells containing numbers in the field (column) of records in the database that match the conditions specified.</td>
</tr>
<tr>
<td>DGET</td>
<td>=DGET(database, field, criteria)</td>
<td>Extracts from the database a single record that matches the conditions specified.</td>
</tr>
<tr>
<td>DMAX</td>
<td>=DMAX(database, field, criteria)</td>
<td>Returns the largest number in the field (column) of records in the database that match the conditions specified.</td>
</tr>
<tr>
<td>DMIN</td>
<td>=DMIN(database, field, criteria)</td>
<td>Returns the smallest number in the field (column) of records in the database that match the conditions specified.</td>
</tr>
<tr>
<td>DSTDEV</td>
<td>=DSTDEV(database, field, criteria)</td>
<td>Estimates standard deviation based on a sample from selected database entries.</td>
</tr>
<tr>
<td>DSUM</td>
<td>=DSUM(database, field, criteria)</td>
<td>Adds the numbers in the field (column) of records in the database that match the conditions specified.</td>
</tr>
<tr>
<td>DVAR</td>
<td>=DVAR(database, field, criteria)</td>
<td>Estimates variance based on a sample from selected database entries.</td>
</tr>
</tbody>
</table>

**Exercise**

- **Exercise File**: None required.
- **Exercise**: Become familiar with Excel’s Database functions.
Text Functions

Excel offers a category of functions aimed at working with text. These functions allow removing, combining, and replacing different pieces of text in a worksheet.

This table lists some of the Text Functions available in Excel 2013.

<table>
<thead>
<tr>
<th>Table 7-12: Overview of Text Functions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CONCATENATE</strong></td>
</tr>
<tr>
<td>EXACT</td>
</tr>
<tr>
<td>LEFT</td>
</tr>
<tr>
<td>LEN</td>
</tr>
<tr>
<td>LOWER</td>
</tr>
<tr>
<td>MID</td>
</tr>
<tr>
<td>PROPER</td>
</tr>
<tr>
<td>REPLACE</td>
</tr>
<tr>
<td>RIGHT</td>
</tr>
<tr>
<td>SUBSTITUTE</td>
</tr>
<tr>
<td>TRIM</td>
</tr>
<tr>
<td>UPPER</td>
</tr>
</tbody>
</table>

Exercise

• Exercise File: None required.
• Exercise: Become familiar with Excel’s Text functions.
Logical Functions

Logical functions allow evaluations of logical arguments and conditions. The most famous logical function is probably the IF function.

This table lists some of the Logical Functions available in Excel 2013.

Table 7-13: Overview of Logical Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AND</td>
<td>AND(logical1,logical2, ...)</td>
<td>Checks whether all arguments are TRUE, and returns TRUE if all arguments are TRUE.</td>
</tr>
<tr>
<td>FALSE</td>
<td>FALSE()</td>
<td>Returns the logical value FALSE.</td>
</tr>
<tr>
<td>IF</td>
<td>IF(logical_test,value_if_true,value_if_false)</td>
<td>Checks whether a condition is met, and returns one value if TRUE, and another value if FALSE.</td>
</tr>
<tr>
<td>IFERROR</td>
<td>IFERROR(value,value_if_error)</td>
<td>Returns value_if_error if expression is an error and the value of the expression itself otherwise.</td>
</tr>
<tr>
<td>NOT</td>
<td>NOT(logical)</td>
<td>Changes FALSE to TRUE, or TRUE to FALSE.</td>
</tr>
<tr>
<td>OR</td>
<td>OR(logical1,logical2,...)</td>
<td>Checks whether any of the arguments are TRUE, and returns TRUE or FALSE. Returns FALSE only if all arguments are FALSE.</td>
</tr>
<tr>
<td>TRUE</td>
<td>TRUE()</td>
<td>Returns the logical value TRUE.</td>
</tr>
</tbody>
</table>

Exercise

- Exercise File: None required.
- Exercise: Become familiar with Excel’s Logical functions.
Information Functions

Information functions allow logical arguments and conditions to be evaluated.

This table lists some of the Information Functions available in Excel 2013.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AND(logical1,logical2, ...)</td>
<td>Checks whether all arguments are TRUE, and returns TRUE if all arguments are TRUE.</td>
</tr>
<tr>
<td>FALSE()</td>
<td>Returns the logical value FALSE.</td>
</tr>
<tr>
<td>IF(logical_test,value_if_true,value_if_false)</td>
<td>Checks whether a condition is met, and returns one value if TRUE, and another value if FALSE.</td>
</tr>
<tr>
<td>IFERROR(value,value_if_error)</td>
<td>Returns value_if_error if expression is an error and the value of the expression itself otherwise.</td>
</tr>
<tr>
<td>NOT(logical)</td>
<td>Changes FALSE to TRUE, or TRUE to FALSE.</td>
</tr>
<tr>
<td>OR(logical1,logical2,...)</td>
<td>Checks whether any of the arguments are TRUE, and returns TRUE or FALSE. Returns FALSE only if all arguments are FALSE.</td>
</tr>
<tr>
<td>TRUE()</td>
<td>Returns the logical value TRUE.</td>
</tr>
</tbody>
</table>

**Exercise**

- **Exercise File**: None required.
- **Exercise**: Become familiar with Excel’s Information functions.
### Engineering and Cube Functions

This table lists some of the Engineering Functions available in Excel 2013.

**Table 7-15: Overview of Engineering Functions**

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BESSELI</td>
<td>BESSELI(x,n)</td>
</tr>
<tr>
<td>BIN2DEC</td>
<td>BIN2DEC(number)</td>
</tr>
<tr>
<td>COMPLEX</td>
<td>COMPLEX(real_num;i_num,suffix)</td>
</tr>
<tr>
<td>CONVERT</td>
<td>CONVERT(number,from_unit,to_unit)</td>
</tr>
<tr>
<td>DELTA</td>
<td>DELTA(number1,number2)</td>
</tr>
</tbody>
</table>

This table lists some of the Cube Functions.

**Table 7-16: Overview of Cube Functions**

<table>
<thead>
<tr>
<th>Function</th>
<th>Formula/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CUBEKPIMEMBER</td>
<td>CUBEKPIMEMBER(connection, kpi_name, kpi_property, [caption])</td>
</tr>
<tr>
<td>CUBEMEMBER</td>
<td>CUBEMEMBER(connection, member_expression, [caption])</td>
</tr>
<tr>
<td>CUBEMEMBERPROPERTY</td>
<td>CUBEMEMBERPROPERTY(connection, member_expression, property)</td>
</tr>
<tr>
<td>CUBERANKEDMEMBER</td>
<td>CUBERANKEDMEMBER(connection, set_expression, rank, [caption])</td>
</tr>
<tr>
<td>CUBESET</td>
<td>CUBESET(connection, set_expression, [caption], [sort_order], [sort_by])</td>
</tr>
<tr>
<td>CUBESETCOUNT</td>
<td>CUBESETCOUNT(count)</td>
</tr>
<tr>
<td>CUBEVALUE</td>
<td>CUBEVALUE(connection, [member_expression1], [member_expression2], …)</td>
</tr>
</tbody>
</table>

---

**Exercise**

- **Exercise File:** None required.
- **Exercise:** Become familiar with some of Excel’s Engineering and Cube functions.
More Functions and Formulas Review

Quiz Questions

1. To change the order of evaluation, enclose the part of the formula to be calculated first in parentheses. (True or False?)

2. Which of the following is NOT a category of functions in Excel?
   A. Scientific
   B. Financial
   C. Logical
   D. Math & Trig

3. By default, Excel recalculates the formulas in a workbook whenever a value is changed that affects another value. (True or False?)

4. Define a name for multiple non-adjacent cells. (True or False?)

5. Which of the following is NOT a button found in the Defined Names group?
   A. Name Manager
   B. Evaluate Formula
   C. Define Name
   D. Use in Formula

6. Click the __________ button to display arrows that show what cells affect the currently selected cell.
   A. Show Formulas
   B. Watch Window
   C. Define Name
   D. Trace Precedents

7. The Error Checking dialog box does not include which one of the following buttons?
   A. Help on this error
   B. Show Calculation Steps
   C. Edit in Formula Bar
   D. Show Formulas

8. What are the three arguments or parts of an IF formula?
   A. IF, THEN, ELSE
   B. The conditional statement, the value if the test is false, and the value if the test is true.
   C. The logical test, the value if the test is true, and the value if the test is false.
   D. The conditional statement, the expression, and the value.

9. Which is NOT a required part of a PMT function?
   A. The interest rate.
B. The amount of the loan, or principal.
C. The number of payments.
D. If the interest rate is Fixed or Variable.

10. The DSUM function calculates the totals of specific records based on the criteria. (True or False?)

11. Which of the following functions looks up values vertically down a column and then horizontally across a row?
   A. HLOOKUP
   B. DSUM
   C. DLOOKUP
   D. VLOOKUP

**Quiz Answers**

1. True. To change the order of evaluation, enclose the part of the formula to be calculated first in parentheses.

2. A. Scientific is not a category of functions in Excel.

3. True. By default, Excel recalculates the formulas in a workbook whenever a value is changed that affects another value.

4. True. Define a name for multiple non-adjacent cells.

5. B. The Evaluate Formula button is not found in the Defined Names group.

6. D. Click the Trace Precedents button to display arrows that show what cells affect the currently selected cell.

7. D. The Error Checking dialog box does not have a Show Formulas button.

8. C. The three parts of an IF formula are the logical test, the value if the test is true, and the value if the test is false.

9. D. A fixed or variable interest rate option is not part of the PMT function.

10. True. The DSUM calculates the totals of specific records based on the criteria.

11. The VLOOKUP functions can look up values vertically down a column and then horizontally across a row.
Working with Data Ranges

Sorting by One Column ..................................... 182
Sorting by Colors or Icons ................................. 184
Sorting by Multiple Columns .............................. 185
Sorting by a Custom List .................................. 186
  Create a custom list .................................. 186
  Sort by a custom list ................................. 186
Filtering Data ....................................................... 188
  Filter text, numbers and dates .................. 188
  Remove filtering ........................................ 188
Creating a Custom AutoFilter ............................ 189
Using an Advanced Filter ................................. 190

If data is organized into a range of rows and columns, it’s easy to sort the data into a desired order, or filter the data to display specific information, such as records from a specific zip code.

This chapter teaches how to sort and filter data in data ranges in several different ways.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Sorting by One Column

In Excel it’s possible to take ranges of data and sort them into different orders.

Before sorting data, make sure it’s organized into two components:

- **Fields (columns):** Records are broken up into fields which store specific pieces of information, such as first and last name.
- **Records (rows):** Each record contains information about a unique thing or person, just like a listing in a phone book.

Once the data is organized in columns and rows, sort by values in a certain column.

**Trap:** If data has column headings, don’t select them when sorting, or they’ll be sorted along with other data—unless the *Sort & Filter* button is first clicked in the Editing group on the Home tab; select *Custom Sort*, and check the *My data has headers* box.

1. Select a range of data or select a cell in the column.

**Trap:** If a column of data is selected with more data next to it, the Sort Warning dialog box appears, asking to expand the selection. Normally, do this; otherwise, the column of data selected will be sorted independently of the surrounding data.

2. Click the *Home* tab on the Ribbon and click the *Sort & Filter* button in the Editing group.

A list of sorting options appears, which change according to the type of data being sorted:

- **Text options:** Sort A to Z or Sort Z to A.
- **Number options:** Sort Smallest to Largest or Sort Largest to Smallest.
- **Date options:** Sort Oldest to Newest or Sort Newest to Oldest.

3. Select a sort option.

The column is sorted based on the values in the left-most column in the selected range. All the fields within each record move together. For example, if a list of first and last names is sorted by last name, the first names still correspond to the last names after sorting.

**Other Ways to Sort:** Select the entire range or select a cell in the column to sort by. Click the *Data* tab on the Ribbon and click one of the sort buttons in the Sort & Filter group. Or, right-click a cell in a column that

---

**Exercise**

- **Exercise File:** SalesReps8-1.xlsx
- **Exercise:** Sort the data in the Last column from A to Z. (Don’t include the column header—“Last”—along with the data.)

![Sort Warning](image)

**Figure 8-1:** Before and after sorting data.

![Sort Warning](image)

**Figure 8-2:** Always expand the selection if sorting data in a list. If the selection is not expanded, the data will be mismatched with other records or fields.
Working with Data Ranges

contains data, point to Sort, and select a sort option from the list.

💡 Tips
✓ To sort by rows instead of columns, click the Sort & Filter button in the Editing group on the Home tab, select Custom Sort, click Options in the Sort dialog box and select Sort left to right.
Sorting by Colors or Icons

To sort by cell colors, font colors, or by icons, use a custom sort.

1. Select the range of data or a cell within the range.
   The data should contain cell or font color formatting or icons created with conditional formatting.

2. Click the **Home** tab on the Ribbon and click the **Sort & Filter** button in the Editing group.

3. Select **Custom Sort**.
   The Sort dialog box appears. First select which column to sort by.
   
   **Tip:** If the range being sorted includes headers, select **My data has headers** option so that the headers aren’t sorted with the rest of the data.

4. Click the **Sort by** list arrow and select the column to sort by.
   Next specify the type of sort.

5. Click the **Sort On** list arrow and select the type of sort to use.
   
   **Tip:** Define the sort order for cell colors, font colors, or icons. Excel does not have a default order like it does for values.

6. Click the first list arrow in the Order column and select a cell or font color, or icon.
   Now tell Excel where to put the color or icon selected. Select: On Top or On Bottom to move it to the top of bottom of the column sort. If sorting by rows, select from On Left or On Right.

7. Click the second list arrow in the Order column and select the option to use.
   
   **Tip:** The data will be sorted with the color or icon selected placed on top or bottom as specified. Specify additional colors or icons by adding additional levels to the sort.

   **Tip:** Click **Add Level** button in the Sort dialog box to add a sort level. Click the **Delete Level** button to delete the selected sort level to stop its use.

8. Click **OK**.

---

### Exercise

- **Exercise File:** SalesReps8-1.xlsx
- **Exercise:** Sort the data by the Sales column so that the red cell icon is on top. Add a second sort level to sort by the Sales column, Cell Icon, and this time with the yellow icon on top. Now the sales reps should be sorted from red icons on top, green icons on the bottom. Finally, clear conditional formatting from the sheet: click the Conditional Formatting button in the Styles group on the Home tab. Point to Clear Rules and select Clear Rules from Entire Sheet.

---

![Figure 8-3: Sorting by cell icon in the Sort dialog box.](image-url)
Sorting by Multiple Columns

To sort by more than one column, use a custom sort.

1. Select a range of cells with at least two columns of data or select a cell within the range.

2. Click the Home tab on the Ribbon and click the Sort & Filter button in the Editing group.

3. Select Custom Sort.
   The Sort dialog box appears.

4. Click the Sort by list arrow and select the first column to sort by.

5. Click the Sort On list arrow and select the type of sort to use.

6. Click the Order list arrow(s) and select the option(s) to use.
   To sort by multiple columns, use more sort levels.

7. Click Add Level.
   Excel will sort the data by each level in order.

8. Repeat the sorting steps for the next level, selecting the next column to sort by, and add more levels.
   Excel will sort the data by each level in order.

   Tip: Click the Delete Level button to delete a sort level to stop its use.

9. Click OK.

Exercise

• Exercise File: SalesReps8-3.xlsx

• Exercise: Sort by multiple columns to see who has the highest sales by region: Sort first by the Region column and sort on Values from A to Z, then sort by the Sales column and sort on Values from Largest to Smallest.

Figure 8-4: Sorting by multiple columns in the Sort dialog box.

Figure 8-5: The results of the custom sort.
Sorting by a Custom List

A custom list allows criteria to be sorted by a specified definition or by one of Excel’s predefined custom lists.

Create a custom list

First let’s look at how to create a custom list.

1. Enter the values to sort by, in the correct order from top to bottom, in a column of cells.

2. Select the values just entered. Now create the list.

3. Click the File tab on the Ribbon and select Options from the list. The Excel Options dialog box appears.

4. Click the Advanced tab, scroll down and in the General section, and click the Edit Custom Lists button. The Custom Lists dialog box appears. See the custom lists that are already stored in Excel.

5. Select the cells to use in the Import list from cells section in the Custom Lists dialog box. Click the Import button.

6. Click OK. The Custom Lists dialog box closes.

7. Click OK. The Excel Options dialog box closes and the custom list is created.

Tip:

✓ It’s only possible to create a custom list based on a value, not on cell color, font color, or an icon.

Sort by a custom list

Once a list is created, or if using one of Excel’s predefined custom lists, the data is ready to sort.

1. Select the range of data to sort or select a cell within the range.

2. Click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and select Custom Sort. The Sort dialog box appears.

Exercise

• Exercise File: SalesReps8-4.xlsx
• Exercise: This exercise sorts the sales reps by position from most senior to least senior.
  In cells A10:A12, enter Senior Manager, Manager, and Associate. Create a custom list using those values.
  Next, sort the data by the Position field using the custom list just created (if Sort levels appear in the dialog box from previous sorts, just modify the first one for this new sort). Then delete the values from cells A10:A12.

Figure 8-6: Adding a custom list in the Custom Lists dialog box.

Figure 8-7: The Custom Lists dialog box after the custom list is added.

Figure 8-8: Results sorted by custom list.
3. Click the **Sort by** list arrow and select a column to sort by (the column with data that matches the custom list).

4. Click the **Order** list arrow and select **Custom List**.

5. Select the custom list to use and click **OK**.

6. Click **OK**.

   The data is sorted according to the custom list.

**Tip:**

- To sort by rows instead of columns, click **Options** in the Sort dialog box and select **Sort left to right**.
Filtering Data

When filtering data, Excel displays only the records that meet the criteria specified—other records are hidden.

Filter text, numbers and dates
Filter by values such as text, numbers, or dates.

1. Select the range of data to filter or select a cell within the range.

2. Click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and click Filter. Filter buttons that look like arrows appear in the first cell of each field header.

   Other Ways to Filter:
   Click the Data tab on the Ribbon and click the Filter button in the Sort & Filter group.

3. Click the filter button for the column to filter.

4. Click the check boxes of values to display.

   Other Ways to Select Filter Criteria:
   Click the Search box in the filter list and type the criteria by which to filter. The list displays criteria that match the search. Keep filtering by additional columns.

5. (Optional) Click another column’s filter button and apply more filter criteria.

6. Click OK.
   The data is further reduced.

Remove filtering
Remove a filter to once again display all the data.

1. Click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and select Filter.
   The filter buttons disappear and filtering is removed.

Exercise

- Exercise File: SalesReps8-5.xlsx
- Exercise: Filter the data by region so that only North sales reps appear. Then filter those records additionally so only Associates appear (only Denise Winters should remain). Remove the filters so all the data once again appears and the filter buttons disappear.
Creating a Custom AutoFilter

Excel offers some predefined filter criteria that can be accessed using a Custom AutoFilter. This lesson explains how to filter data using Custom AutoFilter.

1. Select a range of cells to filter plus the column header row (or a blank row, if there isn’t a header).

2. Click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and click Filter.
   Filter buttons appear in the first cell of each column in the range.

3. Click the filter button in the column to filter.
   A list of options appears. Depending on whether the selected cells contain text, numbers, or dates, the options will differ.

4. Point to the option that appears in the list: Text Filters, Number Filters, or Date Filters.
   A list of comparison operators, such as Equals, appears, as well as the Custom Filter option.

5. Select Custom Filter.
   The Custom AutoFilter dialog box appears.
   ✅ Tip: If working with numbers or dates and a comparison operator such as Above Average is selected (instead of selecting Custom Filter), the Custom AutoFilter dialog box won’t appear—the data will simply be filtered.

6. Click the first list arrow and select a comparison operator.

7. Click the second list arrow in the first row and select a value from the list or enter a value in the text box.

8. (Optional) Select And or Or and select a second criteria to filter the column by.
   ✅ Tip: Use wildcards when entering values in the Custom AutoFilter dialog box. Use a ‘?’ to represent any single character or a ‘*’ to represent a series of characters.

9. Click OK.
   The Custom AutoFilter dialog box closes and the data is filtered.

Exercise

- Exercise File: SalesReps8-6.xlsx
- Exercise: Use a custom filter to display only the sales reps that are not Associates. (Hint: For the Position column, select “Does not equal” as the operator and “Associate” as the value.)
  Clear the filter.

Figure 8-11: The Custom AutoFilter dialog box.
Using an Advanced Filter

Advanced filtering is the most powerful and flexible way to filter Excel data. It’s also the most difficult method, and requires more work to set up and use. With an Advanced Filter, it’s possible to:

- Filter using criteria located outside of the data range.
- Use wildcards in the filter criteria.
- Extract and copy filtered results to another range on the worksheet.

To create an Advanced Filter, start by defining a criteria range. A criteria range is a cell range located outside of the data range that contains the filter criteria.

1. Copy the desired column labels from the data range and paste them in the first row of the criteria range.
   For example, to filter for sales reps with sales greater than $20,000 and who are also managers, copy the Sales and Position column labels to the criteria range.
   
   **Tip:** The criteria range can be any area of open cells on the worksheet and only copy the labels for the columns that contain criteria to be filtering on.

2. In the rows below the criteria labels, type the criteria to filter for.
   In the above example, type >20000 under the Sales label and Manager under the Position label.
   
   **Tip:** Enter values or text to filter for, and incorporate operators such as < or > to specify the records to filter for. Use wildcards—for example, enter *r to filter out text that doesn’t end with the letter “r”.

3. Click the Data tab on the Ribbon and click the Advanced button in the Sort & Filter group.
   The Advanced Filter dialog box appears. Specify the range of data to filter, as well as the criteria to filter by.

4. Make sure the Filter the list, in-place option is selected in the Action area.
   That way, the filtered results will be displayed right in the original data range.
   
   **Tip:** To copy filtered results to another location on the worksheet, first prepare an extract range with labels for the fields to display. The extracted fields needn’t be the same fields that are used in the criteria range. For example, set the filter to only show certain records, and then extract only the names of records that match those criteria. Select

---

**Exercise**

- **Exercise File:** SalesReps8-7.xlsx
- **Exercise:** Use the Advanced Filter to filter for Sales >18,000, and a Position that ends with r (Hint: use *r). Clear the filter.
  Do the same Advanced Filter again, but this time extract the results to a different range. Extract only the Last and First columns to a different range (Excel should end up with Clem Brown being displayed in the extract range).

---

**Figure 8-12:** The Advanced Filter dialog box.

When the list is filtered in place, the records that don’t match the criteria are hidden.

**Figure 8-13:** Data filtered in place using the Advanced Filter.
Copy to another location in the Action area of the Advanced Filter dialog box. In the “Copy to” box, click the Collapse Dialog button, select the range for the extracted results—including labels and blank rows to hold the results—and press <Enter>.

5. Click the List range collapse dialog button and select the data range to filter. Press the <Enter> key.

6. Click the Criteria range collapse dialog button and select the criteria range, including the column labels. Press the <Enter> key.

7. Click OK.

The data is filtered based on the criteria in the criteria range, and the results are displayed in the data range.

Tip: To remove the advanced filtering, click the Clear button in the Sort & Filter group on the Data tab.

Table 8-1: Comparison Operators and Wildcards, provides a description of operators and wildcards that can be used for entering filter criteria.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
<td>Example: Brown-East</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
<td>Example: John-Jane</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>Example: 1200</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>Example: 100</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>Example: 1200 &gt;= 1300</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>Example: 1200 &lt;= 1300</td>
</tr>
<tr>
<td>*</td>
<td>Wildcard—any number of characters in the same position as the asterisk</td>
<td>Example: &quot;*east&quot; finds &quot;Northeast&quot; and &quot;Southeast&quot;</td>
</tr>
<tr>
<td>?</td>
<td>Any single character in the same position as the question mark</td>
<td>Example: sm?th finds &quot;smith&quot; and &quot;smyth&quot;</td>
</tr>
</tbody>
</table>

Figure 8-14: Filter results copied to another location (extracted) using the Advanced Filter.
Working with Data Ranges Review

Quiz Questions

1. Before sorting data, make sure it's organized into...
   A. a chart.
   B. alphabetical order.
   C. a pivot table.
   D. columns and rows.

2. Sort Excel data by any of the following, except by...
   A. font color.
   B. cell icon.
   C. number formatting.
   D. cell color.

3. To sort by multiple columns, use the __________.
   A. Sort dialog box
   B. Column Specifier button
   C. Sort Columns window
   D. drag and drop feature

4. Create a custom list for sorting or use a predefined custom list. (True or False?)

5. Which one of the following is a way to turn on the filtering buttons?
   A. Click the Insert tab and click the Filter button in the Filter group.
   B. Click the Filter tab and click the Filter button in the Filter group.
   C. Click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and click Filter.
   D. Type the formula =Filter(Data) in the first cell of the column to filter.

6. Use wildcards when entering values in the Custom AutoFilter dialog box. (True or False?)

7. An Advanced Filter can do all of the following, except...
   A. Extract and copy filtered results to another range on the worksheet.
   B. Use wildcards in the filter criteria.
   C. Filter using criteria located outside of the data range.
   D. Advanced Filter can do all of these things.
Quiz Answers

1. D. Before sorting data, make sure it's organized into columns and rows.

2. C. Sort data by cell icon, cell or font color, but not by number formatting.

3. A. Use the Sort dialog box to sort data by multiple columns.

4. True. Either create a custom list or use a predefined custom list.

5. C. To display the filtering buttons, click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and click Filter.

6. True. Use wildcards when entering values in the Custom AutoFilter dialog box.

7. D. An Advanced Filter can do all these things.
Working with Tables

Creating a Table .................................................. 195
  Create a table from a cell range .......... 195
  Create a blank table ......................... 196

Adding and Removing Data......................... 197
  Add table rows and columns .............. 197
  Remove table rows and columns .......... 197
  Resize a table ........................................ 198

Working with the Total Row ......................... 199
  Add a Total row ............................... 199
  Calculate Total row values ............... 199
  Structured references ..................... 199

Sorting a Table .................................................... 201
  Custom Sorting ........................................ 201

Filtering a Table .................................................. 203
  Clear a filter ...................................... 203
  Custom AutoFilter .................................. 203
  Removing Duplicate Rows of Data ........ 204

Formatting the Table .......................................... 205
  Apply a style while creating a table .... 205
  Apply a different style to an existing table 205
  Remove a table style ......................... 205
  Format the table style ..................... 205

Using Data Validation ......................................... 207
  Set validation criteria ...................... 207
  Create an input message .................. 208

Summarizing a Table with a PivotTable ....... 209

Converting to a Range ........................................... 210

Tables—called lists in previous versions of Excel—make it easier to work with ranges of Excel data. By turning an Excel range into a table, it’s possible to work with the table data independently from the rest of the worksheet. Quickly sort and filter the table columns, add total rows, and apply table formatting to an Excel table.

Some examples of things to track in a table include telephone numbers, clients, and employee rosters. Once a table is created in Excel, it’s easy to find, organize, and analyze its information with Excel’s rich set of table-management features.

Using Exercise Files

This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may be “built upon,” meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Creating a Table

By turning an Excel range into a table, the table data can be worked with independently from the rest of the worksheet, and filter button arrows appear automatically on the column headers, allowing columns to be filtered and sorted even faster. Add total rows and quickly apply table formatting.

Tables, like normal data ranges of data, consist of two parts:

- **Records (rows):** Each record contains information about a unique thing or person, just like a listing in a phone book.

- **Fields (columns):** Records are broken up into fields which store specific pieces of information, such as first and last name.

**Tips**

 ✓ Before turning a range of data into a table, remove blank rows and columns, and make sure that a single column doesn’t have different types of data within it.

If desired, make sure there are column headers entered. For example, to make a table that lists a company’s sales reps, enter headers such as Last Name, First Name, Territory, etc. Unique records, such as the names and territories of each of the sales reps, should be entered as rows.

Create a table from a cell range

If an organized range of data already exists, it can be turned into a table.

1. Select a cell range to make into a table.

   Normally the cell range needs to include a header row, with labels identifying each of the columns.

**Other Ways to Create a Table:**

It’s possible to simultaneously create and format a table. Select the cells to include in the table and click **Format as Table** in the Styles group on the Home tab; select a table style and click **OK**.

2. Click the **Insert** tab on the Ribbon and click the **Table** button in the Tables group.

The Create a Table dialog box appears. Edit the range that will become a table, and specify whether or not the table has a header row (if it doesn’t, Excel adds a header row above the table data).
3. Set the options in the Create a Table dialog box and click OK.

The table is created. Filters are added to each column, and the table is automatically formatted. Under Table Tools on the Ribbon, the Design contextual tab appears.

Create a blank table

If data to include in a table hasn’t already been entered, create the table first.

1. Select a range of cells that is approximately the size the table needs to be.

   It’s also possible to change the size later.

2. Click the Insert tab on the Ribbon and click the Table button in the Tables group.

   The Create Table dialog box appears.

3. Click OK.

   The table appears, including placeholder column headers that can be edited, and a resize handle that appears in the lower-right corner of the table.

   Table 9-1: Tips for Organizing Tables, provides ideas for setting up the table data.

<table>
<thead>
<tr>
<th>Table 9-1: Tips for Organizing Tables</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Avoid putting blank rows and columns in the table.</strong></td>
</tr>
<tr>
<td><strong>Create column labels in the first row of the table.</strong></td>
</tr>
<tr>
<td><strong>Design the table so that all rows have similar items in the same column.</strong></td>
</tr>
<tr>
<td><strong>Try to break up information as much as possible.</strong></td>
</tr>
<tr>
<td><strong>Each column should contain the same type of information.</strong></td>
</tr>
<tr>
<td><strong>Don’t use duplicate field names.</strong></td>
</tr>
</tbody>
</table>
Adding and Removing Data

It’s easy to add or remove table data.

Add table rows and columns

1. Select a cell in the table row or the table column next to which to add the row or column.

Add a new table row above the row selected, or add a new column to the left of the column selected (unless the last column is selected, in which case a column can also be added to the right).

Tip: Select only the columns or rows within the table for more inserting options. For example, clicking a column header does not allow choosing to insert new columns to the right or left.

2. Click the Home tab on the Ribbon and click the Insert button list arrow.

The options available here change, depending on the cell(s) that are selected in the table or sheet.

3. Select the insertion option to use.

A row or column is inserted into the table.

Other Ways to Insert a Table Row Or Column: Right-click the row or column where to add a row or column, point to Insert in the contextual menu, and select Insert Table Rows Above or Insert Table Columns to the Left or Right. Or, to add a new row to the bottom of the table, place the cell pointer in the last cell of the table and press <Tab>.

Tips
✓ When entering a formula in a blank column of a table, the formula is automatically extended to all the rest of the column—without using the AutoFill feature. If rows are added to the column, the formula appears in those rows as well.

Remove table rows and columns

Remove unwanted table rows and columns by deleting them.

1. Select the table row(s) or columns(s) to delete.

Remember that doing this removes the data from the worksheet completely.

Exercise

• Exercise File: Table9-2.xlsx

• Exercise: Add this data to the bottom of the table:

<table>
<thead>
<tr>
<th>First Name</th>
<th>Last Name</th>
<th>Address</th>
<th>City</th>
<th>State</th>
<th>Zip</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elsa</td>
<td>Martinez</td>
<td>413 Oak St</td>
<td>Faribault</td>
<td>MN</td>
<td>55021</td>
</tr>
<tr>
<td>Bob</td>
<td>Arthur</td>
<td>326 Elm Ave</td>
<td>Toma</td>
<td>WI</td>
<td>54660</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Annual Trips</th>
<th>Income</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>$40,000</td>
</tr>
<tr>
<td>5</td>
<td>$88,000</td>
</tr>
</tbody>
</table>

Figure 9-2: Adding data to a table. If data appears previously in a column, Excel will offer an AutoComplete option as data is entered.
2. Click the **Home** tab on the Ribbon and click the **Delete** button list arrow in the Cells group.

3. Select **Delete Table Columns** or **Delete Table Rows**.
   - The selected row(s) or column(s) are deleted.

**Other Ways to Delete a Table Row or Column:**
- Right-click the row or column to delete, point to **Delete** in the contextual menu, and select **Table Columns** or **Table Rows**.

## Resize a Table

Expand the size of a table to include more data, or reduce the size to remove data.

1. Select a cell in the table.

2. Under Table Tools on the Ribbon, click the **Design** tab.

3. Click the **Resize Table** button in the Properties group.
   - The Resize Table dialog box appears.

4. Select the range to include in the table.

5. Click **OK**.
   - The table is resized. If cells are added to the table, they are empty so that data can be entered in the cells.

**Other Ways to Resize a Table:**
- Click and drag the sizing handle in the lower-right corner of the table to include more or fewer cells.
- Or, enter data in a cell below or to the right of the table; the table automatically expands.
Working with the Total Row

With the Total Row feature, Excel will automatically add a total row to the bottom of a table and sum the last column of the table. The total row can also perform other types of calculations.

Add a Total row

1. Select a cell in the table.
   Table Tools tab appears on the Ribbon.

2. Click the Design contextual tab under Table Tools on the Ribbon.
   Now access is available to commands that can help change the design of the table.

3. Click the Total Row option in the Table Style Options group so that it is selected.
   A Total row appears at the bottom of the table and the last column is summed.

   Tip: If the last column doesn’t contain numbers, Excel displays a count of the number of items in the column.

Calculate Total row values

Once a total row has been added, decide what type of calculation to perform for the total of each table column.

1. In the Total row, select the cell at the bottom of the column that contains values to calculate.

2. Click the cell’s list arrow and select the calculation to perform.

   Table 9-2: Total Row Calculation Options, describes the different types of calculations that Excel can perform in the Total row.

Structured references

Structured references work easily with cell references and formulas in a table. For example, instead of using a cell range reference such as C2:C6 in a formula, refer to the cell range as SaleAmt (the table column name) instead.

When creating a formula using structured references, use several different elements in place of the regular arguments. These include the table name, column header names, or special items that refer to areas of the table, such as a total row.

   Tip: When entering references in a formula in a table, if the cells are clicked to select them (instead...
of typing in their cell addresses) Excel will enter structured references.

### Table 9-2: Total Row Calculation Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No function is inserted.</td>
</tr>
<tr>
<td>Average</td>
<td>Calculates the average, or arithmetic mean, of the numbers in the column.</td>
</tr>
<tr>
<td>Count</td>
<td>Counts the number of all nonblank cells, regardless of what they contain.</td>
</tr>
<tr>
<td>Count Numbers</td>
<td>Counts the number of cells that contain numbers, including dates and formulas. Ignores all blank cells and cells that contain text or errors.</td>
</tr>
<tr>
<td>Max</td>
<td>Returns the largest value in a column.</td>
</tr>
<tr>
<td>Min</td>
<td>Returns the smallest value in a column.</td>
</tr>
<tr>
<td>Sum</td>
<td>Adds all of the numbers in a column.</td>
</tr>
<tr>
<td>StdDev</td>
<td>Estimates standard deviation based on a sample. The standard deviation is a measure of how widely values are dispersed from the average value.</td>
</tr>
<tr>
<td>Var</td>
<td>Estimates variance based on a sample.</td>
</tr>
<tr>
<td>More Functions…</td>
<td>Opens the Insert Function dialog box and choose a different function to perform on the column’s values.</td>
</tr>
</tbody>
</table>
Sorted a Table

Excel is very good at sorting information. Excel can sort records alphabetically, numerically, or chronologically (by date). Additionally, Excel can sort information in ascending (A to Z) or descending (Z to A) order. Sort an entire list or any portion of a list by selecting it.

1. Click the **filter button** for the column to sort.
   
   A list appears, displaying several options for sorting the table data. The options at the top are for sorting.
   
   **Other Ways to Sort:**
   
   Click the **Home** tab and click the **Sort & Filter** button in the Editing group. Select a sorting option from the list.

2. Select the sort option to use.

3. Click **OK**.

**Tips**

- If adding or editing data in a table that is filtered or sorted, click the **Reapply** button in the Sort & Filter group on the Data tab to include the new or edited data.

**Custom Sorting**

To sort by more than one field, use a Custom Sort.

The Custom Sort can sort records by more than one field, such as to sort alphabetically by first and last name, or by state and city.

1. Click a field’s **filter button** and select **Sort by Color** → **Custom Sort…** from the list.
   
   The Custom Sort dialog box appears.

   **Other Ways to Use Custom Sort:**
   
   Click the **Home** tab and click the **Sort & Filter** button in the Editing group. Select **Custom Sort** from the list.

2. Click the **Sort by** list arrow and select the field by which to sort.
   
   This is the first field to sort by.

3. Click the **Sort on** list arrow and choose what to sort by in the field.
   
   The options for the Order change depending on the Sort On variable.

4. Click the **Order** list arrow and select the order by which to sort the data.

**Exercise**

- **Exercise File:** Table9-4.xlsx
- **Exercise:** Sort by Last name in Ascending order (A-Z).

Apply a custom sort to sort first by Last name, and then First name.

**Figure 9-5:** The list before and after being sorted in ascending order by the Last field.

**Figure 9-6:** An example of sorting a table by multiple fields.
5. Click **OK**.

6. (Optional) Sort by multiple fields, by clicking the **Add Level** button and set the sort specifications for the next field.

7. Click **OK**.

   The data in the table is sorted by the sort specifications.

![Figure 9-7: The table sorted by last name, then first name.](image-url)
Filtering a Table

When creating a table, a filter button that looks like a list arrow is added to the header of each column in the table. Use this arrow to filter the table columns; they remain available when scrolling down the list.

1. Click the filter button for the column to filter.
   
   A list appears, displaying several options for sorting or filtering the table data. The check boxes are all the data entries for the selected field.

2. Click the check box/boxes of the filter criteria to use.

   **Other Ways to Select Filter Criteria:**
   
   - Click the Search box in the filter list and type the criteria by which to filter. The list displays criteria that match the search.

3. Click OK.

Clear a filter

When finished with a filter, clear it so all the table data appears again.

1. Click the filter button for the filter to clear.

2. Select the Clear Filter From option.
   
   The filter is cleared and the table data is displayed without the filter.

Custom AutoFilter

To filter using more complicated criteria, use a Custom AutoFilter. Custom AutoFilters are more difficult to set up and create than ordinary AutoFilters, but they’re much more flexible and powerful.

1. Click a field name list arrow and select Custom from the list.

2. Select Text Filters or Number Filters from the list.
   
   A list of ways to filter the text appears.

3. Select a filter option from the list.
   
   If Top Ten was selected, the Top 10 AutoFilter dialog box appears.

4. Complete the dialog box as necessary and click OK.
   
   Excel now filters the table by the custom filter.
Removing Duplicate Rows of Data

If there are duplicate rows of identical data in the table, Excel can find and remove the duplicate rows.

📌 Trap: Removing duplicate values actually deletes the duplicate data, so copy the data to another worksheet or workbook first in case.

1. Select a cell in the table.
   ✔ Tip: Remove duplicates from cell ranges outside of a table as well, but in that case, select the entire cell range to examine.

2. Click the Data tab on the Ribbon and click the Remove Duplicates button in the Data Tools group.
   The Remove Duplicates dialog box appears.

🔍 Other Ways to Display the Remove Duplicates Dialog Box:
   Select a cell in the table. Under Table Tools on the Ribbon, click the Design tab. Click the Remove Duplicates button in the Tools group.

3. Select the columns to check for duplicates.
   All columns are selected by default, but it’s possible to select/deselect individual columns in the Columns list. Use the Select All and Unselect All buttons to select columns.

4. Click OK.
   Duplicate values are deleted and a message appears, telling how many duplicate values were found and removed.

5. Click OK.

Exercise

- Exercise File: Table9-6.xlsx
- Exercise: Remove duplicate rows of data (select all columns).

Figure 9-11: The Remove Duplicates dialog box.

Figure 9-12: The results of the remove duplicates command.
Formatting the Table

Change the appearance of a table by applying a preset table formatting style.

Apply a style while creating a table

Apply a style while also creating a table.

1. Select a cell range that to format as a table.

2. Click the Home tab on the Ribbon and click the Format as Table button in the Styles group.

The table format gallery appears. Select styles from the Light, Medium, or Dark categories. Scroll down the list to see the Dark category.

3. Select a table style.

The Format As Table dialog box appears.

4. Click OK.

A table is created and formatted with the selected style. The Table Tools tab appears on the Ribbon, and the Design contextual tab appears.

Apply a table style to an existing table

1. Select a cell in the table.

2. Under Table Tools on the Ribbon, click the Design tab.

3. Select the style to use in the Table Styles group.

   Tip: To display the entire Table Styles gallery, click the More button in the Table Styles group.

Remove a table style

A table style can easily be remove from a table.

1. Select the table that is formatted with the table style.

   The Design tab appears.

2. Under Table Tools on the Ribbon, click the Design tab.

3. Click Quick Styles table Styles.

4. Click Clear in the Quick Styles Table Styles menu.

   The table format is removed.

Format the table style

After applying a table style, format individual table style elements.
1. Select a cell in the table.

2. Under Table Tools on the Ribbon, click the **Design** tab.

   The formatting options available in the Table Style Options group include:

   - **Header Row**: Toggles the table’s header row on and off.
   - **Total Row**: Adds a total row to the bottom of the table. This option doesn’t just change formatting, but also allows calculating values in the total row.
   - **First/Last Column**: Displays special formatting for the first or last columns in the table.
   - **Banded Rows/Columns**: Displays odd and even rows and columns differently for easier reading.

3. Select the option(s) to use in the Table Style Options group.
Using Data Validation

Help users enter accurate and appropriate information into worksheets with Excel’s Data Validation feature. Data validation restricts the type of information that can be entered into a cell and can provide the user with instructions on entering information in a cell.

Set validation criteria

To use data validation, first specify the validation criteria to use.

1. Select the cells to validate.
   Usually it’s best to select a column of data, although another option is to select a single cell as well.

2. Click the Data tab on the Ribbon and click the Data Validation button in the Data Tools group.
   The Data Validation dialog box appears, displaying the Settings tab.

3. Click the Allow list arrow and select the criteria option to use.
   Table 9-3: Validation Criteria Options, describes the choices.
   Depending on the criteria selection, select a Data option, and/or select additional options in the dialog box. Values may also need to be entered.

4. Complete the remaining fields on the Settings tab and click OK.
   The data validation is set for the selected cell(s). Now when a user tries to enter data that is not valid, Excel will prevent the entry and display a message about the cell being restricted.

Tips

✓ By default, when entering invalid data in a validated cell, a warning message appears and entry of the invalid data is not allowed. However, it’s possible to modify the message that appears, and even to allow invalid data to be entered into a validated cell. To do this, click the Error Alert tab in the Data Validation dialog box and select the desired options.

✓ To find validated data in a worksheet, click the Find & Select button in the Editing group on the Home tab and select Data Validation. The validated cells are highlighted.

<table>
<thead>
<tr>
<th>Table 9-3: Validation Criteria Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any value</td>
</tr>
<tr>
<td>Whole number</td>
</tr>
<tr>
<td>Decimal</td>
</tr>
<tr>
<td>List</td>
</tr>
<tr>
<td>Date</td>
</tr>
<tr>
<td>Time</td>
</tr>
<tr>
<td>Text length</td>
</tr>
<tr>
<td>Custom</td>
</tr>
</tbody>
</table>
To remove validation criteria, select the cells that contain the validation to remove, and click the Data Validation button in the Data Tools group on the Data tab. Click Clear All, then click OK.

Create an input message

Set up Excel to display a message whenever a cell or range of cells is selected. These messages are useful for providing data entry instructions.

1. Select the cells where an input message is to appear.
   The input message will appear when the cell or cells are selected.

2. Click the Data tab on the Ribbon and click the Data Validation button in the Data Tools group.
   The Data Validation dialog box appears.

3. Click the Input Message tab.
   🔄 Tip: Make sure the “Show input message when cell is selected” box is selected—it should be selected by default.

4. Click in the Title box and type a title for the message.
   The title will be displayed along with the message when the cell(s) are selected.

5. Click in the Input message box and type a data input message.
   For example, enter instructions such as “Enter State name as a two-letter abbreviation”.

6. Click OK.
   Now when the cells are selected, the title and message display.
Summarizing a Table with a PivotTable

Analyze table data by using it in a PivotTable.

1. Select a cell in the table.
   The Table Tools appear on the Ribbon.

2. Under Table Tools on the Ribbon, click the Design contextual tab and click the Summarize with PivotTable button in the Tools group.
   The Create PivotTable dialog box appears.

3. Click OK.
   A new sheet is added to the workbook to accommodate the PivotTable report. Create a PivotTable to analyze the data in the table, according to specifications.

Tips
✓ Other lessons describe how to work with PivotTables in more detail. This is the simplest way to view a summary of the table in a PivotTable.

Exercise
- Exercise File: Table9-9.xlsx
- Exercise: Summarize the table with a PivotTable on a new worksheet. Experiment with the PivotTable tools, then delete the worksheet containing the PivotTable.

Figure 9-18: Summarizing table data with a PivotTable.

Figure 9-19: The Create PivotTable dialog box.

The pivot table report is displayed according to the fields chosen.
Converting to a Range

If a table is no longer wanted, turn it back into a normal range.

1. Select a cell in the table.

2. Under Table Tools on the Ribbon, click the Design contextual tab and click the Convert to Range button in the Tools group.

3. Click Yes.

The table converts back to a normal range of cells, but the table formatting is still applied.

**Other Ways to Convert a Table to a Range:**
Select the table, right-click the table and select Table → Convert to Range from the contextual menu.

---

**Exercise**
- **Exercise File:** Table9-10.xlsx
- **Exercise:** Convert the table back to a normal range of cells. Undo that action.

**Figure 9-20:** The Convert to Range button.
Working with Tables Review

Quiz Questions

1. It’s possible to create a blank table or a table that uses an existing data range. (True or False?)

2. Which of the following is NOT a way to resize a table?
   A. Click the Resize Table button in the Properties group.
   B. Use the Resize Table Wizard.
   C. Enter data in a cell below or to the right of the table.
   D. Click and drag the table’s sizing handle.

3. By default, when a total row is added to a table, the last column is summed. (True or False?)

4. Custom sorting allows sorting of data by multiple columns. (True or False?)

5. Which of these is NOT a custom autofilter in Excel?
   A. Top 10
   B. Equals
   C. Contains
   D. Color

6. Removing duplicates from a table moves the duplicate data to another worksheet. (True or False?)

7. Once a table style is applied to a table, it can’t be changed it to a different one. (True or False?)

8. Which of the following is NOT a formatting option in the Table Style Options group?
   A. Header Row
   B. Checkered Rows
   C. Banded Columns
   D. First Column

9. Which of the following statements is NOT true?
   A. It’s possible to provide users with information and feedback using Data Validation.
   B. To use Data Validation, click the Data Validation button in the Data Tools group on the Data tab.
   C. The worksheet must be protected to use the data validation feature.
   D. Data validation allows restriction of which type of information is entered in a cell.

10. Summarize and analyze table data using a ________.
    A. PivotTable
    B. PivotSheet
    C. PivotGrid
    D. DataSheet

11. When converting a table to a range, the table formatting remains applied to the cells. (True or False?)
Quiz Answers

1. True. It's possible to create a blank table or a table that uses an existing data range.

2. B. There isn't a Resize Table Wizard in Excel.

3. True. When adding a total row to a table, the last column is summed by default.

4. True. Custom Sorting allows sorting by multiple levels, so it can sort by multiple columns.

5. D. Color is not a filter option in Excel. It is, however, a way to sort.

6. False. Removing duplicates from a table deletes the data completely.

7. False. Table styles can always be changed.

8. B. Checkered Rows is not an option in the Table Style Options group.

9. C. There's no need to protect the worksheet to use the data validation feature.

10. A. Summarize and analyze table data using a PivotTable.

11. True. When converting a table to a range, the table formatting remains applied to the cells.
Working with PivotTables

Creating a PivotTable ........................................ 214
Specifying PivotTable Data................................215
   Add fields ........................................ 215
   Rearrange fields ................................ 215
Changing a PivotTable's Calculation..................216
Filtering and Sorting a PivotTable .................... 217
   Filter a PivotTable ................................ 217
   Sort a PivotTable ................................ 217
Working with PivotTable Layout ...................... 218
   Adjust PivotTable Field List layout ........... 218
   Show/Hide PivotTable elements ............ 218
   Layout group on the Design tab .......... 219
Grouping PivotTable Items .......................... 220
   Group dates or times .......................... 220
   Group numeric items ......................... 220
   Group other selected items ............... 220
   Ungroup items ................................ 221
Updating a PivotTable ................................ 222
   Refresh PivotTable data ...................... 222
   Change PivotTable data source .......... 222
Formatting a PivotTable ................................ 223
   Apply a built-in style .......................... 223
   Work with style options .................. 223
Creating a PivotChart ................................ 224
Creating a standalone PivotChart ............... 225
Drilling up or down .................................... 226
   Using Quick Explore to drill down or up ... 226
Using Slicers ........................................ 227
   Create a PivotTable Slicer .................. 227
   Filter data using a slicer .................. 228
   Format a slicer .............................. 228
   Delete a slicer .............................. 228
Sharing Slicers Between PivotTables ............. 229
   Apply a slicer to another PivotTable .... 229

There are many ways to analyze worksheet data, including sorting and filtering records. This chapter explains how to use a PivotTable to analyze data ranges.

A PivotTable is usually the best way to summarize and analyze data ranges or tables. PivotTables are good for grouping or expanding levels of data, switching columns and rows (“pivoting” data), and filtering and sorting. They lend themselves particularly well to summarizing long lists of data that need to be summed.

This chapter explains how to create PivotTables, modify their structure, and create PivotCharts that graphically illustrate PivotTables.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Creating a PivotTable

To create a PivotTable, decide which fields to include, how the PivotTable should be organized, and what types of calculations the PivotTable should perform.

Don’t worry if PivotTables are confusing at first, they will make a lot more sense once one has been created.

1. Select a cell in a data range.

   **Other Ways to Create a PivotTable:**
   Select a cell in a table, click the **Design** tab on the Ribbon, and click the **Summarize with Pivot** button in the Tools group.

2. Click the **Insert** tab on the Ribbon and click the **PivotTable** button in the Tables group.

   The Create PivotTable dialog box appears and a moving dashed line appears around the data range that Excel will use for the PivotTable.

   **Tip:** The data range doesn’t have to be in the current workbook. Select the **Use an external data source** option to select data outside the workbook.

3. If necessary, select the data range to analyze, including column labels.

   Next decide to display the PivotTable in a new worksheet or one that already exists in the workbook.

4. Select where to place the PivotTable report.

   Choose a new or existing worksheet.

   **Tip:** If selecting an Existing Worksheet, click the **Collapse Dialog** button and select the worksheet and upper-left cell of the range where to put the PivotTable.

5. Click **OK**.

   The Excel window changes to display the structure for a new PivotTable, along with the PivotTable Field List task pane. No data has been pulled into the PivotTable yet—use the task pane to tell Excel how to lay out the PivotTable.

**Tips**

- Change how the PivotTable Field List task pane looks. Click the button arrow near the top right corner of the task pane and select a layout option.

---

**Exercise**

- **Exercise File:** TripSales10-1.xlsx
- **Exercise:** Create a PivotTable on a new worksheet using the data from the Promotion Sales worksheet.
Specifying PivotTable Data

Once the PivotTable is created, specify the data to analyze. Simply select the fields to display in the PivotTable Field List, then adjust the layout by dragging them between the desired report areas at the bottom of the task pane. It’s difficult to understand how to do this unless it’s tried—so time to get started.

Add fields

1. Click the check boxes next to the fields to use as data in the PivotTable.

   By default, nonnumeric fields are added to the Row Labels area, numeric fields are added to the Values area, and OLAP date and time hierarchies are added to the Column Labels area. However, the fields can be rearranged to other areas.

   Other Ways to Add Fields:
   
   Right-click a field name and select the layout area to which to add the field. Or, click and drag a field name into a layout section.

Rearrange fields

1. Click and drag fields between the areas in the task pane to reposition the PivotTable layout.

   The data and layout of the PivotTable change accordingly.

   Tips
   
   ✓ Drag a field between the Row Labels and Column Labels boxes to change the orientation of the PivotTable.

   ✓ Change PivotTable labels by typing a new label.

Exercise

- Exercise File: TripSales10-2.xlsx
- Exercise: Add the Office, Destination, and Tickets fields to the PivotTable.
  Move the Office field to the Column Labels area.
  Switch the positions of the Office and Destination fields.

Figure 10-3: This diagram illustrates how areas in the PivotTable Field List correspond to areas in the PivotTable report.

Figure 10-4: A PivotTable with data.

1 The report filter area.
   Move a field to this area, then select the criteria by which to filter the PivotTable.

2 The Column Label area.

3 The Row Label area.

4 The Results area.
   The results include data that from the fields in the column and row areas. Results are also filtered from the report filter area.
Changing a PivotTable’s Calculation

Besides adjusting the layout of a PivotTable data, it’s also possible to change how a PivotTable summarizes values. For example, a PivotTable may need to display averages instead of totals.

1. Make sure the cell pointer is located in the PivotTable.
   To change the calculation in a PivotTable, change the value field settings.

2. Under PivotTable Tools on the Ribbon, click the Analyze tab and click the Field Settings button in the Active Field group.
   The Value Field Settings dialog box appears, displaying the “Summarize by” tab. Select calculation options including Sum, Count, Average, or Max, among others.

3. Select the type of calculation to use to summarize the value data from the list.

4. Click OK.
   The summarized value data in the PivotTable changes to using the new calculation.

---

Exercise

- **Exercise File:** TripSales10-3.xlsx
- **Exercise:** Change the calculation of the Tickets field from Sum to Max.
  Change it back to Sum.
Filtering and Sorting a PivotTable

Much like with basic data ranges and tables in Excel, it’s possible to filter and sort data in a PivotTable.

Filter a PivotTable

1. Select a cell in the PivotTable.
   The Analyze and Design tabs appear under PivotTable Tools on the Ribbon.
2. Click the filter button for a row or column label.
   A list sorting and filtering options appears. The bottom area of the list displays criteria by which it can filter.
   - Other Ways to Select Filter Criteria:
     Click the Search box in the filter list and type the criteria by which to filter. The list displays criteria that match the search.
3. At the bottom of the list, click the check boxes next to the fields to filter out to uncheck them.
   Fields with checkmarks next to them will remain, while those without checkmarks will be filtered out.
4. Click OK.
   The PivotTable is updated.
   - Other Ways to Filter a PivotTable:
     Drag a field into the Report Filter area of the PivotTable Field List task pane. Click the field’s filter button above the PivotTable and select what to filter by. Or, click a filter button, point to Label Filters or Values Filters, and select a filtering option.

Sort a PivotTable

1. Select a cell in the PivotTable.
   The Analyze and Design tabs appear under PivotTable Tools on the Ribbon.
2. Click a filter button.
   Here are sort options at the top of the list, along with the filter options toward the bottom.
3. Select a sort option.

Exercise

- Exercise File: TripSales10-4.xlsx
- Exercise: Use the Row Labels filter button to display only records from Blaine. Clear the filter.
  Try another way to filter: Add the Commission field to the Report Filter area of the PivotTable Field List and filter the PivotTable so only commissioned sales appear. Clear the filter.
  Sort the PivotTable by Office (Row Labels) from Z to A, then sort again from A to Z.

Figure 10-6: The PivotTable filtered to display only “Blaine” records.

Figure 10-7: Adding a field to the Report Filter area.
Working with PivotTable Layout

There are several options for altering the layout of the PivotTable and the PivotTable Field List task pane.

Adjust PivotTable Field List layout

Change the layout of the PivotTable Field List makes it easier to work with. For example, display only the fields section if there is a long list of fields to choose from. Or, if setting up the PivotTable is complete, display only the area section.

1. Select a cell in the PivotTable.
   The PivotTable Field List task pane appears.
2. Click the Tools button at the top of the PivotTable Field List task pane and select a layout option.
   Choose to display only the fields section, only the report areas section, or both sections in different arrangements. Table 10-1: PivotTable Field List Layout Options, has more information about these arrangements.

Show/Hide PivotTable elements

Change which elements are displayed in the PivotTable.

1. Select a cell in the PivotTable.
2. Under PivotTable Tools on the Ribbon, click the Analyze tab.
   The Show group contains three buttons. By default, they are all shown in the PivotTable.
   - **Field List**: Show or hide the PivotTable Field List task pane.
   - **+/- Buttons**: Show or hide the +/- buttons that allow multi-level PivotTable items to expand or collapse.
   - **Field Headers**: Show or hide column and row field headers.
3. Click the button to use in the Show group.
   ✓ **Tip**: If the button is an orange color, the element is displayed in the PivotTable. If the button is not orange, the element is hidden.

Exercise

- **Exercise File**: TripSales10-5.xlsx
- **Exercise**: Change the layout of the PivotTable Field List so the field and area sections are side-by-side. Then change them back to Stacked.

In the Show/Hide group of the Analyze tab on the Ribbon, hide the Field List and Field Headers. Show both again.

In the Layout group of the Design tab on the Ribbon, turn off the row and column grand totals. Enable them again.

Change the report layout to Tabular Form.

Table 10-1: PivotTable Field List Layout Options

<table>
<thead>
<tr>
<th>Layout</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is the default layout. The fields are stacked above the areas.</td>
<td></td>
</tr>
<tr>
<td>The fields appear side by side with the areas. This is useful if there is a long list of fields to choose from.</td>
<td></td>
</tr>
<tr>
<td>Only the fields list is displayed. This is ideal if work only needs to be done with adding fields to the PivotTable report.</td>
<td></td>
</tr>
<tr>
<td>Only the areas are displayed (2 by 2). This is ideal if the fields have been added and if working with the report’s layout.</td>
<td></td>
</tr>
<tr>
<td>Only the areas are displayed (1 by 4). This is ideal if the fields have been added and if working with the report’s layout.</td>
<td></td>
</tr>
</tbody>
</table>
Layout group on the Design tab

The Layout group on the Design tab allows change to be made to which elements appear on the PivotTable.

1. Select a cell in the PivotTable.

2. Under PivotTable Tools on the Ribbon, click the Design tab.

   Here is the Layout group. It contains four buttons:
   - **Subtotals**: Click to show or hide subtotals, and to specify where to show them.
   - **Grand Totals**: Click to show or hide grand totals, and to specify whether they appear for rows, columns, or both.
   - **Report Layout**: Show the PivotTable in compact, outline, or tabular form.
   - **Blank Rows**: Insert or remove a blank line between each grouped item in the PivotTable.

3. Click the button to use in the Layout group.

   A list of options appears, depending on the button that was selected.

4. Select an option from the list.

   The PivotTable layout is changed accordingly.
Grouping PivotTable Items

Group PivotTable data in order to set it apart additional subsets of data. Group most items, but dates are a common item to group. For example, group the information in the PivotTable by days, months, quarters, or years.

Group dates or times

1. Select the date or time field in the PivotTable.
   To select the field, click the name of the field in the PivotTable, such as the row or column header.

2. Under PivotTable Tools on the Ribbon, click the Analyze tab and click the Group Field button in the Group group.
   The Grouping dialog box appears.

3. Specify the starting and ending dates to group and the interval to group by.
   By default, the starting and ending dates are the first and last dates in the PivotTable.

4. Click OK.
   The grouping is applied to the PivotTable report.

   Tip: To group dates by weeks, select Days in the By area of the Grouping dialog box and enter 7 in the Number of days box.

Group numeric items

1. Select the numeric field in the PivotTable that contains the data to group by.

2. Under PivotTable Tools on the Ribbon, click the Analyze tab and click the Group Field button in the Group group.
   The Grouping dialog box appears.

3. Specify the starting and ending values to group and the interval to group by, then click OK.

Group other selected items

Another option is to group items that are not dates or numeric data, such as labels.

Exercise

- Exercise File: TripSales10-6.xlsx
- Exercise: First, set up the PivotTable for grouping:
  Remove the Office field from the Row Labels area of the PivotTable Field List. Move the Destination field to the Row Labels area. Add the Date field to the Column Labels area.
  Select cell B4 and group the dates by month. Then ungroup the dates.

Figure 10-10: Grouping the PivotTable dates by month.
Working with PivotTables

1. Select the items in the PivotTable to group.

2. Under PivotTable Tools on the Ribbon, click the Analyze tab and click the Group Selection button in the Group group.

   The items are grouped and collapse buttons appear to collapse or expand the group of data, if desired.

   Tip: Use this method to group specific items in a field.

Ungroup items

1. Select the items in the PivotTable to ungroup.

2. Under PivotTable Tools on the Ribbon, click the Analyze tab and click the Ungroup button in the Group group.

   The items are ungrouped.
Updating a PivotTable

If making changes to the source data a PivotTable is based on, the PivotTable isn't automatically updated. Instead, manually refresh the PivotTable anytime its underlying source data is changed. This lesson explains how to do that, as well as how to change the source of the data the PivotTable is based on.

Refresh PivotTable data

If changes are made to the data that the PivotTable pulls from, refresh the PivotTable to update it.

1. Select a cell in the PivotTable.
   The PivotTable Tools are displayed on the Ribbon.

2. Under PivotTable Tools on the Ribbon, click the Analyze tab and click the Refresh button in the Data group.
   The PivotTable updates to include any changes to the source data.

Change PivotTable data source

It’s easy to change which data is used by the PivotTable.

1. Select a cell in the PivotTable.
   The PivotTable Tools are displayed on the Ribbon

2. Under PivotTable Tools on the Ribbon, click the Analyze tab and click the Change Data Source button in the Data group.
   The Change PivotTable Data Source dialog box appears, along with the current data source—which has a moving dotted line around it.

3. Select a new data range.

4. Click OK.
   The PivotTable updates with the data from the new source range.

Exercise

• Exercise File: TripSales10-7.xlsx
• Exercise: View the Promotion Sales worksheet and change the value in cell G2 to 5. Return to the PivotTable on Sheet2 and refresh the PivotTable. The data updates in C23.
   Change the PivotTable data source so that it uses only the range A1:G4 on the Promotion Sales worksheet.
Formatting a PivotTable

Quickly format a PivotTable with Excel’s built-in styles and style options.

Apply a built-in style

1. Select a cell in the PivotTable.

   The PivotTable Tools tab is displayed on the Ribbon.

2. Click the Design tab and select a style in the PivotTable Styles group.

   The PivotTable is formatted with the style selected.

   **Tip:** Click the More button in the PivotTable Styles group to display an expanded PivotTable Styles gallery.

Work with style options

Besides applying a style to the table, select PivotTable style options that make it possible to adjust the format for a part of a PivotTable. For example, apply special formatting to row headers or make the columns banded.

1. Select a cell in the PivotTable.

   The PivotTable Tools are displayed on the Ribbon.

2. Click the Design tab and select an option in the PivotTable Style Options group.

   Here is a brief description of the style options to select from in the PivotTable Style Options group:

   - **Row/Column Headers:** Displays special formatting for the first row or column of the PivotTable.

   - **Banded Rows/Columns:** Applies different formatting to alternate rows or columns.

   **Tips**

   ✓ Besides using the formatting options on the Design tab, format a PivotTable using general formatting commands found on the Home tab.
Creating a PivotChart

A PivotChart is similar to an ordinary chart created in Excel, except that it plots a PivotTable’s information. Like PivotTable reports, PivotCharts are dynamic, which means a PivotChart’s structure can be changed.

1. Select a cell in the PivotTable.
   The PivotTable Tools are displayed on the Ribbon.

2. Under PivotTable Tools on the Ribbon, click the Analyze tab and click the PivotChart button in the Tools group.
   The Insert Chart dialog box appears, displaying different types of charts.

3. Select the type of chart to use and click OK.
   The chart appears in the worksheet with the PivotTable.
   Tip: Click and drag the PivotChart’s border to move the chart around in the worksheet.

4. Modify the chart using the PivotChart Filter Pane and the PivotTable Tools.

Tips
✓ If modifying the PivotTable, the PivotChart will change also.
✓ More detailed information about modifying and formatting charts can be found in the “Creating and Working with Charts” chapter.

Exercise

- Exercise File: TripSales10-9.xlsx
- Exercise: Insert a Clustered Column PivotChart.

Figure 10-15: The Insert Chart dialog box.

Figure 10-16: The clustered column PivotChart.

Use the PivotChart Filter pane to change the information displayed in the chart.
Creating a standalone PivotChart

When you create a PivotChart, you no longer need to associate it with a PivotTable, you can make one that stands by itself.

1. Select a data range.

2. Click the Insert tab and the Ribbon, and from the Charts group, click PivotChart.

3. The Create PivotChart window appears. Under the Choose the data that you want to analyze heading, check Select a table or range.
   
   Tip: If you have data outside of the worksheet that you want to use, check Use an External Data Source and choose your connection.

4. Click New Worksheet or Existing Worksheet depending on where you want your chart inserted.

5. Click OK.
   
   Your chart is inserted into your worksheet.

Exercise

- **Exercise File**: Table.xlsx
- **Exercise**: Insert a new PivotChart, displaying the First name on the x-axis and the Income on the y-axis.

Figure 10-17: PivotChart of the selected data
Drilling up or down

Some worksheets are extremely complex and require you to sift through layers of data in order to find the information you need. The Drill feature allows you to do just that using a hierarchy system of data layers.

If, for example, you want to see more detail on a specific sales figure, you can drill down, further and further until you reach a desired level. If you want a summarized view, you will drill up until you reach top level.

1. On a PivotTable, PivotChart or matrix, select the item or cell that you want to see details for.

2. The Analyze tab becomes active. Click the Analyze tab.

3. In the Active Field section, click Drill down.
   The level below the cell that you selected is displayed, along with the details related to it. If you want to explore even further down the hierarchy and see more detail, click Drill down again until you have reached the level you need to see.

4. To resurface and see all your data on the parent level in summary form, click Drill up.

Using Quick Explore to drill down or up

The Quick Explore feature in Excel 2013 let’s you drill into your PivotTable hierarchy so that you can analyze data details on different levels. Using Quick Explore, you can navigate to the data that you want to see and have it filtered as you drill down.

1. Select an item in your PivotTable that you want to explore.

2. Click the Quick Explore button on the bottom right of the selection.

3. Pick the item that you want to explore and click Drill Down.

4. Subcategory data for the item you chose is displayed, and you can keep using Quick Explore until you reach the data you want.

5. To drill up, pick an item in your PivotTable hierarchy and click the Quick Explore button on the bottom right of the selection.

6. In the Explore box, pick the item you want to explore and then click Drill Up.

Exercise

• Exercise File: None required
• Exercise: Understand how the drill up and down functions would be applicable to a PivotTable that uses an external Database or OLAP cube.

Figure 10-18: Using the Quick Explore feature to Drill Down.
Using Slicers

Slicers are a new feature in Excel 2013 that has been added in order to provide an easy way to filter PivotTable data. Slicers label the filters applied, with details, so it’s easy to understand the data that is displayed and filtered in the PivotTable report.

Create a PivotTable Slicer

Here’s how to create a slicer in an existing PivotTable.

1. Click the PivotTable report to select it.
   
The PivotTable Tools contextual tabs appear on the Ribbon.

2. Click the Analyze tab under PivotTable Tools on the Ribbon and click the Insert Slicer button in the Filter group.

   The Insert Slicers dialog box appears. All the fields in the PivotTable are listed here; decide which fields to filter by in the PivotTable.

3. Click the check box of the PivotTable fields by which to filter.
   
   Keep in mind that a separate slicer is designated for each field selected.

4. Click OK.

   The slicer(s) appear above the PivotTable. Move a slicer to another location on the worksheet, and resize it as needed.

Exercise

- **Exercise File:** Slicers1.xlsx; Sheet1

- **Exercise:** View the number of tickets the St. Cloud office sold to Boston, New York, and Washington D.C.

   (Insert slicers for the Destination and Office fields. Select the St. Cloud button in the Office slicer. Select the Boston, New York, and Washington, D.C. buttons in the Destination slicer.)

Figure 10-19: The Insert Slicers dialog box.

Figure 10-20: A PivotTable with two slicers applied.
Filter data using a slicer

After a slicer is created, it appears on the worksheet alongside the PivotTable, in a layered display if there is more than one slicer.

1. Click a button in a slicer. Press and hold the <Ctrl> key to select multiple buttons.
   
The button is selected, and the PivotTable data is filtered accordingly.
   
   ✓ Tip: Simply click the button again to stop filtering out the selected data.

Format a slicer

Change the appearance of a slicer to match the color scheme of the PivotTable.

1. Click the slicer to format.
   
The Slicer Tools tab appears on the Ribbon.

2. Click the Options tab under Slicer Tools on the Ribbon and select the style desired in the Slicer Styles group.
   
The style is applied to the slicer.
   
   ✓ Tip: Click the More button in the Slicer Styles group to view more styles.

Delete a slicer

To no longer filter PivotTable data, remove the slicer completely.

1. Click the slicer and press <Delete>.
   
The slicer no longer appears in the worksheet.
   
   ○ Other Ways to Delete a Slicer:
     
     Right-click the slicer, and then select Remove <Name of slicer> from the contextual menu.
Sharing Slicers Between PivotTables

If working with a workbook that has several different PivotTables, it’s a good idea to apply the same filter to other PivotTables. This lesson shows how to share slicers between PivotTables in a workbook.

Apply a slicer to another PivotTable

To use a slicer in another PivotTable, make the slicer available to that PivotTable.

1. Click the slicer to share in another PivotTable.
   The Slicer Tools tab appears on the Ribbon.

2. Click the Options tab under Slicer Tools on the Ribbon and click the Report Connections button in the Slicer group.
   The Report Connections dialog box appears. Other PivotTables to share the slicer with are listed.

3. Click the check boxes of the PivotTables to make the slicer available.

4. Click OK.
   The slicer is now applied to the selected PivotTable(s).

Exercise

- Exercise File: Slicers2.xlsx, Sheet2
- Exercise: Apply the Destination slicer from PivotTable 1 to PivotTable 2.

Figure 10-22: The PivotTable connections dialog box.
Working with PivotTables Review

Quiz Questions

1. Create a PivotTable in its own new worksheet or in one that already exists in the workbook. (True or False?)

2. Specify the data to use in the PivotTable in the ___________ task pane.
   A. Select Fields
   B. Specify Fields
   C. PivotTable Field List
   D. PivotTable Layout

3. Which of the following is NOT a calculation available in the Value Field Settings dialog box?
   A. Count
   B. Average
   C. StdDev
   D. These are all available

4. Filter a PivotTable by dragging a field into the _______ box in the PivotTable Field List.
   A. AutoFilter
   B. Report Filter
   C. Pivot Filter
   D. Data Filter

5. Which of the following is NOT a button found in the Layout group on the Design tab?
   A. Header Row
   B. Grand Totals
   C. Report Layout
   D. Blank Rows

6. You can group any type of PivotTable item except for dates. (True or False?)

7. When making changes to the PivotTable's source data, the PivotTable refreshes automatically to include the edits. (True or False?)

8. Which of the following is NOT an option in the PivotTable Style Options group?
   A. Banded Columns
   B. Banded Rows
   C. Bold Headers
   D. Row Headers

9. When modifying a PivotTable, the PivotChart is updated along with it. (True or False?)

10. You have to first create a PivotTable in order to create PivotChart. (True or False?)
11. A slicer is a visual way to filter PivotTable content. (True or False?)

12. PivotTables can only be applied to a single PivotTable at a time. (True or False?)

Quiz Answers

1. True. Create a PivotTable in either a new or existing worksheet.

2. C. Specify the data to use in the PivotTable in the PivotTable Field List task pane.

3. D. All are available.

4. B. Filter a PivotTable by dragging a field into the Report Filter box in the PivotTable Field List.

5. A. Header Row is not a button found in the Layout group on the Design tab.

6. False. Dates are commonly grouped in PivotTables.

7. False. Manually refresh the PivotTable to include changes made to the source data.

8. C. Bold Headers is not an option in the PivotTable Style Options group.

9. True. When modifying a PivotTable, the PivotChart is updated along with it.

10. False. In Excel 2013, you are able to create a standalone PivotChart without the association of a PivotTable.

11. True. Slicers provide a visual way to filter PivotTables.

12. False. PivotTables can be applied to other PivotTables in a workbook.
Most people don’t realize that Excel has numerous tools for analysis and organization, so they perform Excel tasks the manual way.

This method can help in simple situations, but isn’t very effective when needing to perform more complex what-if analysis or organize large lists of data.

This chapter teaches about Excel’s tools for analyzing and organizing. These include tools for creating multiple worksheet scenarios, using Goal Seek and Solver tools to perform what-if analysis, and organizing data by subtotaling, outlining, or consolidating.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter. (This chapter does not use the same exercise file for the duration of the chapter.)

The exercises are written so that they may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Creating Scenarios

Ever used a worksheet to answer the question “What if?” If so, that question is a what-if analysis. For example, what would happen if an advertising budget increased by 40 percent? How about 50 percent?

Excel has several tools for performing What-If Analysis, including Goal Seek, Data Tables, and Solver. This lesson shows how to create multiple what-if scenarios using Excel’s Scenario Manager.

Create scenarios

A scenario is a set of input values that can be substituted in a worksheet to perform what-if analysis. For example, create scenarios to show various interest rates, loan amounts, and terms for a mortgage. Excel’s scenario manager allows creation and storage of different scenarios in the same worksheet.

1. Create or open a worksheet that contains one or more formulas.
2. Click the Data tab on the Ribbon, click the What-If Analysis button in the Data Tools group, and select Scenario Manager from the list.
   The Scenario Manager dialog box appears with the message “No Scenarios defined. Choose Add to add scenarios.” Add a new scenario.
3. Click the Add button.
   The Add Scenario dialog box appears.
4. Type a name for the scenario and press <Tab>.
   The cursor moves to the Changing cells box. Select the cells that contain the values to change.
   Tip: To select multiple nonadjacent cells, hold down the <Ctrl> key as they are clicked.
5. Select the cells in the worksheet that contain the values to change, then click OK.
   The Scenario Values dialog box appears. Enter desired values for the changing cells.
   Tip: To make sure the original values aren’t lost for the changing cells, use the original cell values in the first scenario created.
6. Enter values in each of the boxes. Click **OK**, or click **Add** to add another scenario.

   ✔ The scenario is added. If **OK** is clicked, the scenario is listed in the Scenario Manager. If **Add** is clicked, the Add Scenario dialog box appears to add another scenario to.

7. Repeat steps 4 – 6 to add a new scenario. Click **OK**.

   The Scenario Manager dialog box lists each scenario created.

8. Click the **Close** button.

   The Scenario Manager closes.

**Tips**

✔ To edit a scenario, select the scenario in the Scenario Manager dialog box and click the **Edit** button.

**Display a scenario**

Once scenarios are created in a worksheet, display the worksheet using the values from those scenarios.

1. Click the **Data** tab on the Ribbon, click the **What-If Analysis** button in the Data Tools group, and select **Scenario Manager** from the menu.

   The Scenario Manager dialog box appears.

2. Select the scenario that to display and click the **Show** button.

   The worksheet’s values are changed to the values specified in the scenario.
Creating a Scenario Report

A scenario summary report is a single compiled report that summarizes the results from several scenarios. It’s easier to read than switching between different scenarios.

Create cell names

The first step in creating a scenario summary report is to create names for the cells that change.

1. Select the cells involved in the scenario and the labels to use to name them.

2. Click the Formulas tab on the Ribbon and click the Create from Selection button in the Defined Names group.

The Create Names from Selection dialog box appears.

3. Select the option that describes where the labels are located in the selected cell range.

The labels that are in the selected cell range will be used as names.

4. Click OK.

The cells are named using the labels.

Create a Scenario Summary report

Once at least two scenarios are created and have named cells, create a summary report.

1. Click the Data tab on the Ribbon, click the What-If Analysis button in the Data Tools group, and select Scenario Manager from the menu.

The Scenario Manager dialog box appears.

2. Click the Summary button.

The Scenario Summary dialog box appears.

3. Make sure the Scenario summary option is selected.

Next, specify the result cells. These are the cells that are affected by the changing cells.

Tip: Alternatively, select the “Scenario PivotTable report” option to create a report that gives an instant what-if analysis of the scenarios.

4. Select the result cell range and click OK.

A new Scenario Summary worksheet is added to the workbook that contains the summary report.

Exercise

- **Exercise File**: LoanPayment11-2.xlsx

- **Exercise**: Select the cell range A3:F4 and name the cells from the selection.

Create a scenario summary report (the result cell range is D4:F4).
## Working with Data Tables

Another way to get answers to what-if questions is by using a data table. A data table is a cell range that displays the results of a formula using different values.

For example, create a data table to calculate loan payments for several interest rates and term lengths.

There are two types of data tables:

- **One-input Data Table**: Displays the results of a formula for multiple values of a single input cell. For example, if there is a formula that calculates a loan payment, create a one-input data table that shows payment amounts for different interest rates.

- **Two-input Data Table**: Displays the results of a formula for multiple values of two input cells. For example, if there is a formula that calculates a loan payment, create a two-input data table that shows payment amounts for different interest rates and different term lengths.

### Create a one-input data table

1. Set up the table area. Make sure to include the formula in the top row and the input values in the left column. Make sure the formula refers to the input cell.

2. Select the table range that contains the formula and substitution values. This should include blank cells below the formula and to the right of the values—this is where the data table will go.

3. Click the *Data* tab on the Ribbon, click the *What-If Analysis* button in the Data Tools group, and select *Data Table*.

   The Data Table dialog box appears.

4. Type the cell reference for the input cell in the Column input cell box and click **OK**.

   Excel displays the results of the formula using each of the substituted values.

   **Tip**: If the table is set up with the data in a row instead of a column, enter the cell reference for the input cell in the Row input cell box instead.

### Exercise

- **Exercise File**: LoanPayment11-3.xlsx and Weather.xlsx.
- **Exercise**: Create a one-input data table:

  Enter \(=\text{PMT}(C4/12,B4*12,A4)\) in cell B7.

  Enter 6.0, 6.5, 7.0, 7.5, 8.0 in cells A8:A12.

  Select the cell range A7:B12 and create a data table. In the Data Table dialog box, enter C4 in the Column input cell box and click **OK**.

  Delete the contents of B8:B12 to prepare for the two-input table.

  Create a two-input data table: Move the formula in cell B7 to cell A7.

  Enter 5, 10, 15, 20 in cells B7:E7. Select the cell range A7:E12.

  Create a data table and enter B4 as the row input cell and C4 as the column input cell.

  Delete the contents of A7:E12.

  Create a relationship between the tables in the Weather.xlsx file.

### Figure 11-6: The Data Table dialog box and the resulting one-input data table showing different monthly payments at different interest rates.
Create a two-input data table

1. Set up the table area. Make sure to include the formula in the upper-left cell and the values for the first input cell in the left column and the values for the second input cell in the top row.
   
   Make sure the formula refers to the two input cells.

2. Select the table range that contains the formula and substitution values (both the row and column values).
   
   This should include blank cells below the formula and to the right of the values—this is where the data table will go.

3. Click the Data tab on the Ribbon, click the What-If Analysis button in the Data Tools group, and select Data Table.
   
   The Data Table dialog box appears. Since this is a two-input table, two input cells need to be entered.

4. Enter the cells to use for the Row input cell and the Column input cell and click OK.

Creating Relationships between tables

A Relationship is an association between two or more tables that is created based on matching data. By creating a table relationship, you can build PivotTables or other reports that use fields from each table.

1. In a workbook that has at least two tables, make sure that each table has a column that can be mapped to a column in another table.

2. On the Data tab, in the Data Tools group, click Relationships.
   
   The Manage Relationships dialogue box opens.

3. Click New.
   
   The Create Relationships box appears.

4. Click the list arrow for Table and select a Table from the drop-down list.

5. For Column (Foreign), select the column that contains the data that is related to the selection you will make in Related Column (Primary).

6. For Related Table, select a table that has at least one column of data that is related to the table you just selected for Table.
Analyzing Data

7. For Related Column (Primary), select a column that has unique values that match the values in column you selected for Column (Foreign).

8. Click OK.
Using Goal Seek

When the desired result of a single formula is attained, but not the value the formula needs for the result, use the Goal Seek feature. For example, if a $1,200 monthly payment is affordable, so how much of a loan can be taken out? When goal seeking, Excel plugs different values into a cell until it finds one that works.

1. Open or create a workbook that contains the formulas to work with.

2. Click the Data tab on the Ribbon, click the What-If Analysis button in the Data Tools group, and select Goal Seek.

The Goal Seek dialog box appears.

3. Click the Set cell box, and click the cell in the worksheet that contains the formula to use.

4. Click the To value box and enter the value to change it to.

5. Click the By changing cell box, and click the cell to change to achieve the formula result.

   This cell must be a cell that is referenced by the formula.

6. Click OK.

   Excel calculates and displays the value needed to achieve the formula result desired.

7. Click OK to replace the original values or click Cancel to keep the original values.

Exercise

Exercise File: LoanPayment11-4.xlsx

Exercise: Use Goal Seek to determine the maximum loan amount possible to afford with a $1200 monthly payment.

Figure 11-10: Using Goal Seek to determine the maximum loan amount with a $1200 monthly payment.
Using Solver

Excel’s Solver tool can perform advanced what-if analysis on problems with many variable cells. It can also specify constraints, or conditions that must be met to solve the problem.

Solver has been improved in Excel 2013 to include a new user interface, and better functionality.

Install the Solver add-in

Solver is an optional Excel add-in. It needs to be installed before it can be used.

1. Click the File tab on the Ribbon and select Options from the menu.
   The Excel Options dialog box appears.

2. Click the Add-Ins tab.
   By default, Excel Add-ins are displayed. The top of the list displays add-ins that are active, the bottom displays add-ins that are available, but are not currently active.

3. Click the Go button.
   The Add-Ins dialog box appears, displaying a list of the add-ins available for Excel.

4. Click the Solver Add-in check box to select it and click OK.

Microsoft Office reconfigures so that Solver is installed in Excel. The Solver command will now be available in the Analysis group on the Data tab on the Ribbon.

Tip: Excel may need to be restarted so that Solver installs properly.

Use Solver

1. Open or create a workbook that contains the problem to solve.
   A problem should consist of a formula that Excel needs to solve by changing the values of its inputs until it arrives at the desired result.

2. Click the Data tab on the Ribbon and click the Solver button in the Analysis group.
   The Solver Parameters dialog box appears. First, tell Excel the target cell. This is the cell that contains the formula to solve.

Exercise

Exercise File: Mailings11-5.xlsx

Exercise: Imagine being in charge of a mailing campaign for five states. The campaign necessitates the following budget constraints: total budget is $35,000, spending at least 50% of the budget on Minnesota mailings, and at least three mailings must go out in each state.

Based on this information, and the fact that the number of mailings must be a whole number, use Solver to calculate the maximum number of mailings to send out to each state.
3. Select the target cell in the worksheet.
   The cell reference for the target cell appears in the Set Target Cell box.

4. Select a To option. If selecting the Value of option, enter a value.
   Choose from Max, Min, or Value Of, depending on what value Solver needs to calculate. For example, if Max is selected, Solver will change the specified cells to make the target cell as large as possible.

Next, specify the cells that Solver can change to meet the target cell goal.

5. Click the Collapse Dialog button in the By Changing Cells box and select the cells that need to change to reach the goal.
   Tip: Press and hold the <Ctrl> key to select multiple nonadjacent cells.

Finally, add any constraints on the problem. For example, specify that one of the formula’s input cells can’t be greater than a certain value.

6. Click the Add button in the Subject to the Constraints section.
   The Add Constraint dialog box appears.

7. Enter a cell reference, select an operator, and then enter the constraint value to apply to the cell.

8. Click Add to add another constraint, or Cancel to continue.
   Excel returns to the Solver Parameters dialog box.

9. Click the Solve button.
   The Solver Results dialog box appears, stating whether or not Solver found a solution.

10. Select Keep Solver Solution or Restore Original Values and click OK.
Using Text to Columns

The Convert Text to Columns feature in Excel allows splitting the contents of a cell into different columns. For example, it’s possible to split a person’s first and last name into separate columns.

Split data into columns using two different methods:

- **Delimited**: The data will be separated based on the location of commas or tabs within the data.
- **Fixed Width**: Specify a fixed column break location.

Take a look at both methods.

**Tips**

- Before using the text to columns feature, make sure there are enough blank columns next to the data so that the split data will have somewhere to go without copying over the rest of the data.

**Split data using a delimiter**

If the data has delimiters such as commas or tabs, use them to split the data.

1. Select the cell range to convert.

2. Click the **Data** tab on the Ribbon and click the **Text to Columns** button in the Data Tools group.
   
   The Convert Text to Columns Wizard dialog box appears.

3. Select the **Delimited** option and click **Next**.
   
   Here, select the types of delimiters to use to separate the data. Tabs, semicolons, commas, and spaces are all common delimiters.

   The selection will depend on the types of delimiters present in the data. For example, to split first and last names using the space between the names, select the **Space** option.

4. Click the check box next to each delimiter to select in the Delimiters area.

   A preview appears, showing the data will be split into different columns based on the selection.

5. Click **Next**.

   Next, select a format for each column of data.
6. Select a column in the Data preview area and then select a format option for that column in the Column data format area. Repeat for additional columns.

⚠️ **Tip:** To make sure the new columns don’t replace the original data, click the Destination Collapse Dialog button and select the range to where to put the split data.

7. Click **Finish**.

⚠️ **Tip:** A message may appear, asking to replace the contents of the destination cells. To do so, click **OK**.

The data is split into different columns.

**Split data using a fixed column break**

Decide where to split the data using a fixed column break.

1. Select the cell range to convert.

2. Click the **Data** tab on the Ribbon and click the **Text to Columns** button in the Data Tools group.

   The Convert Text to Columns Wizard dialog box appears.

3. Select the **Fixed width** option and click **Next**.

   Manually add break lines to separate data into different columns.

4. Click in the Data preview area to where to place a break line.

   A line appears, showing where the data will be separated.

5. Add additional break lines as desired, then click **Next**.

   Select a format for each column of data.

6. Select a column in the Data preview area and then select a format option for that column in the Column data format area. Repeat for additional columns.

7. Click **Finish**.

⚠️ **Tip:** A message may appear, asking to replace the contents of the destination cells. To do so, click **OK**.

The data is split into different columns.
Grouping and Outlining Data

Many spreadsheets are created in a hierarchical style. For example, a worksheet might contain a column for each month, followed by a total column. By outlining worksheets, they’re easier to understand and read. Instead of sifting through irrelevant information, collapse an outline to display each group’s bottom line. There are several ways to outline a workbook.

- **Using the Auto Outline Feature:** The Auto Outline command automatically outlines a selected range of cells or the entire worksheet, based on formulas and the direction of references.

- **Grouping Data:** Group rows and columns manually by selecting them.

- **Using the Subtotals Feature:** The Subtotals command calculates subtotal values for the labeled columns selected. Excel automatically inserts and labels the total rows and outlines the list.

- **Using the Consolidate Feature:** Consolidate several sheets using the Consolidate feature.

This lesson explains how to use the Auto Outline feature and how to group data manually.

**Group rows or columns manually**

1. Select the column or row data to group.

2. Click the Data tab on the Ribbon and click the Group button in the Outline group.

   The Group dialog box appears. Select whether to group rows or columns.

3. Select the Rows or Columns option and click OK.

   The selected rows or columns are grouped together.

**Hide or show detail**

Once data is grouped or outlined, collapse or expand the group detail.

1. Click the Data tab on the Ribbon and click the Hide Detail or Show Detail button in the Outline group.

   **Other Ways to Hide or Show Detail:**
   - Click the outline symbols next to or above the worksheet. These include the Row Level and Column Level buttons and the plus and minus button.

---

**Exercise**

- **Exercise File:** MonthlySales11-8.xlsx

- **Exercise:** Manually group rows 3 through 6 and practice hiding and displaying details.

Then remove the grouping.

Use the Auto Outline feature (Excel should outline columns E to G). Clear the outline.
Ungroup rows or columns

1. Select the grouped row or column data.

2. Click the Data tab on the Ribbon and click the Ungroup button in the Outline group.

Outline data automatically

If the data contains detailed rows or columns that are summed or subtotaled, Excel can automatically group the data into outline form.

Tips

✓ Excel will only outline numerical data that is related by a sum or subtotal formula. It cannot outline text data or numerical data that is not totaled by a formula.

1. Make sure data has column labels and contains formulas that summarize the data.

   The sum and subtotal functions are commonly used to summarize rows or columns.

   Tip: Summary rows and columns should be below and to the right of the data, respectively. If they are above or to the left, click the Outline Dialog Box Launcher in the Outline group. Remove the checkmark from the Summary rows below detail or Summary columns to right of detail check box.

2. Select a cell in the data range to outline.

3. Click the Data tab on the Ribbon, click the Group button list arrow in the Outline group, and select Auto Outline.

   The data is automatically outlined so that the detailed rows or columns can be collapsed and only the totals or subtotals can be viewed.

Remove an outline

1. Click the Data tab on the Ribbon, click the Ungroup button list arrow in the Outline group, and select Clear Outline.

   The outline is cleared from the worksheet.
Using Subtotals

A quick and easy way to group and summarize data is to use Excel’s Subtotals feature. Usually, subtotals are created with the Sum function, but subtotals can also be created using functions such as Count, Average, Max, and Min. The Subtotals feature also outlines the data, displaying and hiding the detail rows for each subtotal.

Create subtotals

1. Make sure data is arranged into labeled columns, that the data in each column is of the same type, and that data sorted based on the column to group the subtotals by.

   Now Excel is ready to subtotal the data.

   **Tip:** Excel’s Subtotals feature subtotals data by automatically inserting the Subtotal function.

2. Select a cell in the data range.

3. Click the **Data** tab on the Ribbon and click the **Subtotal** button in the Outline group.

   The Subtotal dialog box appears.

4. Click the **At each change in** list arrow and select the column to subtotal.

   This command specifies what to subtotal. For example, to subtotal a list of customers, the products they bought, and the amounts of the sales, subtotal the list by the type of product; to get the subtotal, select the column that contains the products.

5. Click the **Use function** list arrow and select the function to use to calculate the subtotals.

   For example, select Sum, Count, Average, or Max.

6. In the “Add subtotal to” box, click the check box next to each column that has values to subtotal.

7. Click **OK**.

   The data is organized with subtotals.

**Tips:**

- To hide or show subtotals detail, click the **Hide Detail** and **Show Detail** buttons in the Outline group on the Ribbon or use the outline symbols next to the worksheet to hide or display individual subtotals.

- To add more subtotals, repeat the steps but uncheck the **Replace current subtotals** check box so that the existing subtotals are not overwritten.
Analyzing Data

**Remove subtotals**

1. Click the **Data** tab on the Ribbon and click the **Subtotal** button in the Outline group.
   
   The Subtotal dialog box appears.

2. Click the **Remove All** button.

   The subtotals are removed.

![Figure 11-23: Subtotals of sales and commissions calculated at each change in position. In other words, the subtotal of each position appears in the list, with the grand total appearing at the bottom.](image)
Consolidating Data by Position or Category

Excel can automatically summarize or consolidate information from multiple worksheets into a single master worksheet using the Consolidate feature. For example, if there’s sales data from three different offices on three different worksheets, Excel can total them on another worksheet.

Excel can consolidate information in three different ways: by position, by category, or by using formulas. This lesson describes the first two ways.

- **Consolidate by position**: Used when data in all the worksheets is arranged in exactly the same order and location.

- **Consolidate by category**: Used when the worksheets have the same row and column labels, but the rows and columns aren’t arranged in the same order on all the worksheets. Excel uses the labels to match the data.

**Tips**

- Make sure the label spelling and capitalization are identical on each of the worksheets to consolidate by category.

**Consolidate by position or category**

Before consolidating by position or category, make sure the data is arranged in labeled rows and columns without blank rows or columns. Each of the ranges to consolidate needs to be on a separate worksheet, with a blank worksheet for the consolidation’s destination.

When consolidating, it’s not necessary to actually specify whether data is being consolidated by position or category—Excel knows how to consolidate based on the data range selected and whether or not the consolidating worksheets are arranged identically.

1. On the blank worksheet, click the upper-left cell in the area where to put the consolidated data.

2. Click the Data tab on the Ribbon and click the Consolidate button in the Data Tools group.

   The Consolidate dialog box appears.

3. Click the Function list arrow and select the function to use to consolidate the data.

   Consolidation functions include Sum, Count or Average.

---

**Exercise**

- **Exercise File**: MonthlySales11-10.xlsx
- **Exercise**: Add a new worksheet to the workbook.

Consolidate the Sales totals from worksheets Jan, Feb, and Mar into the new worksheet.

Copy the Sales and First Name labels to the consolidated worksheet.

**Figure 11-24**: Consolidating sales data from three different worksheets.
4. Click the Reference text box. Then click the first worksheet tab to consolidate and select the range to consolidate.

  Tip: If source data is in a different workbook, click Browse to locate the file and click OK.

5. Click the Add button.

6. Repeat steps 4 and 5 to select the ranges on any other worksheets.

  Tip: If consolidating from multiple workbooks and the consolidation should be updated automatically whenever the source data changes, click the Create links to source data check box to select it.

7. To copy labels to the consolidated worksheet, click the Top row and Left column options.

   This tells Excel where the labels are located in the source ranges.

8. Once ready to consolidate, click OK.

   The values from the selected ranges are combined on the consolidation worksheet using the function selected.

  Tips

  ✓ To copy labels onto the consolidation worksheet, any labels that don’t appear in all of the source ranges will appear in separate rows or columns on the consolidation worksheet, along with their corresponding data cells.
Consolidating Data Using Formulas

Consolidating with formulas is the most versatile and powerful way to consolidate data from multiple worksheets into a single worksheet because there is no prescribed format for the data that is consolidated.

The cells referenced don’t need to be in the same position on each sheet, or even have the same labels, to be consolidated using this method:

1. Copy any column or row labels to use from the source worksheets to the consolidation worksheet, then paste the labels where to see consolidated data.

2. Enter a formula that references the source cells in each worksheet that to consolidate.

For example, combine three different cells on three different worksheets by typing =Sum(Sheet2!A6,Sheet3!B7,Sheet4!D2). Or, to reference the same cell on different worksheets, enter =Sum(Sheet2:Sheet4!A6).

**Tips**

- Instead of typing each cell reference, type the first part of the formula, for example =Sum(, and then click the cells to include.
- Enter a comma between cell selections from different worksheets.
- The consolidation will automatically update when the source cell ranges are changed.

### Exercise

**Exercise File:** MonthlySales11-11.xlsx

**Exercise:** Find the total commission paid out in the first quarter of the year. Label the total “1st Quarter Commission Total”

In cell A9 on Sheet1, enter =Sum( Then select cells G2:G6 on the Jan sheet, type a semi-colon, select G2:G6 on the Feb tab, type a semi-colon, and select G2:G6 on the Mar tab, and press Enter.

The total 38,850 appears in cell A9 on Sheet1.

---

**Figure 11-26:** Consolidating data using a formula.
Analyzing Data Review

Quiz Questions

1. To make sure the original values for the changing cells aren't lost, use the original cell values in the first scenario created. (True or False?)

2. The result cells specified in the Scenario Summary dialog box are __________.
   A. the total row of the scenarios
   B. the data labels used in the scenarios
   C. the cells that change in the scenarios
   D. the cells that are affected by the changing cells in the scenarios

3. It's possible to create either a one- or a two-input data table. (True or False?)

4. Use Goal Seek when __________.
   A. the result of a formula isn't known, but the formula input values are known
   B. the desired result of a formula is known, but not the input value the formula needs to arrive at the result
   C. wanting to quickly create scenarios
   D. the result of one formula is known, but not the result of another formula that references that formula

5. Solver is an optional Excel Add-In feature. (True or False?)

6. Which of the following is NOT a delimiter that Excel can use to split cell data?
   A. Space
   B. Semicolon
   C. Comma
   D. All of these are common delimiters

7. Group rows and columns manually by selecting them. (True or False?)

8. Sort data before grouping and summarizing its information using the Subtotals command. (True or False?)

9. Consolidate by _______ when the data in all the worksheets is arranged in exactly the same order and location.
   A. position
   B. category
   C. absolute reference
   D. column

10. The cells referenced don't need to be in the same position on each sheet, or even have the same labels, to be consolidated using formulas. (True or False?)
Quiz Answers

1. True. To make sure the original values for the changing cells aren't lost, use the original cell values in the first scenario created.

2. D. The result cells specified in the Scenario Summary dialog box are the cells that are affected by the changing cells in the scenarios.

3. True. Create either a one- or a two-input data table

4. B. Use Goal Seek when the desired result of a formula is known, but not the input value the formula needs to arrive at the result.

5. True. Solver is an optional Excel Add-In feature.

6. D. All of these are common delimiters that Excel can use to split cell data.

7. True. Group rows and columns manually by selecting them.

8. True. Always sort data before using the Subtotals command.

9. A. Consolidate by position when the data in all the worksheets is arranged in exactly the same order and location.

10. True. The cells referenced don't need to be in the same position on each sheet, or even have the same labels, to be consolidated using formulas.
Excel’s Internet features allow hyperlinks to be added to workbooks to link them to another workbook, a file created in another program, or even a Web page. Connect to data sources through the Web, or to other databases.
Inserting a Hyperlink

In this lesson, learn how to use hyperlinks in Excel. A hyperlink is text or an image that points to a file, a specific location in a file, or a Web page on the computer, on a network, or on the Internet. Whenever clicking on a hyperlink, it jumps to the hyperlink’s destination (if it’s available).

A hyperlink is usually indicated by colored and underlined text. On the Internet, hyperlinks are used all the time to move between different Web pages.

1. Select the cell to use for the hyperlink and enter the text or image to hyperlink.

2. Click the Insert tab on the Ribbon, and click the Hyperlink button in the Links group.

Other Ways to Insert a Hyperlink:
Select the text and press `<Ctrl>` + `<K>`. Or, right-click the cell and select Hyperlink from the contextual menu.

The Insert Hyperlink dialog box appears. There are four different types of Hyperlink destinations that can be created:

- **Existing File or Web Page:** Creates a link to another Excel workbook or to a file created in another program, such as a Microsoft Word document, or to a Web page on the Internet.

- **Place in This Document:** Takes the user to a bookmark in the same document.

- **Create New Document:** Creates a new Excel workbook and inserts hyperlinked text into the existing workbook that connects to the new one.

- **E-mail Address:** Creates a clickable e-mail address.

3. Either browse to or enter the hyperlink’s destination and click OK.

The hyperlink is created. Now whenever the hyperlink is clicked, Excel will take the user to the hyperlink’s destination file or the location specified.

Tips

✔ To edit an existing hyperlink, right-click the hyperlink and select Edit Hyperlink from the contextual menu.

✔ To remove a hyperlink, right-click the hyperlink and select Remove Hyperlink from the contextual menu.
Importing Data from an Access Database or Text File

Excel can connect to external data sources including other files, databases or Web pages. In order to work with data from an external source, create a data connection in Excel.

Import data from an Access database

1. Click the Data tab on the Ribbon and click the Get External Data button.
2. Click From Access.
   
   The Select Data Source dialog box appears. By default, it searches for data sources available on the computer and displays them in the dialog box.
   
   Tip: If the Get External Data group does not appear on the Ribbon, click the Get External Data button and select an option from the list.
3. Browse to and select the database file that contains the data to import. Click the Open button.
   
   The Select Table dialog box appears. Here, select which table to import from the database.
   
   Tip: If the Select Table dialog box does not appear, there is only one table in the database, and it is automatically selected.
4. Select a table and click OK.
   
   The Import Data dialog box appears. Here, tell Excel how to display the data in the workbook—as a table, PivotTable, etc.—as well as where to put the data—in the existing worksheet or in a new one.
5. Select an option for how to view the data and then select an option for where to put it. Click OK.
   
   Tip: Select to put the data in the existing worksheet, also select the cell where to put it.

The data is imported from the Access database into the workbook.

Tips

✓ If, while connecting to external data, a security notice appears saying that it is connecting to an external source that may not be safe, click OK.

Exercise

- Exercise File: Board of Directors Meeting.txt
- Exercise: Create a new workbook and import the Board of Directors Meeting.txt file data into it. In the Text Import Wizard, leave the default options selected. Save the new workbook as April.xlsx.
Import data from a Text file

Import data from text files with .txt and .csv extensions.

1. Click the **Data** tab on the Ribbon and click the **From Text** button in the Get External Data group.

   The Import Text File dialog box appears.

   **Trap:** If the Get External Data group does not appear on the Ribbon, click the **Get External Data** button and select an option from the list.

2. Browse to and select the text file that contains the data to import. Click the **Import** button.

   Step 1 of the Text Import Wizard appears. Select whether the file is delimited or fixed width. Also, select the row of text from which to start importing data.

3. Select a file type and enter the row at which to start importing. Click **Next**.

   Step 2 of the Text Import Wizard appears. Specify the delimiters used to separate the data in the text file.

4. Select delimiters or specify fixed width column breaks. Click **Next**.

   Step 3 of the Text Import Wizard appears. Select a column and choose the format to use for its data. Or, select the option to skip the column.

5. Specify a format for each column, or skip the column. Click **Finish**.

   The Wizard closes and the Import Data dialog box appears, asking where to import the data in the workbook.

6. Select where to put the imported data. Click **OK**.

   The data from the text file appears in the workbook.
Importing Data from the Web and Other Sources

Instead of copying and pasting data into a worksheet from a Web page—which normally causes no end of formatting problems—import data from a growing number of Web sites. It’s also possible to get data from a variety of sources such as a SQL server.

**Tips**
- Some data sources may require special security access, and the connection process can often be very complex. Enlist the help of an organization’s technical support staff for assistance.

**Import data from the Web**

1. Click the **Data** tab on the Ribbon and click the **Get External Data** button.
2. Click **From Web**.
   The New Web Query window opens, displaying the Internet Explorer Home page.
   **Trap:** If the Get External Data group does not appear on the Ribbon, click the Get External Data button and select an option from the list.
3. Enter the address of the Web site to visit in the Address box and click **Go**.
   If the Web site is set up to export data, note table selection arrows next to the pieces of data.
4. Click the table selection arrows next to the data to import, then click **Import**.
   **Tip:** When clicking a yellow table selection arrow, it turns into a green checkmark.
   The Import Data dialog box appears. Specify where to put the data.
5. Select an option for where to put the data. Click **OK**.
   The Web data appears in the workbook.

---

**Exercise**
- **Exercise File:** None required.
- **Exercise:** Create a new workbook and import data from [http://moneycentral.msn.com](http://moneycentral.msn.com).
  Close the workbook without saving.

---

**Figure 12-8:** The New Web Query Window.
**Import data from other sources**

1. Click the **Data** tab on the Ribbon. Click the **Get External Data** button.

   Click **From Other Sources**.

   **Trap:** If the Get External Data group does not appear on the Ribbon, click the **Get External Data** button and select an option from the list.

   Several data source options appear.

2. Select a data source, then follow the onscreen instructions or instructions from an organization’s technical support staff to complete the connection.
Working with Existing Data Connections

Besides allowing Excel to add connections, Excel has tools to help view and manage the data connections that are accessible in the workbook, on the computer, or on the network.

Access existing connections

If connections have been added that should or need to be displayed, or to open a connection that Excel has built in, use the Existing Connections dialog box.

1. Click the Data tab on the Ribbon and click the Get External Data button.
2. Click Existing Connections.
   
   Trap: If the Get External Data group does not appear on the Ribbon, click the Get External Data button and select an option from the list.

   The Existing Connections dialog box appears. Here are the connections in the open workbook, on the network, or on the computer. Excel has automatically included a few Web site connections in the “on your computer” section.
3. Select the connection to display and click the Open button.
   
   The Import Data dialog box appears.
4. Select how and where to display the data in the workbook and click OK.
   
   The data appears in the workbook.

Manage connections

View the present connections in the workbook and change their properties using the commands in the Connections group.

1. Click the Data tab on the Ribbon.
   
   The Connections group offers several options for working with the workbook’s connections:
   
   • Connections button: Display the Workbook Connections dialog box to see the connections and locations of connections in the workbook. Add, remove, refresh, or adjust the properties of the connections.

   Exercise

   • Exercise File: April.xlsx
   • Exercise: Click cell outside the A1:D6 data range and view the existing connections from which to get external data. Close the dialog box.

   Click a cell within the A1:D6 data range and click the Connections button in the Connections group. Click “Click here to see where the selected connections are used” in the Workbook Connections dialog box. Close the dialog box.

   View the properties for the external data range and then close the dialog box.

---

Figure 12-9: The Existing Connections dialog box.

Figure 12-10: The Workbook Connections dialog box.
Working with the Web and External Data

- **Properties button**: Change the connection properties of the imported data currently selected in the worksheet. Properties include the name of the connection, formatting and layout, and refresh options. Refer to Table 12-1: Data Range Properties, for more information about properties.
- **Refresh All button**: Updates workbook data to match the external data source.
- **Edit Links**: Shows the other files the workbook is connected to so it’s possible to edit or remove the links.

2. Click a button in the Connections group and work with the connection as necessary.

**Tips**

- When working with workbooks that have data connections, a Security Warning banner may appear below the Ribbon stating that connections have been disabled. Click Enable this content, and click OK.

<table>
<thead>
<tr>
<th>Table 12-1: Data Range Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Save query definition</strong></td>
</tr>
<tr>
<td><strong>Save password</strong></td>
</tr>
<tr>
<td><strong>Enable background refresh</strong></td>
</tr>
<tr>
<td><strong>Refresh every</strong></td>
</tr>
<tr>
<td><strong>Refresh data on file open</strong></td>
</tr>
<tr>
<td><strong>Remove external data from worksheet before saving</strong></td>
</tr>
<tr>
<td><strong>Include field names</strong></td>
</tr>
<tr>
<td><strong>Preserve column sort/filter/layout</strong></td>
</tr>
<tr>
<td><strong>Include row numbers</strong></td>
</tr>
<tr>
<td><strong>Preserve cell formatting</strong></td>
</tr>
<tr>
<td><strong>Adjust column width</strong></td>
</tr>
<tr>
<td><strong>Fill down formulas in columns adjacent to data</strong></td>
</tr>
</tbody>
</table>
Working with the Web and External Data Review

Quiz Questions

1. A hyperlink is text or an image that points to a file, a specific location in a file, or a Web page on the computer, on a network, or on the Internet. (True or False?)

2. To import data into Excel, use the buttons in the ___________ group on the Data tab on the Ribbon.
   A. Connect to External Data
   B. Get External Data
   C. Import Data
   D. Import Files

3. When clicking a yellow table selection arrow on a Web page, it turns into a green checkmarked box. (True or False?)

4. Which of the following is NOT a button in the Connections group on the Data tab on the Ribbon.
   A. Hyperlink
   B. Refresh All
   C. Properties
   D. Connections

Quiz Answers

1. True. A hyperlink is text or an image that points to a file, a specific location in a file, or a Web page on the computer, on a network, or on the Internet.

2. B. To import data into Excel, use the buttons in the Get External Data group on the Data tab on the Ribbon.

3. True. When clicking a yellow table selection arrow on a Web page, it turns into a green checkmarked box.

4. A. Hyperlink is not a button in the Connections group.
If performing the same task over and over again, consider creating a macro to complete the task. A macro helps perform routine tasks by automating them. Instead of manually performing a series of time-consuming, repetitive actions, record a single macro that does the entire task all at once.

This entire chapter is devoted to macros. We start with the basics: learning how to record and play a macro. Then the lesson moves into some more advanced topics including how to write and edit macros using the Visual Basic programming language.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways to follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that they may be “built upon”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Recording a Macro

A macro is a series of Excel commands and instructions that are recorded so that they can be executed as a single command. Instead of manually performing a series of time-consuming, repetitive actions in Excel, create a macro to perform the task.

There are two ways to create a macro: by recording them or by writing them in Excel’s Visual Basic programming language. This lesson explains the easy way to create a macro—by recording the task(s) the macro shall execute.

When recording a macro, imagine it being videotaped; everything is recorded—all commands, the data entered, even any mistakes made. Before recording a macro, it’s helpful to write down a script that contains all the steps the macro will record. Practice or rehearse the script a couple times, to make sure it works, before actually recording it. If a mistake is made while recording a macro, don’t worry—the existing macro can always be deleted; try again or edit the macro’s Visual Basic source code to fix the mistake.

1. Click the View tab on the Ribbon and click the Macros button list arrow in the Macros group. Select Record Macro.

   The Record Macro dialog box appears.

   Tip: If clicking the Macros button list arrow and select Use Relative References, actions are recorded relative to the initially selected cell.

2. Enter a name for the macro and press <Tab>.

   Next, enter a shortcut key that will allow Excel to run the macro by pressing the <Ctrl> + <shortcut key>.

3. Enter a shortcut key, if desired.

   Now, tell Excel where to store the macro. There are three choices:

   - **Personal Macro Workbook**: If a macro needs to be available whenever using Microsoft Excel, store the macro in the Personal Macro Workbook.
   - **New Workbook**: Stores the macro in a new workbook.
   - **This Workbook**: Stores the macro in the active or current workbook.

---

**Exercise**

- **Exercise File**: WeeklySales13-1.xlsx
- **Exercise**: Create a macro that inserts the current date with Bold and Center Alignment formatting:

  Click cell B3. Open the Record Macro dialog box and name the new macro “DateStamp”. Assign the macro the shortcut <Ctrl> + <d>, make sure This Workbook is selected, and enter the description “This macro inserts the current date”. Click OK.

  To record the macro, type =Today() and click the Enter button on the Formula Bar. Apply bold and center formatting. Stop recording the macro.

  Save the workbook as a macro-enabled file type (.xlsm).

---

**Figure 13-1**: The Record Macro dialog box.

**Figure 13-2**: The Stop Recording button in the status bar indicates all the actions are being recorded in the macro. Click the Stop Recording button to stop recording the macro.
4. Click the **Store macro in** list arrow and select where to store the macro.

5. Click in the Description box and enter a description for the macro, if desired.

6. Click **OK**.

   Now comes the important part—recording the macro.

7. Record the macro: perform the actions to include in the macro.

   Once all the actions have been recorded, stop recording.

8. Click the **Macros** button list arrow in the Macros group and select **Stop Recording**.

   The macro is recorded and ready to use.

   ![Other Ways to Stop Recording:](image)

   **Other Ways to Stop Recording:**
   
   Click the **Stop Recording** button on the status bar.

9. Save the workbook. Click **No** to save the file as a macro-enabled workbook.

   The Save As dialog box appears.

10. Click the **Save as type** list arrow and select **Excel Macro-Enabled Workbook (.xlsm)** from the list.

    Click **Save**.

    The workbook is saved, and the macros will be available next time the workbook is opened.

---

**Figure 13-3:** This dialog box appears to warn that macros must be saved in a different file type.
Working with Macros

Playing and Deleting a Macro

Once a macro has been recorded, it’s ready to be viewed and played.

Tips

✓ If a Security Warning message beneath the Ribbon appears saying that macros have been disabled, click the Enable Content button.

Play a macro

1. Click the View tab on the Ribbon and click the Macros button list arrow in the Macros group. Select View Macros.
   The Macro dialog box appears. Here are the macros that have been recorded.

2. Select the macro to run and click the Run button.
   The macro runs, performing the steps recorded.

Delete a macro

1. Click the View tab on the Ribbon and click the Macros button list arrow in the Macros group. Select View Macros.
   The Macro dialog box appears.

2. Select the macro to delete and click the Delete button.

3. Click Yes.
   The macro is deleted.

Exercise

• Exercise File: WeeklySales13-2.xlsx
• Exercise: Run the DateStamp macro so that the current date appears in cell C3.

Figure 13-4: Macros are usually disabled when the file is opened, even if the file is saved to be macro-enabled.

Figure 13-5: Playing a macro in the Macro dialog box.
Adding a Macro to the Quick Access Toolbar

To make macros fast and easy to access, add them as buttons on the Quick Access Toolbar.

Tips

✓ It may seem obvious, but it’s necessary to create a macro before it can be added to the Quick Access Toolbar.

1. Click the **Customize Quick Access Toolbar** button next to the Quick Access Toolbar and select **More Commands**.
   
The Quick Access Toolbar tab of the Excel Options dialog box appears.

2. Click the **Choose commands from** list arrow and select **Macros**.
   
A list of macros appears.

3. Select the macro to add to the Quick Access Toolbar and click the **Add** button.
   
The macro now appears in the list on the right side of the dialog box. At this point, select a symbol to represent the macro on the toolbar.

4. Click the **Modify** button.
   
The Modify Button dialog box appears, displaying dozens of symbols to choose from.

5. Select a symbol.
   
Modify the display name that will appear when hovering over the button on the toolbar.

6. (Optional) Enter a different name for the button in the **Display name** box.

7. Click **OK** to close the Modify Button dialog box. Click **OK** to close the Excel Options dialog box.
   
The macro appears as a button on the Quick Access Toolbar. Click it to run the macro.

8. Click the macro button on the Quick Access Toolbar.

Tips

✓ To remove a macro from the Quick Access Toolbar, right-click the button and select **Remove from Quick Access Toolbar**.

Exercise

- **Exercise File**: WeeklySales13-3.xlsm

- **Exercise**: Add the DateStamp macro to the Quick Access Toolbar, selecting the green triangle symbol to represent the macro on the Toolbar.

Then remove the DateStamp macro from the Quick Access Toolbar.

Figure 13-6: The Quick Access Toolbar with a macro button added.

Figure 13-7: Adding the DateStamp macro button to the Quick Access Toolbar.

Figure 13-8: Selecting a button symbol in the Modify Button dialog box.
Editing a Macro’s Visual Basic Code

This lesson introduces the Visual Basic (also called VB or VBA) programming language—the code Excel uses to record macros. Using the Visual Basic language and the Visual Basic editor can make minor changes to macros once they are recorded.

The best way to learn about Visual Basic is to view existing code. This lesson looks at how to view and edit the code for an existing macro.

1. Click the View tab on the Ribbon and click the Macros button list arrow in the Macros group. Select View Macros.
   The Macro dialog box appears. See the macros that have been recorded.

2. Select the macro to edit and click the Edit button.
   The Microsoft Visual Basic Editor program appears. Those funny-looking words are Visual Basic—the language that was used by Excel to record the macro created.

   It’s not necessary to have to learn Visual Basic to be proficient at Excel, but knowing the basics can be helpful if ever wanting to modify an existing macro. Take a close look at the code for a macro; some of the procedures should make a little sense. For example, if a macro contains a copy or paste command, see the text “Selection.Copy” or “Selection.Paste”.

   Delete sections of code to delete certain actions from the macro, or edit the code to change the macro’s actions.

3. Edit the macro’s code as desired, then click the Save button on the Standard toolbar.

4. Click the Close button in the upper right-hand corner.
   The Visual Basic Editor window closes.

Exercise

- Exercise File: WeeklySales13-4.xlsm
- Exercise: Open the DateStamp macro in editing mode. Edit the code so that the date is horizontally aligned to the left instead of center.
  Run the macro in cell D3 to see that the macro enters the date so it is aligned to the left side of the cell.

Figure 13-9: Editing a macro’s code using the Microsoft Visual Basic Editor.
Inserting Copied Code in a Macro

Unless a programmer, it’s unlikely that learning many of Visual Basic’s hundreds of functions, statements, and expressions will be necessary—and that’s okay.

A very useful technique to use to edit and create macros is to insert code that has been copied, or plagiarized, from another macro. This technique adds steps to an existing macro by recording the steps to add in new macros, copying the appropriate code and inserting it into the existing macro.

Display the Developer tab and enable macros

Before copying code, display the Developer tab and enable macros by turning off macro security.

1. Open any workbook, click the File tab on the Ribbon and select Options.
   
   The Excel Options window appears.

2. Click the Customize Ribbon tab. Click Developer check box in the Customize the Ribbon column. Click OK.
   
   Next, enable all macros.

3. Click the Developer tab on the Ribbon and click the Macro Security button in the Code group.
   
   The Trust Center window appears, displaying the Macro Settings.

4. Select the Enable all macros… option and click OK.

   Tip: For security purposes, once done working with macros, disable them again in the Trust Center.

   Other Ways to Enable Macros for a Single Workbook:

   When a file that uses macros is open, click the Enable macros button in the Security Warning bar.

Insert code in a macro

1. Open the workbooks containing the macros to work with.

   This includes both the workbook with the macro to be copied from and the workbook with the macro to be pasted into.

Exercise

- Exercise File: ExpenseReport13-5.xlsm
- Exercise: The object of the exercise is to copy the code that inserts today’s date from the DateStamp macro into the ExpenseFillin macro.

First, open the ExpenseReport13-5 workbook, display the Developer tab and enable macros.

Open the DateStamp macro and copy the block of code starting at the line `ActiveCell.FormulaR1C1 = "=TODAY()"` and ending at the line `Selection.PasteSpecial Paste:=xlPasteValues`.

Paste this code into the ExpenseFillin macro under the line `Range("C5").Select`.

Save the changes to the ExpenseFillin macro.

Run the ExpenseFillin macro in cell A5.
2. Click the View tab on the Ribbon and click the Macros button in the Macros group. Select the macro that contains the code to copy and click the Edit button.

The Visual Basic Editor window opens. In the Project pane on the left side of the window are the macros associated with all the workbooks that are open.

3. In the Project pane on the left side of the window, click the expand button to expand the source workbook’s project until the Modules folder can be seen. Expand this folder and double-click the module that contains the code to copy.

The code for the selected module, or macro, appears in the window to the right.

Tip: A module is just like a folder where Excel puts the code each time a macro is recorded.

4. Scroll through the code until the code to copy is visible, then select the code and click the Copy button on the Standard toolbar.

The code is copied.

Now open the macro in which to paste the copied code.

5. In the Project pane along the left side of the window, open the module in which to paste the copied code.

The code for the selected module, or macro, is displayed in the window.

Tip: If the macros to copy and paste between are in the same workbook, they appear in the code part of the window together. They are simply separated by a line.

6. Click where to paste the code and click the Paste button on the Standard toolbar.

The copied code is inserted into the macro.

7. Click the Save button on the Standard toolbar, then click the Visual Basic Editor window’s Close button.

The Visual Basic Editor window closes. The macro with the newly inserted code is now ready to be run.
Declaring Variables and Adding Remarks to VBA Code

Heard that programming is a lot like algebra? It’s true! Algebra uses variables, like \( r \) in the equation \( \pi r^2 \). Programming uses variables too. Always declare any variables when using them in code. Declaring a variable is like telling Excel “I’m going to be using a variable named \( r \) in my code.”

This lesson explains how to declare variables and how to add remarks—in code.

Declare a variable (DIM statement)

In Visual Basic, use the DIM statement to declare variables, using the syntax `DIM variablename As datatype`.

1. Open the workbook that contains the macro with the code to change.
2. Click the View tab on the Ribbon and click the Macros button in the Macros group.
   The Macros dialog box appears.
3. Select the macro that contains the code to work on and click Edit.
   The macro opens in the VBA window.
4. Click where to add the statement in the code. Add a Dim statement at the beginning of the procedure, using the syntax `Dim VariableName As DataType`.

Here’s what the arguments of the Dim statement mean:

- **VariableName**: The name of the variable.
  Example: `EmployeeName`.

- **DataType**: The type of data to use in the variable, such as a number, date, or text. See Table 13-1: Data Types used in DIM Statements for a list of data types that can be used.

Make sure to add an “As” between the variable name and the data type. Example: `As String`.

Exercise

- **Exercise File**: ExpenseReport13-6.xlsm
- **Exercise**: Open the ExpenseFillin macro in the Visual Basic Editor. Enter the following DIM and REM statements at the top of the macro’s code:

  ```vba
  Dim EmployeeName As String
  'Declares the EmployeeName variable as a text string
  Dim EmployeeNo As Long
  'Declares the EmployeeNo variable as an integer
  ```

Figure 13-13: The syntax of a DIM statement.

Figure 13-14: An example of DIM and REM statements.
Add a remark to a procedure (REM statement)

Code can be confusing, but it’s possible to make it easier to understand by adding explanatory remarks to it. These remarks are called REM statements. A REM statement doesn’t do anything—it’s just a way to add notes explaining the function of the code.

1. Open the workbook that contains the macro with the code to change.
2. Click the View tab on the Ribbon and click the Macros button in the Macros group.
   The Macros dialog box appears.
3. Select the macro that contains the code to work on and click Edit.
   The macro opens in the VBA window.
4. Click where to add the remark in the code. Type ‘ ‘ (an apostrophe) then type the rest of the remark.

<table>
<thead>
<tr>
<th>Table 13-1: Data Types used in DIM Statements</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Date Type</strong></td>
</tr>
<tr>
<td>Byte</td>
</tr>
<tr>
<td>Boolean</td>
</tr>
<tr>
<td>Integer</td>
</tr>
<tr>
<td>Long (Long Integer)</td>
</tr>
<tr>
<td>Date</td>
</tr>
<tr>
<td>String (Text)</td>
</tr>
</tbody>
</table>
Prompting for User Input

When creating macros and code it is often useful to prompt the user for information. Then, use this information in any number of ways—place it in a cell, use it in a calculation, or print it in a header or footer.

This lesson explains one of the easiest ways to prompt the user for information—using the InputBox function. The InputBox function prompts the user for information by displaying a dialog box.

The syntax for the InputBox function is

```
InputBox("Prompt")
```

where "Prompt" is the message to display (usually enclosed in quotation marks).

1. Open the workbook that contains the macro with the code to change.

2. Click the View tab on the Ribbon and click the Macros button in the Macros group.

   The Macros dialog box appears.

3. Select the macro that contains the code to work on and click Edit.

   The macro opens in the VBA window.

4. Click where to add the InputBox function to in the code.

5. Add an Input statement using the syntax

   `InputBox("Prompt")`.

Exercise

- **Exercise File:** ExpenseReport13-7.xlsm
- **Exercise:** Open the ExpenseFillin macro in the Visual Basic Editor. Enter the following InputBox statements below the second REM statement:

  ```vba
  EmployeeName = InputBox("Enter the Employee Name.")
  EmployeeNo = InputBox("Enter the Employee Number.")
  ```

  Run the ExpenseFillin macro in A5, entering a name and employee number when prompted.
Using the If…Then…Else Statement

The “If…Then…Else” statement takes action based on a certain condition. For example, if an employee’s weekly sales are more than $2,500, then calculate a 5% commission bonus for the employee, or else don’t calculate a bonus.

1. Open the workbook that contains the macro with the code to change.
2. Click the View tab on the Ribbon and click the Macros button in the Macros group.
   The Macros dialog box appears.
3. Select the macro that contains the code to work on and click Edit.
   The macro opens in the VBA window.
4. Click to where to add the remark in the code. Add an If…Then…Else statement using the following syntax (italicized text is where variables belong in the statement):

   ```vba
   If condition Then
   statement if true
   Else
   statement if false
   End If
   ```

   **Exercise**
   - **Exercise File:** ExpenseReport13-8.xlsm
   - **Exercise:** Use the If…Then…Else statement to enter the employee number 45177 if the employee is Jeff Nelson, else the user will have to enter their employee number.
     Run the ExpenseFillin macro entering Jeff Nelson as the Employee Name.

   ![Image of VBA window showing an If…Then…Else statement](image.png)

   **Figure 13-17:** The syntax of an If…Then…Else statement.

   ![Image of an If…Then…Else statement used in a macro](image2.png)

   **Figure 13-18:** An example of an If…Then…Else statement used in a macro.
Working with Macros Review

Quiz Questions

1. Which of the following is NOT a place to choose to store a macro in?
   A. This Workbook  
   B. New Workbook  
   C. Universal Macro Workbook  
   D. Personal Macro Workbook

2. To play a macro in the Macro dialog box, click the _______ button
   A. Run  
   B. Play  
   C. Macro  
   D. Go

3. Select a symbol to represent the macro on the Quick Access Toolbar. (True or False?)

4. Excel macros are written in the ________ programming language.
   A. ABC  
   B. Visual Basic  
   C. Basic Macro  
   D. Visual Excel

5. Change the macro security settings in the _________ window.
   A. Macro Center  
   B. Code Center  
   C. Trust Center  
   D. VBA Control

6. Which of the following statements declares a variable?
   A. REM HireDate as Date  
   B. Dim HireDate as Date  
   C. InputBox(HireDate) = Date  
   D. Sub HireDate() = Date

7. Which of the following statements would prompt a user for information?
   A. REM DOB as Date  
   B. Sub HireDate(  
   C. DIM HireDate(  
   D. InputBox(
Quiz Answers

1. C. The Universal Macro Workbook is not a place a macro can be stored.
2. A. Click the Run button in the Macro dialog box to play a macro.
3. True. Select a symbol to represent the macro on the Quick Access Toolbar.
4. B. Excel macros are written in the Visual Basic programming language.
5. C. Change macro security settings in the Trust Center window.
6. B. Dim HireDate as Date would declare the variable 'HireDate' as a date.
7. D. The statement InputBox(.
Customizing is a great asset in an application. Customization allows the use of a particular mix of commands and shortcuts that are best for a working style.

The lessons in this chapter focus on how to customize the Ribbon, the Quick Access Toolbar, and AutoCorrect. It also discusses how to access and review the default options for a program.
Customizing the Ribbon

One of the most useful features in Office 2013 is customizing the Ribbon. Add tabs and groups, or rearrange the Ribbon to better fit a particular work style.

Create a new tab or group

Add new groups to tabs, or create new tabs with new groups.

1. Click the File tab on the Ribbon and select Options.
   The Options dialog box appears.

2. Click the Customize Ribbon tab.
   The left column displays commands that can be added to the Ribbon.
   The right column displays the tabs on the Ribbon, and the groups and commands in each tab.
   Tip: Click the plus sign next to a tab or group to expand it.

3. In the right column, select the tab to add the new tab or group there.
   A new tab, which automatically includes a new group, will be inserted below the selected tab.
   A new group will be inserted within the selected tab.

4. Click the New Tab or the New Group button.
   The new tab or group is added.

Rename a tab or group

Once a tab or group is created, give it a name.

1. Select the tab or group to rename.

2. Click the Rename button.
   The Rename dialog box appears.

3. Enter a name for the selected tab or group in the Display Name text box.
   The tab or group is renamed. For a group, also select a symbol to represent the group.

4. Click OK.
   The tab or group is renamed.

Exercise

- Exercise File: None required.
- Exercise: Create a new group on the Home tab called “Printing” and include the command to Print Preview and Print.
  Restore the Ribbon defaults.
Customizing Excel

Add a command to a group

Once a new tab or group is created, add commands to the group. Also add commands to groups that already appear on the Ribbon.

1. In the right column, select the group to which to add a command to.
   This could be a group created from scratch, or even a group that appears by default.

2. In the left column, select the command to add to the Ribbon. Click the Add button.
   The command is added to the group.

   Tip: Not finding the command to add? Click the Choose commands from list arrow and select the group of commands to view.

Restore the default Ribbon

If no longer wanting to use the customizations added to the Ribbon, restore the Ribbon to its original, default settings.

1. Click the Reset button.
   Two options appear:
   - Reset only selected Ribbon tab: Restores the default settings for the selected tab.
   - Reset all customization: Removes all Ribbon and Quick Access Toolbar customizations, restoring them to the default arrangement and appearance.

2. Select the reset option to use.
   The Ribbon is restored to its default settings.

Remove a tab or group

Remove a specific tab or group from the Ribbon.

1. In the right column, right-click the tab or group to use.

2. Select Remove from the contextual menu.
   The tab or group is removed from the Ribbon.

Tips

✓ Any changes made to a program’s Ribbon will appear only in that program.
✓ To hide a tab on the Ribbon, deselect its check box.
Customizing the Quick Access Toolbar

The Quick Access Toolbar is a shortcut for commands that are used often. If the Quick Access Toolbar doesn’t contain enough frequently used commands, customize it by adding or deleting commands.

1. Click the File tab and select Options. The Excel Options dialog box appears.

2. Click the Quick Access Toolbar tab. This tab displays options for customizing the Quick Access Toolbar.

3. In the left column, select the command to add to the Quick Access Toolbar.

4. Click the Add button. The command is added to the Quick Access Toolbar.

Tips

✓ Arrange the order in which the commands are displayed by clicking the Move Up and Move Down buttons to the right of the column.

✓ Click the Reset button and select Reset only Quick Access Toolbar to return the Quick Access Toolbar to its default commands.

✓ Select a command in the Quick Access Toolbar column and click the Remove button to remove it from the Quick Access Toolbar.

Exercise

• Exercise File: None required.

• Exercise: Add the Print Preview command from the Popular Commands group to the Quick Access Toolbar.

Move the Quick Access Toolbar below the Ribbon.

Figure 14-4: Adding a command to the Quick Access Toolbar.
Using and Customizing AutoCorrect

AutoCorrect automatically corrects many common typing and spelling errors as they are typed. It is also a great way to use shorthand for longer words, phrases, or symbols.

AutoCorrect is a feature that is shared across the Microsoft Office suite—so any additions or changes made to AutoCorrect in one program, such as Word, will appear in all Microsoft Office programs, like Excel, Excel, and Outlook.

**How AutoCorrect works**

Sometimes typos are corrected as text is entered in Word. When typing an AutoCorrect entry and then pressing the <Spacebar>, AutoCorrect replaces that text with the correct text.

For example, AutoCorrect will change the mistyped words “hte” to “the”, or “adn” to “and”. AutoCorrect also corrects simple grammar mistakes, such as capitalization problems. For example, it would change “GOing” to “Going,” or capitalize the first letter in sentences.

**Create an AutoCorrect entry**

Excel already has many entries in AutoCorrect, but it allows adding entries to correct habitual misspellings, quickly insert a symbol, or insert a shorthand version of a long phrase frequently used.

1. Click the **File** tab and select **Options**.
   
   The Excel Options dialog box appears.

2. Click the **Proofing** tab.
   
   This tab displays options for how Excel corrects and formats text.

3. Click the **AutoCorrect Options** button.
   
   The AutoCorrect dialog box appears with the AutoCorrect tab in front.

4. Type the word or phrase to correct or use as shorthand in the **Replace** text box.
   
   This is the text that AutoCorrect will recognize when typed.

5. Type the word or phrase to appear in the **With** text box.
   
   When the text in the “Replace” text box is typed with a space, the text in the “With” text box will appear.

---

**Exercise**

- **Exercise File**: None required.

- **Exercise**: Create an AutoCorrect entry that replaces “ot” with “to”.

  Try the AutoCorrect entry with this phrase, “He was going ot the store.”

```plaintext
He was going ot |  Press <Spacebar>

He was going to |
```

**Figure 14-5**: An example of how AutoCorrect works.

**Figure 14-6**: The AutoCorrect tab of the AutoCorrect dialog box.
6. Click **Add**.
   
   The entry is added to the AutoCorrect list.

7. Click **OK** to close the AutoCorrect dialog box. Click **OK** to close the Excel Options dialog box.
   
   The dialog boxes close and the entry will now be available in all Excel workbooks, and also in all other Office applications.
Changing Excel’s Default Options

Microsoft spent a lot of time and research when it decided what the default settings for Excel should be. However, the default settings may not always fit the user’s needs.

This lesson isn’t so much an exercise as it is a reference on how to customize Excel by changing its default settings.

1. Click the File tab and select Options.
   The Excel Options dialog box appears.

2. Click the tabs on the left to view different option categories.
   See Table 14-1: Tabs in the Excel Options Dialog Box, for more information on these categories.

3. Change the options as desired. Click OK to confirm the changes.
   The changes are applied to the Excel program.

Exercise

- Exercise File: None required.
- Exercise: Explore the tabs in the Excel Options dialog box.

Table 14-1: Tabs in the Excel Options Dialog Box

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Change the most commonly modified options in Excel. This includes enabling</td>
</tr>
<tr>
<td></td>
<td>the Mini Toolbar and Live Preview. Also, change the color scheme, control</td>
</tr>
<tr>
<td></td>
<td>ScreenTips, and change the user name.</td>
</tr>
<tr>
<td>Formulas</td>
<td>Change options related to formula calculation, performance, and error</td>
</tr>
<tr>
<td></td>
<td>handling.</td>
</tr>
<tr>
<td>Proofing</td>
<td>Change how Excel corrects and formats text. Change the types of errors that</td>
</tr>
<tr>
<td></td>
<td>Excel flags when looking for spelling and grammar errors.</td>
</tr>
<tr>
<td>Save</td>
<td>Customize how workbooks are saved, such as how often AutoRecover saves a</td>
</tr>
<tr>
<td></td>
<td>workbook, and change default file locations.</td>
</tr>
<tr>
<td>Language</td>
<td>Add additional languages to edit documents. Also set the language priority</td>
</tr>
<tr>
<td></td>
<td>order for added languages.</td>
</tr>
<tr>
<td>Advanced</td>
<td>Advanced options for working with Excel. Change how Excel works when editing</td>
</tr>
<tr>
<td></td>
<td>text; modify how cut, copy, and paste commands operate; customize tools in</td>
</tr>
<tr>
<td></td>
<td>the window, such as how it displays screen tips and scroll bars; adjust how</td>
</tr>
<tr>
<td></td>
<td>Slide Show view looks and operates; control how the workbook is printed;</td>
</tr>
<tr>
<td></td>
<td>choose advanced save options; and control various Web options.</td>
</tr>
<tr>
<td>Customize</td>
<td>Create custom tabs and groups for the Ribbon.</td>
</tr>
<tr>
<td>Ribbon</td>
<td></td>
</tr>
<tr>
<td>Quick Access Toolbar</td>
<td>Add commands to the Quick Access Toolbar.</td>
</tr>
<tr>
<td>Add-Ins</td>
<td>View and manage Microsoft Office add-ins, such Acrobat PDFMaker and custom</td>
</tr>
<tr>
<td></td>
<td>XML data.</td>
</tr>
<tr>
<td>Trust Center</td>
<td>Help keep workbooks safe and the computer secure and healthy. Read privacy</td>
</tr>
<tr>
<td></td>
<td>statements and change Trust Center Settings to control how Excel works with</td>
</tr>
<tr>
<td></td>
<td>macros, add-ins, the message bar, trusted publishers and locations, and more.</td>
</tr>
</tbody>
</table>

Figure 14-7: The Formulas tab of the Excel Options dialog box.
Creating a Custom AutoFill List

Excel’s AutoFill feature is the nifty function that automatically enters a series of values. If typing the same list of words frequently, a good idea is to save a lot of time by creating a custom AutoFill list. Once a custom AutoFill list is created, the one thing left to do is type the first entry of the list in a cell, and use AutoFill to have Excel complete the rest of the list.

Create a custom AutoFill list

1. Click the File tab on the Ribbon and select Options.
2. Click the Advanced tab and scroll down to the General section. Click the Edit Custom Lists button.
   
   The Custom Lists dialog box appears.
3. Select New List under the Custom lists section.
4. Type the first entry to include in the AutoFill list and press <Enter>. Repeat for each entry of the list.
   
   Other Ways to Enter Custom List Entries:
   
   Select the cell range that contains the information to include in the custom AutoFill list. Then open the Custom Lists dialog box. Click Import.
5. Click Add.
   
   The custom list is added to the dialog box.
6. Click OK, OK.

Use a custom AutoFill list

Using a custom AutoFill list is just like completing any other series with AutoFill.

1. Click the cell where to begin the custom fill series in.
2. Type an item from the series.
3. Click and drag the cell’s fill handle to complete the series in the cells selected.

Exercise

- **Exercise File:** CustomizingExcel.xlsx
- **Exercise:** Use the data in A1:A10 to create a custom AutoFill list.
  
  Try using the AutoFill list in the worksheet.
Creating a Custom Number Format

A previous lesson in this chapter already covered how to format values (numbers). Excel comes with a huge number of predefined number formats to use. With so many available number formats, it is unlikely that a custom number format will ever need to be created, but if it does, here’s a brief overview.

1. Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Number group.

2. Click Custom in the Category box.

   This is where to modify a copy of an existing format code to meet the specifications. A custom number format is created by specifying format codes that describe how to display a number, date, time, or text. Table 14-2: Format Codes for Numbers and Dates, gives some examples of how to use these codes when creating custom number formats.

   Tip: The sample area of the number dialog box becomes very important when creating custom number formats. Watch the sample area carefully to see how the custom number format

3. In the Type list, select a number format that to customize.

   The number format appears in the Type box.

4. Make changes to the number format in the Type box using the format codes shown in the Table 14-2: Format Codes for Numbers and Dates.

<table>
<thead>
<tr>
<th>Numbers</th>
<th>Dates and Times</th>
</tr>
</thead>
<tbody>
<tr>
<td>To Display</td>
<td>Use this Code</td>
</tr>
<tr>
<td>1234.59 as 1234.6</td>
<td>####.#</td>
</tr>
<tr>
<td>12499 as 12,499</td>
<td>.###</td>
</tr>
<tr>
<td>12499 as 12,499.00</td>
<td>#,####.##</td>
</tr>
<tr>
<td>1489 as $1,489.00</td>
<td>$#,###.##</td>
</tr>
<tr>
<td>.5 as 50%</td>
<td>0%</td>
</tr>
<tr>
<td>.055 as 5.5%</td>
<td>0.0%</td>
</tr>
<tr>
<td>Hide value</td>
<td>;;</td>
</tr>
</tbody>
</table>

Figure 14-9: Creating a custom number format.

Exercise

• Exercise File: CustomizingExcel.xlsx
• Exercise: Select cell C1 and create this custom number format: ##-###
Customizing Excel Review

Quiz Questions

1. It's only possible to add custom groups to custom tabs. (True or False?)

2. What is the purpose of the Quick Access Toolbar?
   A. To provide quick access to the commands used most frequently.
   B. To make Excel 2013 look more like previous versions.
   C. To provide Microsoft Access commands in the Excel program.
   D. To provide a backup in case the Ribbon fails

3. AutoCorrect changes:
   A. Spelling errors
   B. Grammar errors
   C. Capitalization errors
   D. All of these.

4. AutoCorrect entries created in Excel will not appear in any other programs. (True or False?)

5. Which of the following is NOT a tab in the Excel Options dialog box?
   A. Proofing, which changes how Excel corrects text.
   B. Display, which changes how content appears on the screen.
   C. General, which lists the most commonly modified options in Excel.
   D. Trust Center, which changes the privacy options.

6. Which of the following is NOT an example of information that could be used in an AutoFill list?
   A. Since it's possible to create AutoFill lists, use any of this information in an AutoFill list.
   B. The names of the seven dwarves.
   C. A product list.
   D. A list of employees.

7. The United States decides to change the format of social security numbers. How can a custom number format be created for the new social security format?
   A. Click the Number tab on the Ribbon and click the Custom List button in the Number group. Select the Custom category and type the number format in the Type box.
   B. Buy and install the Custom Number Wizard Add-On for Microsoft Excel.
   C. Enter the number format in the Number Format list on the Formatting tab of the Ribbon.
   D. Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Number group. Select the Custom category and type the number format in the Type box.
Quiz Answers

1. False. Add custom groups to default tabs or to custom tabs.

2. A. The purpose of the Quick Access Toolbar is to provide quick access to the commands used most frequently.

3. D. AutoCorrect changes spelling errors, grammar errors, and capitalization errors.

4. False. AutoCorrect entries created in Excel will appear in all other Microsoft Office programs.

5. B. There is no Display tab in the Excel Options dialog box.

6. A. Since it's possible to create AutoFill lists, use any of this information in an AutoFill list.

7. D. To create a custom number format, click the Home tab on the Ribbon and click the Dialog Box Launcher in the Number group. Select the Custom category and type the number format in the Type box.